Results 1 to 6 of 6

Thread: [ASK] Problem installing DeSmuME 0.9.6 from sources

  1. #1
    Join Date
    Dec 2010
    Location
    Bali, Indonesia
    Posts
    19

    Default [ASK] Problem installing DeSmuME 0.9.6 from sources

    Heloo everyone....
    Can anyone help me, coz I've problem while installing DeSmuME 0.9.6 from sources.
    When I tried to run "./configure" from Konsole, on last line, I got an error:

    Code:
    configure: error: zlib was not found, we can't go further. Please install it or specify the location where it's installed.
    I've installed zlib on my system. I've try "./configure --with-zlib:/lib" (I give /lib for the location, coz I don't know where is zlib real location) but still, same error occur. Can anyone help me with this problem.

    Thanks for u'r attention.
    NB: I'm really sorry for my poor English.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: [ASK] Problem installing DeSmuME 0.9.6 from sources

    Hi
    When compiling from source, you need to ensure you have the corresponding devel package installed eg zlib-devel.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Dec 2010
    Location
    Bali, Indonesia
    Posts
    19

    Default Re: [ASK] Problem installing DeSmuME 0.9.6 from sources

    Thanks malcommlewis. It's solved this problem, but now I've got another problem. When I try to run ./configure, @ last 2 line it's show an error:

    grep: po/Makefile.in: No such file or directory
    config.status: error: po/Makefile.in.in was not created by intltoolize.
    I've try to use touch to create Makefile.in file. But the error message:

    config.status: error: po/Makefile.in.in was not created by intltoolize.
    still appear. Can you help me to fix this problem??

    Thanks for the attention. And as usual sorry for my poor English.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: [ASK] Problem installing DeSmuME 0.9.6 from sources

    Quote Originally Posted by mardangga
    Thanks malcommlewis. It's solved this problem, but now I've got another
    problem. When I try to run ./configure, @ last 2 line it's show an
    error:

    > grep: po/Makefile.in: No such file or directory
    > config.status: error: po/Makefile.in.in was not created by
    > intltoolize.


    I've try to use *touch* to create Makefile.in file. But the error
    message:

    > config.status: error: po/Makefile.in.in was not created by
    > intltoolize.


    still appear. Can you help me to fix this problem??

    Thanks for the attention. And as usual sorry for my poor English.

    Hi
    Is there a file called autogen.sh? If so ensure you have automake and
    autoconf installed and then run the command;
    Code:
    autoreconf -af
    ../configure --prefix=/usr
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
    up 16 days 9:59, 3 users, load average: 0.15, 0.06, 0.01
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36


  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,529
    Blog Entries
    15

    Default Re: [ASK] Problem installing DeSmuME 0.9.6 from sources

    Quote Originally Posted by mardangga
    Thanks malcommlewis. It's solved this problem, but now I've got another
    problem. When I try to run ./configure, @ last 2 line it's show an
    error:

    > grep: po/Makefile.in: No such file or directory
    > config.status: error: po/Makefile.in.in was not created by
    > intltoolize.


    I've try to use *touch* to create Makefile.in file. But the error
    message:

    > config.status: error: po/Makefile.in.in was not created by
    > intltoolize.


    still appear. Can you help me to fix this problem??

    Thanks for the attention. And as usual sorry for my poor English.

    Hi
    Had a look at the source and I see the version has bumped to 0.9.7. It
    builds except there is a couple of errors so it won't pass OBS rpm
    checks. I have created rpms for 0.9.7 here under home:malcolmlewis:Testing
    http://software.opensuse.org/search?...ude_debug=true

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
    up 16 days 23:23, 4 users, load average: 0.55, 1.09, 0.90
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36


  6. #6

    Default Re: [ASK] Problem installing DeSmuME 0.9.6 from sources

    I had the same problem above, and followed you (thanks for that). When I got to the point

    >grep: po/Makefile.in: No such file or directory
    >config.status: error: po/Makefile.in.in was not created by intltoolize.

    but I typed ' autoconf -af ' and my pc said:

    >/usr/bin/autoreconf: unrecognized option `-af'
    >Try `/usr/bin/autoreconf --help' for more information.

    I searched in the help but had no answer. What else should I do?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •