Results 1 to 3 of 3

Thread: KDE Desktop Effects Cannot Revert to openGL

  1. #1

    Default KDE Desktop Effects Cannot Revert to openGL

    Last night I was playing around with Desktop Effects and set the composting engine to Xrender, it was openGL. And things started to slow down tremendously. There is now lag on Alt+F1, lag when mousing over hidden taskbar, lag when moving windows, etc. I was trying to get rid of a trail of images when moving windows around. I created more problems.
    Things got even better when I tried to change back to openGL:

    "Failed to activate desktop effects using the given configuration options. Setting will be reverted back to previous values. Check your X configuration. You may also consider changing advancde options, especially changing the composting type."

    The same thing happens when I click on "Default", the default options disable desktop effects.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  2. #2

    Default Re: KDE Desktop Effects Cannot Revert to openGL

    Can't edit the post.
    nouveau drivers, booting with nomodeset option enabled.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

  3. #3

    Default Re: KDE Desktop Effects Cannot Revert to openGL

    This pushed me over the edge and I went ahead and installed Nvidia, the trails went away, I can switch to openGL and all the lag is gone.
    Vaio F11: i7-720QM 8GB RAM Nvidia GT 330m
    Win 7 Pro 64 bit | openSuse 11.4 64 bit | Arch Linux 64 bit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •