Results 1 to 6 of 6

Thread: want to try fvwm2 on 11.2

  1. #1

    Default want to try fvwm2 on 11.2

    So I did a fresh install with no gnome, kde, or xfce. Then I logged in and ran the startx command. The X display just showed a blank purple screen with no mouse cursor and no response to keyboard or mouse. That suggests to me that I need some packages that the install scripts didn't bring in with the fvwm2 package. Can anyone tell me if this is just a problem of missing packages and what those packages are?

  2. #2

    Default Re: want to try fvwm2 on 11.2


    This is 11.3. But I use to have it in 11.2 too.
    You just need to install fvwm2:
    Code:
    zypper in fvwm2

  3. #3

    Default Re: want to try fvwm2 on 11.2

    Oooops ! That wasn't actually your question. Hmmm ... only fvwm2 and purple screen...
    What about graphics card and driver?

    Code:
    hwinfo --gfxcard

  4. #4

    Default Re: want to try fvwm2 on 11.2

    Previously installed with KDE, gnone and xfce. All of those worked so Occam's razor says my graphics card is good and there is a good X driver to be found .... somewhere.

    Maybe this will help someone assist me with the fvwm2 PD. .xsession-errors is below. Looks to me that the driver is not there for fvwm2. If I am correct, what "magic" was missing for it not to be installed automatically? What is the "fastpath" to install it manually?

    xauth: creating new authority file /root/.serverauth.2187


    X.Org X Server 1.6.5
    Release Date: 2009-10-11
    X Protocol Version 11, Revision 0
    Build Operating System: openSUSE SUSE LINUX
    Current Operating System: Linux linux-xgps 2.6.31.5-0.1-default #1 SMP 2009-10-26 15:49:03 +0100 i686
    Build Date: 02 November 2009 12:05:39PM

    Before reporting problems, check X.Org Wiki - Home
    to make sure that you have the latest version.
    Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 28 20:54:10 2011
    (==) Using default built-in configuration (48 lines)
    (EE) Failed to load module "fglrx" (module does not exist, 0)
    (EE) open /dev/fb0: No such file or directory
    FATAL: Module mach64 not found.
    (EE) [drm] drmOpen failed.
    (EE) MACH64(0): [dri] DRIScreenInit Failed
    /etc/X11/xim: Checking whether an input method should be started.
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Dummy input method "none" (do not use any fancy input method by default)

  5. #5

    Default Re: want to try fvwm2 on 11.2

    Quote Originally Posted by nospam990 View Post
    Maybe this will help someone assist me with the fvwm2 PD. .xsession-errors is below. Looks to me that the driver is not there for fvwm2. If I am correct, what "magic" was missing for it not to be installed automatically? What is the "fastpath" to install it manually?
    Indeed, it looks like the Xorg video driver wasn't installed for some reason.

    Quote Originally Posted by nospam990 View Post
    (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jan 28 20:54:10 2011
    (==) Using default built-in configuration (48 lines)
    (EE) Failed to load module "fglrx" (module does not exist, 0)
    (EE) open /dev/fb0: No such file or directory
    FATAL: Module mach64 not found.
    (EE) [drm] drmOpen failed.
    (EE) MACH64(0): [dri] DRIScreenInit Failed
    /etc/X11/xim: Checking whether an input method should be started.
    sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
    INPUT_METHOD is not set or empty (no user selected input method).
    Trying to start a default input method for the locale en_US.UTF-8 ...
    There is no default input method for the current locale.
    Dummy input method "none" (do not use any fancy input method by default)
    fglrx is an ATI proprietary driver for different models of ATI cards.. mach64 is an old open source driver for ATI Mach based video cards, which is part of the xorg-x11-driver-video package - which HAS to be installed!

    We need to know the model of your graphic card to be able to tell you precisely which video driver you need to install. So boot your computer in text mode (append a "3" to the options line at the bottom of the Grub screen) and type the command:

    Code:
    hwinfo --gfxcard
    Unfortunately the title of your thread is misleading and I guess that's why you didn't receive an answer earlier. The problem has very little to do with fvwm2 ... except that it seems that the driver wasn't installed or isn't used with this type of minimal installation, which looks like a bug to me.

    Please also post the output of the two following commands:

    Code:
    rpm -qa | grep video
    zypper lr
    Since you did a fresh install, why did you install 11.2 rather than 11.3?

  6. #6

    Default Re: want to try fvwm2 on 11.2

    Sorry for delay. Other projects interfered. Output of hwinfo, rpm, and zypper are the same on both my kde install where X works and my fvwm install where it doesn't. Occam's razor suggests to me that some configuration file is missing info on the fvwm install.

    linux-e087:~ # hwinfo --gfxcard
    18: PCI 09.0: 0300 VGA compatible controller (VGA)
    [Created at pci.318]
    UDI: /org/freedesktop/Hal/devices/pci_1002_474d
    Unique ID: WL76.4PSspk9x+Z9
    SysFS ID: /devices/pci0000:00/0000:00:09.0
    SysFS BusID: 0000:00:09.0
    Hardware Class: graphics card
    Model: "ATI Xpert 98 RXL AGP 2X"
    Vendor: pci 0x1002 "ATI Technologies Inc"
    Device: pci 0x474d "Rage XL AGP"
    SubVendor: pci 0x1002 "ATI Technologies Inc"
    SubDevice: pci 0x0008 "Xpert 98 RXL AGP 2X"
    Revision: 0x65
    Memory Range: 0xe2000000-0xe2ffffff (rw,non-prefetchable)
    I/O Ports: 0xa400-0xa4ff (rw)
    Memory Range: 0xe1800000-0xe1800fff (rw,non-prefetchable)
    Memory Range: 0x28000000-0x2801ffff (ro,prefetchable,disabled)
    IRQ: 9 (52 events)
    I/O Ports: 0x3c0-0x3df (rw)
    Module Alias: "pci:v00001002d0000474Dsv00001002sd00000008bc03sc00i00"
    Driver Info #0:
    XFree86 v4 Server Module: ati
    Color Depths: 8, 16, 24
    Extensions:
    Options:
    Config Status: cfg=no, avail=yes, need=no, active=unknown

    Primary display adapter: #18

    linux-e087:~ # rpm -qa | grep video
    xorg-x11-driver-video-7.4-87.88.1.i586
    xorg-x11-driver-video-radeonhd-1.3.0_20091026_8b89b9-1.1.1.i586

    linux-e087:~ # zypper lr
    # | Alias | Name | Enabled | Refresh
    --+-------------------------------+-------------------------------+---------+--------
    1 | openSUSE_11.2-0 | openSUSE 11.2-0 | Yes | No

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •