Results 1 to 10 of 10

Thread: Gnomenu problem

  1. #1

    Default Gnomenu problem

    I installed Gnomenu 2.9 from this repo and ad it to the gnome-panel. Everything worked great until I started to try out some themes. Now the menu wont show up but I can configure the gnomenu?

    I also tried gnomenu 2.8 from this repo but the problem was the same.

    Any help on this is really appreciated.

    Edit: JUst found out that the menu shows if I set the gnome-panel to "top" instead of bottom. The Gnomenu icon is upside down, but at least the menu shows when I click the icon. Maybe it is something in my compiz or emerald settings that blocks the menu from showing?

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Gnomenu problem

    Hi
    Uninstall any version that you have installed first, I've updated my repo for the 2.9 version (might take a little while to sync though) and install that one. Can you confirm if your system is 32 or 64bit as well.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Gnomenu problem

    Hi

    I removed previous version and repository, then installed version 2.9 from your repository. After a reboot I enabled Gnomenu again but the problem is the same. When using gnome-panel on top position it works, but not standard position at bottom of the screen. I run 32-bit system of openSUSE 11.3

    Appreciate your contribution with the repository and any help. Will check if there is any compiz effect that blocks the menu from showing. Also to point out, you seem to forgot to add the suse icons to Gnomenu? suse and bluesuse icons are not there.

  4. #4

    Default Re: Gnomenu problem

    I disabled the effects and the gnomenu works. Will look more into it.

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Gnomenu problem

    Hi
    I done a few updates, mainly for the 64bit version. I've added an openSUSE button theme as a test, can you look at this? Or perhaps a suggestion for a different icon?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: Gnomenu problem

    I don't know why but for some reason your build of Gnomenu isn't working that good or you forgot to update it correctly? I don't have all the themes and buttons that Gnomenu from the XND repo has and your build is a bit unstable. If I change a theme all my settings in Gnomenu are also lost. It's like Gnomenu resets its configurations after restarting the applet. If you try the version from XND you will see there are a nice buttons for openSUSE and the Win7 theme is also there.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Gnomenu problem

    Quote Originally Posted by Joakim W
    I don't know why but for some reason your build of Gnomenu isn't working
    that good or you forgot to update it correctly? I don't have all the
    themes and buttons that Gnomenu from the 'XND repo'
    (http://download.opensuse.org/reposit...openSUSE_11.3/) has
    and it's a bit unstable. If I change a theme all my settings in Gnomenu
    are also lost. It's like Gnomenu resets its configurations after
    restarting the applet. If you try the version from XND you will see
    there are a nice buttons for openSUSE and the Win7 theme is also there.

    Hi
    That package has been customized and differs from the original source
    (I personally wouldn't use it). The correct way for that is for that
    user to package up/identify etc....

    Here is the spec file;
    https://build.opensuse.org/package/v...02c65d518c95fb

    So what's not working on the version I have built. If you start it from the command line and test;
    Code:
    GnoMenu.py run-in-window
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
    up 8 days 8:40, 2 users, load average: 0.04, 0.09, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36


  8. #8

    Default Re: Gnomenu problem

    I found the openSUSE logo you added and it's ok, but I highly recommend to use this ones at deviantart

    Here is the output message I get

    Code:
    gconf backend
    GnoMenu 2.9
    settings load
    gmenu found, using it as default menu parser
    map
    start
    shaping window
    /usr/lib/gnomenu/Menu_Main.py:267: DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use PyArray_NewFromDescr.
      for row in self.colorpb.get_pixels_array():
    Error reading web bookmarks
    Using own key method - binding
    position changed
    X protocol error:
    <class 'Xlib.error.BadAccess'>: code = 10, resource_id = 469, sequence_number = 7, major_opcode = 33, minor_opcode = 0
    When testing and then closing the menu I get this error

    Code:
    (GnoMenu.py:8344): Bonobo-WARNING **: Never got frame, control died - abnormal exit condition
    show
    /usr/lib/gnomenu/cairo_drawing.py:91: DeprecationWarning: PyArray_FromDimsAndDataAndDescr: use PyArray_NewFromDescr.
      for row in colorpb.get_pixels_array():
    focus lost
    hide
    show
    focus lost
    hide
    show
    focus lost
    hide
    cleanup
    Fatal Python error: PyEval_RestoreThread: NULL tstate
    1f4818b3-9c54-1b84-0ba6496d-6f14b3d4 is dumped
    
    ** (bug-buddy:8672): WARNING **: Couldn't load /etc/xdg/autostart/ksmolt-autostart.desktop: Invalid key name: X-KDE-autostart-condition[$e
    I will use your build and happy to help out with testing it.

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,673
    Blog Entries
    15

    Default Re: Gnomenu problem

    Hi
    OK, I've added the SuSEOrb Button only at this point (not sure of the windows 7 one or if it's a potential copyright issue). I've also updated the requires, so see if that helps.

    The three files are;
    gnomenu, gnomenu-lang and gnomenu-opensuse-branding

    See how this one goes with the previous command.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: Gnomenu problem

    I did some further testing of Gnomenu and compared performance with other menus. Decided to go for the "Menu bar" applet for now which performs good. Thanks for showing interest to help out with the problem I had from the start and good luck with future builds of Gnomenu.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •