Results 1 to 5 of 5

Thread: Error : `GLIBCXX_3.4.14' not found

  1. #1
    Join Date
    Jan 2011
    Location
    United States
    Posts
    2

    Default Error : `GLIBCXX_3.4.14' not found

    Hello,
    Recently I installed gcc-4.3.4 on my suse 11.3( I had to install it because matlab mex compiler was supported uptill gcc-4.3.4. ). It took me several mins to compile the source and installing took another hour.

    Now, the problem which I'm facing is as follows:
    1. can't open install/remove software, zypper, openoffice, firefox .. and many other applications.

    zypper: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by zypper)
    zypper: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by zypper)
    zypper: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libzypp.so.706)
    zypper: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/libzypp.so.706)
    ".

    2. and once i restart my computer, I can no longer use Nautilus (I'm using gnome) and if i launch it from command line, it says the same problem
    (
    nautilus: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /usr/lib/libexempi.so.3)
    nautilus: /usr/local/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by /usr/lib/libexempi.so.3)
    ).

    Thanks in advance.

    -
    Aneesh

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Error : `GLIBCXX_3.4.14' not found

    Hi
    Your setting your LD Library path to /usr/local/lib? Anyway, it's looking there instead of /usr/lib for the files...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jan 2011
    Location
    United States
    Posts
    2

    Default Re: Error : `GLIBCXX_3.4.14' not found

    Thanks @malcolmlewis,

    Changing path of LD_LIBRARY_PATH worked

    export LD_LIBRARY_PATH=/usr/lib:$LD_LIBRARY_PATH
    But still some program like Nautilus, open-office is giving some weird error
    (nautilus:13716): Eel-WARNING **: GConf error:
    Failed to contact configuration server; some possible causes are that you need to enable TCP/IP networking for ORBit, or you have stale NFS locks due to a system crash. See GConf configuration system for information. (Details - 1: Failed to get connection to session: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.)
    But still somehow it manages to start.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,890
    Blog Entries
    15

    Default Re: Error : `GLIBCXX_3.4.14' not found

    Hi
    You should have added the configure option --prefix=/usr then it would have installed in the normal paths. Unset the LD PATH statement you added, then logout/login and try try running (as root user eg su -)
    Code:
    /sbin/ldconfig
    Else I would uninstall, export the cflags and cxxflags to use 4.3 and then rerun the configure/make etc.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Error : `GLIBCXX_3.4.14' not found

    Quote Originally Posted by aneeshfsu View Post
    Recently I installed gcc-4.3.4 on my suse 11.3( I had to install it because matlab mex compiler was supported uptill gcc-4.3.4. ). It took me several mins to compile the source and installing took another hour.
    Code:
    $ zypper se -s gcc43
    Loading repository data...
    Reading installed packages...
    
    S | Name                | Type    | Version            | Arch   | Repository   
    --+---------------------+---------+--------------------+--------+--------------
      | gcc43               | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43               | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-32bit         | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-ada           | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-ada           | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-c++           | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-c++           | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-fortran       | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-fortran       | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-fortran-32bit | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-gij           | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-gij           | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-gij-32bit     | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-info          | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-info          | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-java          | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-java          | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-locale        | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-locale        | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-obj-c++       | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-obj-c++       | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-objc          | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-objc          | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3
      | gcc43-objc-32bit    | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-testresults   | package | 4.3.4_20091019-3.1 | x86_64 | openSUSE 11.3
      | gcc43-testresults   | package | 4.3.4_20091019-3.1 | i586   | openSUSE 11.3

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •