Is there any way to run KDE 4.6 RC2 (4.5.95) and KDEPim 4.6 beta 3(4.5.85) together?

For example kmail-4.5.86 (from KDE:/Unstable:/SC/openSUSE_11.3) requires KDE >= 4.6.0 and that means I have to install kde 4.6.40 (which is the only version >= 4.6.0).