Results 1 to 8 of 8

Thread: Stopping the Screen Saver and stopping the screen locking

  1. #1

    Default Stopping the Screen Saver and stopping the screen locking

    In December I finally filled up my root partition and broke Suse 11.1. I therefore resized my partitions and installed Suse 11.3 on /root. I didn't not touch my /home partition.

    I notice that when I leave my machine and come back the screen has locked. I have tried to turn off the screensaver, but it hasn't worked. I have Googled, but unfortunately the screen shots don't look like what I have and the instructions to stop this do not seem to match what I am seeing on the screen.

    Is there a way to do this via the command line?

    I am happy to provide any information to sort this out.

    Thank you.

    Regards

    Nappy501

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Stopping the Screen Saver and stopping the screen locking

    What desktop environment are you using? (e.g. KDE or GNOME)
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3

    Default Re: Stopping the Screen Saver and stopping the screen locking

    Sorry, should have said. I believe it is KDE 4. When I used Suse 11.1 it was KDE3.

    Regards

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Stopping the Screen Saver and stopping the screen locking

    You should be able to configure screensaver settings under Configure Desktop -> Desktop -> Screensaver
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Stopping the Screen Saver and stopping the screen locking

    ah7013 wrote:
    > You should be able to configure screensaver settings under Configure
    > Desktop -> Desktop -> Screensaver


    unfortunately there are more things going on that just a screen
    saver...see this thread http://forum.kde.org/viewtopic.php?f=66&t=35085

    read it all...

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  6. #6

    Default Re: Stopping the Screen Saver and stopping the screen locking

    Right I went onto Kicker > system settings > Desktop > Screensaver. See here:
    screenlock | Flickr - Photo Sharing!

    I went away and it was fine. I went away for a bit longer and I was just coming to ask if I could have the screen saver without it locking and the screen was locked. It was black, when I moved the mouse the little window was there asking me enter my user password.

    So it was longer than 2 minutes, before it locked. What am I missing?

    Regards

  7. #7

    Default Re: Stopping the Screen Saver and stopping the screen locking

    Well, what a palaver.

    So here is what I did:
    Kickoff > System settings > Desktop > Screen Saver, then under settings uncheck 'Require password to stop.
    Then:
    Kickoff > System settings, click on the Advanced tab > Power Management > General settings, uncheck 'Lock screen on resume'
    Then on the left hand side click on 'Edit Profiles' then Powersave. None of the drop down tabs have 'lock screen'

    Then click on Performance. None of the drop down tabs have 'lock screen'.

    I am not sure what all the settings should be here and I presume they would be different if you are using a laptop.

    Thank you for your assistance.

    Regards

    Nappy501

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,743

    Default Re: Stopping the Screen Saver and stopping the screen locking

    This may be due to old kde3 settings. Create a new user and see the the problem is also seen for the new user. If not rename the ~./kde and ~/kde4 directory and res do your desktop settings.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •