Results 1 to 8 of 8

Thread: Frustration not able to download packages

  1. #1

    Default Frustration not able to download packages

    I have been wading through so many different webpages on how things work my head is spinning and trying to decipher tech talk is also doing my head in. Quite simply at the moment I am trying to download applications and I always have to abort. I have a script saying that there is a wrapper problem. I deleted all the repro's and reinstalled all of them back again. Even when the repro's were empty it still gave me a warning
    There was an error in the repository initialization.
    Error refreshing service Wrapped
    (http://repos.opensuse-community.org/...wrapped.repo):
    Then when I do get the YaSt2 open and start downloading I can't. I have to confess I am doing what I did last time I tried Linux and spent more time sorting out than working on it. So I have always dumped it in the end as I want to work on the computer.
    Subprocess failed. Error: RPM failed: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "libc.so.6()(64bit)" records from Requirename index
    Subprocess failed. Error: RPM failed: error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) setting "libc.so.6()(64bit)" records from Requirename index
    error: db3 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: error(-30987) getting "libc.so.6()(64bit)" records from Requirename index
    I hope to sort this out soon

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,564
    Blog Entries
    38

    Default Re: Frustration not able to download packages

    I recommend new users always limit their repositories to only these 4 :
    • OSS
    • Non-OSS
    • update
    • packman

    Just those 4. No others.

    Reading your post I am speculating you could have one of two problems. Possibly you need to boot with IPV6 disabled (in which case this boot code in the options line of the very first grub boot menu will do that):
    Code:
    ipv6.disable=1
    ... and another possibility is your rpm database is corrupted. If so, there is guidance here on how to repair it: Repair an RPM database safely where after doing the backups that web page recommends as necessary, the command (as root) is:
    Code:
    rpm -vv --rebuilddb
    and then sit back and pray it works.

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Frustration not able to download packages

    On 01/23/2011 09:36 PM, oldcpu wrote:
    > and then sit back and pray it works.


    very very good advice from oldcpu...to which i want to add:

    maybe the head spinning is caused more by expecting this system to
    behave exactly like some other used previously...or, maybe because of
    just trying different things rather than trying to find the VAST
    documentation available..

    and, then there is that 'patience' thing--i mention this becuase the
    OP mentioned when using YaST "I always have to abort" .... which is
    the very easiest way i know to corrupt the RPM data base and ensure a
    snarl in the middle of the pathway to happiness..

    it takes more time to learn how to do it right....and, it take more
    time to wait for YaST to complete (rather than force an abort)...but,
    in the end the pathway to happiness is clear and one can quickly arrive..

    i say all of that because i installed 11.3/KDE on a virgin hard drive
    and after finding and adjust the volume i now have (*easily* and
    quickly) an almost full up machine with sound, mike, skype,
    google-earth....there are a few little problems i can probably live
    with..

    like, the dang web cam doesn't work and i'm scheduled to do a live
    strip tease here in about an hour...sigh ;-)

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 11.3, KDE4.4.4
    release 3, Thunderbird3.0.11,]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,822
    Blog Entries
    15

    Default Re: Frustration not able to download packages

    Quote Originally Posted by DenverD
    i say all of that because i installed 11.3/KDE on a virgin hard drive
    and after finding and adjust the volume i now have (*easily* and
    quickly) an almost full up machine with sound, mike, skype,
    google-earth....there are a few little problems i can probably live
    with..

    [posted via NNTP w/openSUSE 11.3, KDE4.4.4 release 3, Thunderbird3.0.11,]
    Hey DenverD, look at you running 11.3 AND KDE4!!!

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.27-0.2-default
    up 6 days 0:39, 2 users, load average: 0.00, 0.05, 0.06
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.36


  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: Frustration not able to download packages

    This is so OT, but yeah - DenverD running a current system made me fall off my chair! Congrats! :-)

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Frustration not able to download packages

    Quote Originally Posted by DenverD View Post
    i say all of that because i installed 11.3/KDE...
    First I thought I had fallen asleep, but then it slowly dawned that you may have really installed 11.3 and multimedia... BUT WAIT, I could be dreaming...
    like, the dang web cam doesn't work and i'm scheduled to do a live
    strip tease here in about an hour...sigh ;-)
    No, not dreaming. Having a nightmare!... BUT WAIT, he did say "dang web cam doesn't work". Phew, that's ok. At least we won't see the spectacle on wikileaks.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Frustration not able to download packages

    i know you are just pretending to not wanna see my slow, sensuous strip!

    maybe you will dream it tonight....sleep well..

    heh, maybe there is a nightmare headed your way, bud!!

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 11.3, KDE4.4.4
    release 3, Thunderbird3.0.11,]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8

    Default Re: Frustration not able to download packages

    Thanks all info is graciuosly recieved. I have had another problem and I have now reloaded. Packages will be kept to a minimum and I still have the other problems to resolve. Thanks guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •