Results 1 to 3 of 3

Thread: (not) automounting disks

  1. #1

    Question (not) automounting disks

    I'm running opensuse 11.2 with gnome. When I plug in a USB disk. It automatically mounts those partitions that it recognizes. I'd rather it didn't. It creates icons on the desktop although I've managed to stop it opening a file manager window for each partition.

    But how do I stop the mounting altogether? I've looked in the menus, yast, gnome control centre and sysconfig editor but haven't found anything. And google hasn't given me any clues.

    Ideally I think I'd like it to ask me whether to mount or not, but failing that I'd like it not to mount at all.

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: (not) automounting disks

    djh-novell wrote:
    > Ideally I think I'd like it to ask me whether to mount or not, but
    > failing that I'd like it not to mount at all.


    i'm not a Gnome user, but i _think_ when one first plugs in a USB
    device (say a hard disk) the system will "see" it and offer a list of
    things that can be done with that device....for example if it is a
    disk or memory stick you might be offered to "Open in a new window",
    or if it is a camera (or jpeg holding memory stick) it might offer to
    "Download Photos with digiKam"..

    AND, on that same pop-up offering your options, is a little box which
    says (on my machine) "Always do this for this type of media." so, it
    sounds like you (or someone else) checked that box in the past and
    told HAL [Hardware Abstraction Layer] to always "open in a new window"..

    i don't know the easy way to make it UNremember what you (or someone)
    told it to "Always do"...but, if you have anything different that you
    (or someone) has not told it to remember what to do, THEN the first
    time that new thing is plugged in you too will get that list of stuff
    pop-up, and _maybe_ while on your screen you will see a "Configure"
    button or a menu list, and you can figure out how to make it forget
    what it has been told to do, "Always"..

    then, every time you plug in that unremembered type of appliance again
    it will ask you what to do..

    be sure and tell all others using your manchine to not tell HAL to
    remember something you don't want it to remember, "Always"....

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]
    Be it ever so humble, there is no place like 127.0.0.1.

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: (not) automounting disks

    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •