Results 1 to 9 of 9

Thread: big problem on networkmanager

  1. #1

    Default big problem on networkmanager

    on my dell latitude e6510 opensuse 11.3 kde 4.4.4 with tri boot windows
    7 and two suse
    if boot with windows7 and I connect to internet by wired eth0 and then
    reboot in opensuse, networkmanager doesn't find my networkboard eth0 but
    only wireless, I have to reboot, enter in bios setup, exit, reboot, and
    then opensuse find my eth0, I tried with gnome too but is the same, wich
    kind of problem could be this??

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,584
    Blog Entries
    1

    Default Re: big problem on networkmanager

    I remember similar behaviour being reported previously (with other makes and models). From memory, the solution involved navigating to the NIC device propeties > 'Power Management' tab, and disabling 'Allow the computer to turn off this device to save power' (or similar). I know other users have mentioned BIOS settings that can be adjusted to do the same.

    Maybe someone can confirm this, or offer more detailed advice...
    Last edited by deano_ferrari; 15-Dec-2010 at 02:44.

  3. #3
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,905

    Default Re: big problem on networkmanager

    Sometimes Windows leaves some device in a state that cannot be used by another OS. Full power off power on will fix the problem. At least as a work around.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,584
    Blog Entries
    1

    Default Re: big problem on networkmanager

    Yes, that was another workaround required for some NIC hardware. I meant to clarify further, that the power management suggestion was with respect to Windows configuration, so that the NIC state was left 'Linux friendly'.

  5. #5

    Default Re: big problem on networkmanager

    Maaaany thanks, the full power off and on works, but I cannot find in windows7 the way to disable anything aout the NIC, I disabled almost everything in power management, the settings are quite hide in veritas, I found things about wireless but nothing about network board

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,905

    Default Re: big problem on networkmanager

    Yep Window is just great about such things. Though it may be the driver for the network card or the BIOS that is at fault. But something is leaving the card in a weird state and the BIOS is not doing a full hardware reset on it.

  7. #7
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: big problem on networkmanager

    You can got into network settings of the network card and under properties --->advanced there will be a whole host of changes that you can make to the card......the one thing that you can try and do is change the 'Power Management' to off. It is on most networking cards.

    Cheers!
    etech97

  8. #8

    Default Re: big problem on networkmanager

    FWIW I just ran into this issue after hibernating. I had been on battery power when I suspended to disk (don't know if that's relevant or not), then powered back up in my docking station.

    Viewing hardware information revealed that my nic uses 'modprobe e1000e' so for kicks I did 'rmmod e1000e' and then 'modprobe e1000e' again. The nic came back to life at that point.

    Hope this helps at least 1 person.

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    21,584
    Blog Entries
    1

    Default Re: big problem on networkmanager

    Yes, that can be a problem with certain network and graphics card hardware drivers , although a completely different issue to the OP's. You can automate the driver removal and loading via the use of suspend/resume (or hibernate/thaw) hooks as outlined here:

    SDB Pm-utils - openSUSE

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •