Results 1 to 9 of 9

Thread: Convenience and logging in

  1. #1

    Default Convenience and logging in

    When I first set up my computer I had it set to auto log me in (no
    lectures necessary. I know the risks and I'm not root!).

    My son needed to do some video editing so I set him up w/an account and
    turned off the autologin feature. I'm trying to turn it back on now,
    but it won't. I've gone into Configure Desktop, Advanced tab, Login
    Manager, entered the requisite root password, and clicked on the
    Convenience tab. Enable Auto-Login is checked, and my account is
    selected as the user. However when I power up the machine it always
    presents the login screen.

    I've also tried enabling the password-less login but that didn't make a
    difference.

    What am I missing?

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Convenience and logging in

    Maybe try setting it in YaST -> Security and Users -> User and Group Management -> Expert Options dropdown -> Login Settings?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Aug 2008
    Location
    Seattle, WA
    Posts
    1,376

    Default Re: Convenience and logging in

    Check the display manager settings in the /etc/sysconfig editor in YaST. In particular, look at DISPLAYMANAGER_AUTOLOGIN.

  4. #4
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Convenience and logging in

    Kevin Miller wrote:
    > What am I missing?


    wow, it sure sounds to me like you are doing it the right way...your
    problem sounds _very_ uncommon to me (though i have not googled it in
    our forum) so, i wonder which operating system, version and desktop
    environment and version you are using...

    i'm thinking maybe you have some 'factory' mixed into your setup, maybe??

    certainly, the system should be switchable back and forth (auto to not
    to auto)...so....well this is really strange..

    might you show us the output of entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

    What if there were no hypothetical questions?

  5. #5
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: Convenience and logging in

    On Mon, 17 Jan 2011 13:21:13 +0530, DenverD
    <DenverD@no-mx.forums.opensuse.org> wrote:

    > Kevin Miller wrote:
    >> What am I missing?

    >
    > wow, it sure sounds to me like you are doing it the right way...your
    > problem sounds _very_ uncommon to me (though i have not googled it in
    > our forum) so, i wonder which operating system, version and desktop
    > environment and version you are using...
    >
    > i'm thinking maybe you have some 'factory' mixed into your setup, maybe??



    i don't think so, that the OP has factory mixed in there. the same thing
    happened to me (while i wasn't on factory yet): changing autologin options
    in KDE systemsettings didn't affect the login behavior at all; only after
    changing the setting under YAST / user management did i get my KDE login
    screen back (after i forgot to disable auto-login during installation).

    > certainly, the system should be switchable back and forth (auto to not
    > to auto)...so....well this is really strange..


    it is, but from YAST->user & group management->expert options (right
    bottom corner)->login settings.


    --
    phani.

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Convenience and logging in

    phanisvara wrote:
    > i don't think so, that the OP has factory mixed in there. the same thing
    > happened to me (while i wasn't on factory yet): changing autologin
    > options in KDE systemsettings didn't affect the login behavior at all;


    ok...good to know, i hadn't seen that problem in mine, or around here
    before..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

    What if there were no hypothetical questions?

  7. #7

    Default Re: Convenience and logging in

    On 01/16/2011 10:51 PM, DenverD wrote:
    > Kevin Miller wrote:
    >> What am I missing?

    > wow, it sure sounds to me like you are doing it the right way...your
    > problem sounds _very_ uncommon to me (though i have not googled it in
    > our forum) so, i wonder which operating system, version and desktop
    > environment and version you are using...
    >
    > i'm thinking maybe you have some 'factory' mixed into your setup, maybe??
    >
    > certainly, the system should be switchable back and forth (auto to not
    > to auto)...so....well this is really strange..
    >
    > might you show us the output of entering the following into a terminal
    >
    >
    Code:
    > zypper lr -d
    >
    >
    > and copy/paste the output back to this thread using the instructions
    > here: http://goo.gl/i3wnr

    Doh! After reading and posting here for as long as I have you'd think
    I'd at least have sense to include my version & pertinent settings.
    :-) Sorry about that.

    Code:
    mkm@orca:~> zypper lr -d
    #  | Alias                               |
    Name                                | Enabled | Refresh | Priority |
    Type   |
    URI                                                              | Service
    ---+-------------------------------------+-------------------------------------+---------+---------+----------+--------+------------------------------------------------------------------+--------
    1  | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3
    11.3-1.82 | Yes     | Yes     |   99     | rpm-md |
    http://download.opensuse.org/update/11.3/                        |
    2  | download.nvidia.com-opensuse        | NVIDIA
    Repository                   | No      | Yes     |   99     | rpm-md |
    ftp://download.nvidia.com/opensuse/11.3/                         |
    3  | download.opensuse.org-mozilla       | openSUSE BuildService -
    Mozilla     | Yes     | Yes     |   99     | rpm-md |
    http://download.opensuse.org/repositories/mozilla/openSUSE_11.3/ |
    4  | download.videolan.org-SuSE          | VideoLan
    Repository                 | No      | No      |   99     | rpm-md |
    http://download.videolan.org/pub/videolan/vlc/SuSE/11.3/         |
    5  | openSUSE-11.3 11.3-1.82             | openSUSE-11.3
    11.3-1.82             | No      | No      |   99     | yast2  |
    cd:///?devices=/dev/sr0,/dev/sr1                                 |
    6  | openSUSE-11.3-Source                |
    openSUSE-11.3-Source                | Yes     | Yes     |   99     |
    yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/  |
    7  | packman                             |
    packman                             | Yes     | Yes     |   99     |
    rpm-md | http://packman.unixheads.com/suse/11.3/                          |
    8  | repo-debug                          |
    openSUSE-11.3-Debug                 | No      | Yes     |   99     |
    NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/   |
    9  | repo-non-oss                        |
    openSUSE-11.3-Non-Oss               | Yes     | Yes     |   99     |
    yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/     |
    10 | repo-oss                            |
    openSUSE-11.3-Oss                   | Yes     | Yes     |   99     |
    yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/         |
    11 | virtualbox                          | VirtualBox for openSUSE
    11.3        | Yes     | Yes     |  120     | rpm-md |
    http://download.virtualbox.org/virtualbox/rpm/opensuse/11.3      |
    Pretty stock set of repos.

    I'll take a look at Phanisvara's suggestion and report back.

    Thanks...

    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org


  8. #8

    Default Re: Convenience and logging in

    On 01/17/2011 04:15 AM, phanisvara wrote:
    > On Mon, 17 Jan 2011 13:21:13 +0530, DenverD
    > <DenverD@no-mx.forums.opensuse.org> wrote:
    >
    >> Kevin Miller wrote:
    >>> What am I missing?

    >>
    >> wow, it sure sounds to me like you are doing it the right way...your
    >> problem sounds _very_ uncommon to me (though i have not googled it in
    >> our forum) so, i wonder which operating system, version and desktop
    >> environment and version you are using...
    >>
    >> i'm thinking maybe you have some 'factory' mixed into your setup, maybe??

    >
    >
    > i don't think so, that the OP has factory mixed in there. the same thing
    > happened to me (while i wasn't on factory yet): changing autologin
    > options in KDE systemsettings didn't affect the login behavior at all;
    > only after changing the setting under YAST / user management did i get
    > my KDE login screen back (after i forgot to disable auto-login during
    > installation).
    >
    >> certainly, the system should be switchable back and forth (auto to not
    >> to auto)...so....well this is really strange..

    >
    > it is, but from YAST->user & group management->expert options (right
    > bottom corner)->login settings.


    OK - I just did that and will post results next boot. Thanks. I'd
    looked in YaST before but missed the expert options drop down menu.

    Thanks much...

    ....Kevin
    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

  9. #9

    Default Re: Convenience and logging in

    On 01/17/2011 04:15 AM, phanisvara wrote:
    > it is, but from YAST->user & group management->expert options (right
    > bottom corner)->login settings.


    OK, that worked fine. I can now log in automatically again. Thanks!

    --
    Kevin Miller - http://www.alaska.net/~atftb
    Juneau, Alaska
    In a recent survey, 7 out of 10 hard drives preferred Linux
    Registered Linux User No: 307357, http://counter.li.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •