Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Geeko no longer shown at boot

  1. #1
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Geeko no longer shown at boot

    This morning, I updated my GRUB config. I reordered some menu items and set openSUSE as default OS.

    When I boot into openSUSE, I am no longer greeted by Geeko when openSUSE is loading. I only see text from the boot procedure scroll by like it's still the 90s. While there's a certain coolness in seeing openSUSE switch to runlevel 5 and all that jazz, I want my chameleon back.

    A few weeks ago, I configured openSUSE to boot with flag vga=0x3ef so that it would boot with my preferred resolution immediately. This used to work fine. Since this morning, openSUSE crashes when X is attempting to start. I can still boot into openSUSE by removing that flag, but even then I still don't see the chameleon.

    How do I get my favorite Linux mascot back?

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Geeko no longer shown at boot

    Quote Originally Posted by pdedecker View Post
    This morning, I updated my GRUB config. I reordered some menu items and set openSUSE as default OS.

    When I boot into openSUSE, I am no longer greeted by Geeko when openSUSE is loading. I only see text from the boot procedure scroll by like it's still the 90s. While there's a certain coolness in seeing openSUSE switch to runlevel 5 and all that jazz, I want my chameleon back.

    A few weeks ago, I configured openSUSE to boot with flag vga=0x3ef so that it would boot with my preferred resolution immediately. This used to work fine. Since this morning, openSUSE crashes when X is attempting to start. I can still boot into openSUSE by removing that flag, but even then I still don't see the chameleon.

    How do I get my favorite Linux mascot back?
    Do you have
    Code:
    splash=silent
    As part of the kernel options in GRUB?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Geeko no longer shown at boot

    Quote Originally Posted by ah7013 View Post
    Do you have
    Code:
    splash=silent
    As part of the kernel options in GRUB?
    Yes. Here is my value for "Optional Kernel Command Line Parameter":
    resume=/dev/disk/by-id/ata-ST9250410AS_5VG6PVQA-part5 splash=silent quiet showopts

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Geeko no longer shown at boot

    Quote Originally Posted by pdedecker View Post
    Yes. Here is my value for "Optional Kernel Command Line Parameter":
    resume=/dev/disk/by-id/ata-ST9250410AS_5VG6PVQA-part5 splash=silent quiet showopts
    Just guessing here but maybe you could add
    Code:
    vga=0x3ef nomodeset
    to the "Optional Kernel Command Line Parameter". So it would end up like this:
    Code:
    resume=/dev/disk/by-id/ata-ST9250410AS_5VG6PVQA-part5 splash=silent quiet showopts vga=0x3ef nomodeset
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Geeko no longer shown at boot

    The addition of the nomodeset flag allowed me to start openSUSE with a 1600x900 resolution without having X crash at startup, but it doesn't bring the splash back. I also tried reverting to the proposed GRUB configuration, but that didn't fix the issue either.

  6. #6
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Geeko no longer shown at boot

    What about removing the
    Code:
    vga=0x3ef nomodeset
    options and just adding
    Code:
    vga=791
    Just guessing here. It might cause X to crash just like on 0x3ef but it is worth a try
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  7. #7
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Geeko no longer shown at boot

    I had tried booting without any VGA flag before creating this thread, but that didn't restore the splash. I'll give vga=791 a try though.

  8. #8
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Geeko no longer shown at boot

    Alas... no difference. I'm thinking the GRUB parameters aren't the culprit here. Are there any logs or config files that I could examine for clues?

  9. #9
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Geeko no longer shown at boot

    If X is crashing with
    Code:
    vga=0x3ef
    Then you could look in /var/log/Xorg.0.log for clues
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  10. #10
    Join Date
    Dec 2010
    Location
    Belgium, Europe
    Posts
    192

    Default Re: Geeko no longer shown at boot

    Here's the difference between a successful X boot and an X boot that ended up hanging the system.

    http://www.pieterdedecker.be/tmp/Xorg.0.log
    http://www.pieterdedecker.be/tmp/Xorg.0.log.old

    These errors seem noteworthy:

    ...
    [ 18.436] failed to get auxch 0030 40 30 02
    [ 18.437] failed to get auxch 0031 40 30 02
    [ 18.437] failed to get auxch 0037 40 30 02
    [ 18.437] failed to get auxch 0050 40 30 02
    [ 18.437] failed to get auxch 0050 40 30 02
    [ 18.437] failed to get auxch 0050 40 30 02
    [ 18.438] failed to get auxch 0050 40 30 02
    ...
    [ 18.455] (II) RADEON(0): Not using default mode "640x350" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "320x175" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "640x400" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "320x200" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "720x400" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "360x200" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "320x240" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "640x480" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "320x240" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "640x480" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "320x240" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "640x480" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "320x240" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "800x600" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "400x300" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "400x300" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "800x600" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "400x300" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "800x600" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "400x300" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "800x600" (vrefresh out of range)
    [ 18.455] (II) RADEON(0): Not using default mode "400x300" (doublescan mode not supported)
    [ 18.455] (II) RADEON(0): Not using default mode "1024x768i" (interlace mode not supported)
    ...
    I have no experience with the inner workings of X, but it appears that it fails to find a working resolution when I boot with vga=0x3ef which, again, used to work perfectly fine.

    Fortunately I can work around this problem by not starting with a custom vga flag, but I do want to get the Geeko splash back. Does sysVinit keep a log that could help diagnose the problem?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •