Hello folks,

I am looking for a guiding hand who can show me how to
a) get to know if my rocketraid 2300 setup under linux is actually working
b) get my rocketraid 2300 RAID card up and running with opensuse 11.3 if !a

Hardware info:
RocketRaid 2300 with 2 disks (1TB each) connected to RR2300 ports 1 and 2 and setup as a Raid 1 (and named it RAID_1_1TB).

Both disks show up as sda and sdb when loading suse 11.3 installation.

As Highpoint doesn't offer a 11.3 driver, I did the following:
left sdb alone, installed suse on sda2 (sda1 is swap), compiled the driver against the running kernel.
When doing the make install I get the info
(from depmod executed through make install)
"modprobe: module sata_mv not found" and
"WARNING: no dependencies for kernel modules "sata_mv" found."

the drives are referenced by the disk id, e.g. "dev/disk/by-id/ata-ST....-part2" (for root device, etc.pp.)

The install process executes mkinitrd as well.

I then modprobe'd "modprobe rr2310_00" and figured out with lsmod that the module is loaded but not in use.
Hmm. The driver is in /lib/modules/..../ existing.

So when I now reboot the system (reboot -n), the system doesn't come up anymore, yielding the error message
"resume device /dev/disk/by-id/ata-ST....-part1 not found (ignoring)"
and
"waiting for device /dev/disk/by-id/ata-ST....-part2 to appear"
and so forth...
then shell-prompt.

So, some help would be highly appreciated. Somehow I feel like a newbie, but having worked with lx for quite some years, this leaves me puzzled like rarely before...

What I tried as well was to copy the self-compiled drive on a USB device and to direct the installation loader to load a custom driver (f6 key). But again here I am not given any feedback whether the driver was loaded or not, so I don't know if it is working (as I get the same view of the disks as above without the driver). What am I missing here?

Thanks for any help anybody can provide!
Florian