Results 1 to 2 of 2

Thread: Hiding grub in a kiwi live boot

  1. #1

    Default Hiding grub in a kiwi live boot

    Naturally, hiding the graphical grub screen on a regular installation is easy, by adding either "timeout 0" or "hiddenmenu" to menu.lst. But on a live boot, there seems to be no menu.lst - at least no accessible one.

    Although, in some kiwi image types, you can specify boottimeout="n" in the image description's type element, it does not have the intended effect. Here is an example. The following type element's boottimeout attribute will invoke the first grub menu item instantly. Changing the value to zero, not only does not hide the grub screen, but seems to restore the default 10 second time out.

    <type image="iso" primary="true" boot="isoboot/suse-11.3" boottimeout="1" hybrid="true" flags="clic"/>

    What is going on here?
    Is there any way to hide the graphical grub screen in a kiwi live boot?

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    12,046
    Blog Entries
    2

    Default Re: Hiding grub in a kiwi live boot

    Although I haven't worked with kiwi, because I'm working on something that could have been related to your post I did a little investigating (which may or may not be accurate).

    First, as a build tool I was curious whether it might be jumping ahead to implement GRUB2 which deprecates menu.lst, replacing the single config file with the configuration directory (directories within the config directory are compiled into an aggregate config). I couldn't find any indication of that so I kind of doubt that would be happening.

    So, assuming that kiwi doesn't impose non-standard components like GRUB2, I suggest you maybe try a couple options:
    - Modify the original configuration rather than alter later (if that's what you're doing). This link might help to script the GRUB config within Kiwi
    SDB:KIWI Cookbook Splash Screen - openSUSE

    - Try setting a timeout to one second. Some functions elsewhere don't support zero and interpret that value as "default" which I suspect is what you're seeing.

    HTH,

    Tony

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •