Results 1 to 7 of 7

Thread: Copy/Paste KMail

  1. #1
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Copy/Paste KMail

    Hi,

    since some days I have a strange problem with KMail (1.13.5) in KDE4.5.5. When I try to copy some text from an email and past it to any other program (e.g. Openoffice), not only the marked text will be pasted, but a kind of HTML code including the text.
    This bug is not OpenSuse specific. I found the same bug in a Fedora mailing list (of course, whithout an answer): Strange Copy/Paste behavior in KMail 1.13.5/Kontact 4.4.8 -- Fedora Linux Users

    Has anybody the same bug (and perhaps a solution)?

    Michael

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,450

    Default Re: Copy/Paste KMail

    Not experienced it - and I do the same frequently. Only difference is I am still on 4.4.4.

    That said, since 4.4.4 I have noticed that formatting information is more frequently included in Copy, e.g. from Konqueror, and, in some cases, the only way to get the plain text is to retrieve it from Klipper. Perhaps this is an incremental change in the way Copy works in KDE.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Default Re: Copy/Paste KMail

    Just guessing, but isn't there a way to set kmail to display the messages in plain text, like a security mode or something? That way what you copy/paste will probably be plain text.

    Another option is to use the select (to copy) and middle-button-click (to paste). It is the linux way, apart from the windowsy CTRL-C/CTRL-V.
    I thing this will bring only the unformatted text, give it a try.

  4. #4
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Copy/Paste KMail

    Hi,

    the middle-button-clicks results in the same bug.

    This is an example what will be pasted (instead of xxxxtestxxxx):
    "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd">
    <body><font class="Apple-style-span" face="arial, helvetica, sans-serif" size="2">xxxxxtestxxxx</font></body>"

    The bug does not occur in KDE4.4. I think bug came with KDE 4.5.4 or 4.5.5.

    Michael

  5. #5
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Copy/Paste KMail

    Quote Originally Posted by michaelhust View Post
    Hi,

    the middle-button-clicks results in the same bug.

    This is an example what will be pasted (instead of xxxxtestxxxx):
    "<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "DTD/xhtml1-strict.dtd">
    <body>
    <script type="text/javascript"><!--
    var _gaq = _gaq || [];
    _gaq.push(
    ['_setAccount', 'UA-7519982-1'],
    ['_trackPageview']
    );
    (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
    })();
    //-->
    </script>
    <font class="Apple-style-span" face="arial, helvetica, sans-serif" size="2">xxxxxtestxxxx</font></body>"

    The bug does not occur in KDE4.4. I think bug came with KDE 4.5.4 or 4.5.5.

    Michael
    Yes, you are right. It happens to me too. I'm using KMail 1.13.5 in kde 4.54.
    It's a bit unconfortable, in fact.
    What brunomcl says in post #3 above works: uncheck Folder -> Prefer html to plain text
    Then copy and paste and you'll get the text without the formatting.

  6. #6
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    272

    Default Re: Copy/Paste KMail

    @wrbt: Thanks.
    When I remove the "prefer html to plain text" function, then I can copy text from plain text emails . But when I get html mail, I still have the problem .

    Michael

  7. #7
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: Copy/Paste KMail

    Quote Originally Posted by michaelhust View Post
    @wrbt: Thanks.
    When I remove the "prefer html to plain text" function, then I can copy text from plain text emails . But when I get html mail, I still have the problem .

    Michael
    Are you sure?
    I have tried now several times. If I copy from a html mail with "prefer html to plain text" disabled, when I paste it I get just text, not the html code.

    Anyway, I agree with you that this is a bit unconfortable. I would prefer that it worked as before. Another possibility would be to implement this function (paste html code), and at the same time the function "paste without code" or "paste simple text" or something similar (at least in kmail composer).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •