Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Installation of opensuse 11.3 on Vaio Y21 laptop

  1. #1

    Default Installation of opensuse 11.3 on Vaio Y21 laptop

    Hi there,

    I've a sony vaio Y21S1E and I can't install opensuse in graphic mode (I got a black screen just after the loading page...). So I installed it in text mode, but on reboot, I have exactly the same problem... I had a look in the logs but I found nothing ... My Xorg.conf seems to be OK (intellegacy)...

    Someone could help please ?
    Thanks in advance,

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    It would have helped if you had specified your Intel device
    Have you looked at this
    openSUSE Graphic Card Practical Theory Guide for Users

    Have you tried failsafe boot?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Try booting with the option nomodeset

  4. #4

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    caf4926: I can boot in failsafe mode, but I can't startx (black screen again...), I'll take a look at youir link, thanks.
    A-D4M: OK, I'll try this and I'll come back to tell you ...

    both: Thanks for replying

  5. #5
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Quote Originally Posted by kipioca View Post
    Hi there,

    I've a sony vaio Y21S1E and I can't install opensuse in graphic mode (I got a black screen just after the loading page...). So I installed it in text mode, but on reboot, I have exactly the same problem... I had a look in the logs but I found nothing ... My Xorg.conf seems to be OK (intellegacy)...

    Someone could help please ?
    Thanks in advance,
    The Sony VAIO Y21-series has an Intel Pentium U5400 processor. Do not be mislead by the name, as it is a close cousin of the i3/i5 Arrandale line, built on a thin(ner) base for ultra-thin/ultra-lights. (Has very respectable power consumption and thermal dissipation!). However (there is always a "but" or "however"), ...

    The U5400 has the Intel Integrated Graphics. The problem you are experiencing is rather well-known. The circumvention(s) include booting in Failsafe mode, or specifying nomodeset on the boot options line. These techniques will give you a deprecated display, but everything else should work.

    To get your display to function natively (1366 x 768), with full graphics, try the procedures found here - The "Black Screen" on Boot .... a Surprise !, with attention to post #18.

    Please post back here with your results !

    If you could, please post the following:
    Code:
    uname -a
    
    zypper lr -d
    
    lspci -v
    If possible, following a successful boot, please post the contents of /var/log/boot.msg. If you cannot get s successful boot, re-boot with either nomodeset or in Failsafe mode, and post the contents of /var/log/boot.omsg. Please carefully note the underlining.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  6. #6

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Hi there,
    so I tried with the nomodeset option, and I got the same problem after a brief text boot sequence... So I can only boot in failsafe mode.
    SeanMc98, here is the result of the commands :

    uname:
    Linux linux-29hz.site 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux

    zypper:

    # | Alias | Nom | Activé | Rafraîchir | Priorité | Type | URI | Service
    --+--------------+-----------------------+--------+------------+----------+------+-----------------------------------------------------------------+--------
    1 | repo-debug | openSUSE-11.3-Debug | Non | Oui | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    2 | repo-non-oss | openSUSE-11.3-Non-Oss | Oui | Oui | 99 | NONE | Index of /distribution/11.3/repo/non-oss |
    3 | repo-oss | openSUSE-11.3-Oss | Oui | Oui | 99 | NONE | Index of /distribution/11.3/repo/oss |
    4 | repo-source | openSUSE-11.3-Source | Non | Oui | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    5 | repo-update | openSUSE-11.3-Update | Oui | Oui | 99 | NONE | Index of /update/11.3 |

    lspci:
    00:00.0 Host bridge: Intel Corporation Core Proc
    cat boot.omsg:
    klogd 1.4.1, log source = ksyslog started. <5>[

    Thanks again !

  7. #7
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Quote Originally Posted by kipioca View Post
    Hi there,
    so I tried with the nomodeset option, and I got the same problem after a brief text boot sequence... So I can only boot in failsafe mode.
    The boot.omsg posted indicated that the prior boot was performed with the nomodeset option. Can you re-run the sequence with:

    1. Attempt normal boot (without nomodeset or Failsafe)
    2. If the boot in step 1 is successful, post /var/log/boot.msg, and continue running your PC.
    3. If the boot in step 1 fails (hangs, black screen, white screen, or anything other that a clean oS boot), then re-boot in Failsafe mode, and post /var/log/boot.omsg (the boot.msg of the previous failed boot).

    Quote Originally Posted by kipioca View Post
    SeanMc98, here is the result of the commands :

    uname:
    Linux linux-29hz.site 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 x86_64 x86_64 x86_64 GNU/Linux
    2.6.34-12 is the openSUSE kernel straight from the liveCD. You really should run the updates (YAST --> Online Update). 2.6.34-12 OOTB (out-of-the-box, off-of-the-whatever) does not play well with the Intel Integrated graphics. Even in Failsafe mode, the borders of windows disappear, tasks hang, etc. Run the updates before re-doing the boot sequence above. The update sequence will bring your kernel to 2.6.34.7-07.1, along with (most likely) quite a few additional updates.

    Quote Originally Posted by kipioca View Post
    zypper:

    # | Alias | Nom | Activé | Rafraîchir | Priorité | Type | URI | Service
    --+--------------+-----------------------+--------+------------+----------+------+-----------------------------------------------------------------+--------
    1 | repo-debug | openSUSE-11.3-Debug | Non | Oui | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    2 | repo-non-oss | openSUSE-11.3-Non-Oss | Oui | Oui | 99 | NONE | Index of /distribution/11.3/repo/non-oss |
    3 | repo-oss | openSUSE-11.3-Oss | Oui | Oui | 99 | NONE | Index of /distribution/11.3/repo/oss |
    4 | repo-source | openSUSE-11.3-Source | Non | Oui | 99 | NONE | Index of /source/distribution/11.3/repo/oss |
    5 | repo-update | openSUSE-11.3-Update | Oui | Oui | 99 | NONE | Index of /update/11.3 |
    All good here, looks like the repositories should fresh from the install.

    Quote Originally Posted by kipioca View Post
    All good here. After you perform the updates, test your audio. (Yes, the Intel stuff spreads it around !).

    Quote Originally Posted by kipioca View Post
    See the notes at the top regarding the boot sequence. This showed that the prior boot was a nomodeset. This option disables KMS, so you get the fallback drivers.

    One last question (I might have missed it): Are you running KDE or Gnome ?
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  8. #8

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Quote Originally Posted by SeanMc98 View Post
    One last question (I might have missed it): Are you running KDE or Gnome ?
    I'm runnning KDE.
    Thanks for your help !

  9. #9

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    Re,

    I followed the procedure (upgrading distrib and reboot normally, I had a black screen and then, reboot in failsafe mode) and here are the results :
    uname :

    Linux linux-29hz.site 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux

    boot.omsg of the last boot sequence :
    klogd 1.4.1, log source = ksyslog started. <5>[

    Thanks again ^^

  10. #10

    Default Re: Installation of opensuse 11.3 on Vaio Y21 laptop

    some news... I also tried the latest kernel (2.6.37 from repo HEAD:Kernel), but I have again the same result ... black screen... Please help !

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •