Results 1 to 4 of 4

Thread: High CPU load from XOrg and gconfd-2 with nvidia

  1. #1

    Default High CPU load from XOrg and gconfd-2 with nvidia

    I just posted about this in this thread, but as the other thread was started by a KDE user then I thought I'd post here as well.

    I've had high CPU usage for a few months now - probably since trying the 0.9 branch of Compiz then dropping back to the default openSUSE builds (XOrg and gconfd-2 running a Core i5 at about 30% on every core*). I've now finally found a solution after deciding I wanted to fix it once and for all.

    Once again, the Ubuntu forums come to the rescue with this thread (I don't like the distro as a whole, but I do find the forums useful!). I'm using Compiz, but it turns out that Metacity was running as well. A quick "killall -9 metacity" and the gconfd-2 process has vanished and XOrg settled down to its normal 1-2% (which is reasonable when I've got a Conky config refreshing every fraction of a second to repaint a sound visualiser!). Now I just need to find out why Metacity starts when I'm using Compiz...

    * according to Conky's per-core graphs, although top only reported 15% overall and the Conky "top 3 procs by CPU" reported a measly 3% for each process, so someone's maths was out somewhere!

  2. #2

    Default Re: High CPU load from XOrg and gconfd-2 with nvidia

    I found the source of the problem - after upgrading to Compiz 0.9 then dropping back to the openSUSE version of Compiz* then I had a problem with starting the correct window manager. I tinkered with /desktop/gnome/session/required_components/windowmanager and ended up with "metacity" as the value and "compiz-manager --replace" as a startup app as being the only way to get all four desktops and a window manager. Changing the value to "compiz-manager" but keeping the startup app as well seems to have fixed it for now and lowered my CPU usage

    * I was running off the OBS repo with the latest build, then I got in a bit of a mess where I had upgraded part of Compiz to 0.9 accidentally but not all of it, and downgrading wasn't possible. I tried 0.9 but had a few issues, so I tried the old openSUSE version (which I've finally got to work how I like it, even though it doesn't have Fusion Icon).

  3. #3
    Join Date
    Mar 2010
    Austin - Texas
    Blog Entries

    Smile Re: High CPU load from XOrg and gconfd-2 with nvidia

    metacity, normally loaded with the GNOME desktop is said to be a fast Windows Manager for the 2.x GNOME desktop. gconfd-2 is part of gconf2, said to be the GNOME Configuration Database. I would expect you would only have these if you have also loaded the GNOME desktop in addition to the KDE desktop. I can't say that I have ever had any issues with these programs. I do find gconfd-2 loaded when running the System Monitor. I do use KDE all of the time, I have updated my kernel version to 2.6.37 and my Video driver is the latest from nVIDIA. I decided to look up the issues as you put forth, but I can't say I have seen any problems with them myself so far.

    Thank You,
    My Blog:

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4

    Default Re: High CPU load from XOrg and gconfd-2 with nvidia

    Strangely enough, I am using Gnome, hence the appearance of gconfd-2 and Metacity I've never got on with KDE - either 3.x or 4.x.

    As I said, the problems occurred because of my tinkering, but I put the topic up anyway in case other people had got themselves into the same situation. I've tried just setting the GConf key I mentioned to "compiz-manager" and not having "compiz --replace" as a startup app, but I end up with no real window manager (Alt+F2 won't work, compositing isn't there and compiz isn't in the "ps aux" list) and only one workspace. It looks like "compiz-manager" and the startup app is the way to go for now, though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts