Results 1 to 2 of 2

Thread: [11.3] 2x nVidia graphics card with 2 X servers

  1. #1

    Default [11.3] 2x nVidia graphics card with 2 X servers

    I have a system with two nVidia graphics cards, with monitors connected to each graphics card. I used nvidia-settings to setup a X server for each graphics card. Rebooted with saved xorg.conf file. I do see all monitors displaying their correct image.

    I am using Gnome 2 supplied with 11.3.

    The problem is: how do I start applications on the 2nd X server? If I use the application launcher on 2nd X server, the applications appear on the monitors of the 1st X server. I am also unable to move applications windows from one X server to the other.

  2. #2

    Default Re: [11.3] 2x nVidia graphics card with 2 X servers

    Quote Originally Posted by ajpeck View Post

    The problem is: how do I start applications on the 2nd X server? If I use the application launcher on 2nd X server, the applications appear on the monitors of the 1st X server.
    This is normal. You have either to specify the screen number in the command line or change the value of the variable DISPLAY

    try:
    Code:
    xclock -display :1.0
    Quote Originally Posted by ajpeck View Post
    I am also unable to move applications windows from one X server to the other.
    This is normal. I wouldn't know how to move an application from one screen to another. Two X servers, each running on their own screen, are not the same as two monitors in one screen (this is possible too). Notice that monitor and screen do not refer to the same thing. You could also have two X servers simultaneously running with only one monitor. And you could have two monitors (or more) serving the same screen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •