Results 1 to 9 of 9

Thread: Update error on Suse 11.3 (fresh install)

  1. #1
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Unhappy Update error on Suse 11.3 (fresh install)

    I have installed Suse 11.3 on my computer yesterday but since then I have been trying to update it but unable to do so. Everytime I try I get this error message:

    "system management is locked by the application with pid 6953 (usr/sbin/packagekitd).
    close this appliaction before trying again."

    What can I do to get rid of this. Please help me.
    I am new to Suse, and have very little knowledge of Linux commands.

    Thanks in advance.

  2. #2
    Join Date
    Jan 2009
    Location
    Switzerland
    Posts
    1,529

    Default Re: Update error on Suse 11.3 (fresh install)

    Open a terminal window, then do

    Code:
    su -
    <enter your root password here>
    
    kill 6953
    
    exit
    Technology is 'stuff that doesn't work yet.' -- Bran Ferren

  3. #3
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Re: Update error on Suse 11.3 (fresh install)

    Thanks a lot.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,525
    Blog Entries
    37

    Default Re: Update error on Suse 11.3 (fresh install)

    Quote Originally Posted by babloo75 View Post
    I have installed Suse 11.3 on my computer yesterday but since then I have been trying to update it but unable to do so. Everytime I try I get this error message:

    "system management is locked by the application with pid 6953 (usr/sbin/packagekitd).
    close this appliaction before trying again."

    What can I do to get rid of this. Please help me.
    I am new to Suse, and have very little knowledge of Linux commands.

    Thanks in advance.
    Some basics with an explanation.

    When you first start your openSUSE, the packagekitd will check for software updates. While it is doing that, you either need to close that application, or wait until it is finished before you start to try and update. If you look in the lower right hand corner of your screen/desktop, you shoudl see the icon that represents the packagekitd trying to do its job. And only one of you (either YOU or packagekitd) are allowed to do this at a time.

    vodoo give you a command to kill it (based on the PID you provided) but did not provide the philosophy as to why that should work. Hopefully this extra bit helps.

  5. #5
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Update error on Suse 11.3 (fresh install)

    Quote Originally Posted by oldcpu View Post
    Some basics with an explanation.

    When you first start your openSUSE, the packagekitd will check for software updates. While it is doing that, you either need to close that application, or wait until it is finished before you start to try and update. If you look in the lower right hand corner of your screen/desktop, you shoudl see the icon that represents the packagekitd trying to do its job. And only one of you (either YOU or packagekitd) are allowed to do this at a time.

    vodoo give you a command to kill it (based on the PID you provided) but did not provide the philosophy as to why that should work. Hopefully this extra bit helps.
    And if you are quick enough you can go into the YaST online update before packagekitd checks for updates
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  6. #6
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Unhappy Re: Update error on Suse 11.3 (fresh install)

    But please help me in getting rid of this problem. Every time I start Suse, there is some or the other process which interferes with update.

    Is there any command to update Suse through Terminal.
    (the one used in Ubuntu 'sudo apt-get update' doesn't work here.)

    Thanks.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Update error on Suse 11.3 (fresh install)

    apt- is not part of openSUSE

    I assume you are using Gnome??
    You need to configure the updater applet 'never' to look for updates.

    To update from the terminal in SUSE

    switch to su -
    then do

    Code:
    zypper up
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8
    Join Date
    Nov 2008
    Location
    Delhi, India
    Posts
    191

    Default Re: Update error on Suse 11.3 (fresh install)

    Sorry I forgot to mention earlier, I have KDE Suse 11.3.

    Thanks a lot.

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: Update error on Suse 11.3 (fresh install)

    Right click the update applet in the tray
    You can configure it not to start at boot, then quit and reboot. You should be good then.

    Gnome users have to go to the control centre
    http://dl.dropbox.com/u/10573557/SUS...date-check.png
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •