OpenSUSE 11.3
Zypper 1.4.8-0.2.4 (i586)

When attempting to run commands of zypper:
Code:
$ sudo zypper install <XXX>
$ sudo zypper help
$ sudo zypper services
The following error is displayed:
zypper: symbol lookup error: /usr/local/lib/libreadline.so.6: undefined symbol: PC
I looked through my command history to verify I hadn't done anything stupid. The only thing I had done since my last zypper command was to install ngspice....WITH zypper.

Looks to me like libreadline.so.6 is corrupt.

Is there a way I can "update" or reinstall libreadline.so.6 with an uncorrupted version without bricking my OS? I looked into uninstalling libreadline.so.6 from Yast Software Manager (GUI) but it throws all kinds of warnings about how it can't complete operations and it will break links and such....so I'd like to avoid it unless a guru says otherwise.

Maybe you gurus have another idea of what's wrong?

Thanks!

-Dustin