Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Not able to start mySQL , Please help

  1. #1

    Default Not able to start mySQL , Please help

    Need help here, PLEASE

    Running
    openSUSE 11.3 (x86_64)
    Linux 2.6.34.7-0.7-desktop x86_64
    mysql-community-server_64 5.1.46-2.18-x86_64 from vendor openSUSE
    php5-mysql 5.3.3-0.7.1-x86_64 from vendor openSUSE
    Apache2 2.2.15-3.7-x86_64
    apache2-mod_php5 5.3.3-0.7.1-x86_64 from vendor openSUSE


    Trying to start mysql in YaST > system services (runlevel) >
    Expert mode
    gives following message
    /etc/init.d/mysql start returned 1 (unspecified error):

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Not able to start mySQL , Please help

    On 2011-01-05 15:06, cord1 wrote:

    > Trying to start mysql in YaST > system services (runlevel) >
    > Expert mode
    > gives following message
    > /etc/init.d/mysql start returned 1 (unspecified error):


    Get to a root terminal and type "rcmysql start". Then look up the logs to
    find the exact error.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: Not able to start mySQL , Please help

    Hi Carlos,
    Thanks for responding.

    The result of : rcmysql start
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
    failed

    can you help me foreward?

  4. #4
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Default Re: Not able to start mySQL , Please help

    Hi,
    Is that the complete error message? Are you getting anything else like

    Code:
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within
    30 seconds
    You may be suffering from this bug https://bugzilla.novell.com/show_bug.cgi?id=626297

    The Bugreport suggests the following:
    Make sure you are running as root and execute the following commands from the terminal

    Code:
    /etc/init.d/apache2 restart
    service mysql start
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

  5. #5

    Default Re: Not able to start mySQL , Please help

    linux-984r:~ # whoami
    root
    linux-984r:~ # /etc/init.d/apache2 restart
    Syntax OK
    Shutting down httpd2 (waiting for all children to terminate) done
    Starting httpd2 (prefork) done
    linux-984r:~ # service mysql start
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
    failed
    linux-984r:~ #

  6. #6
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Default Re: Not able to start mySQL , Please help

    Would you try those two commands again and then post the output of
    Code:
    tail -n100 /var/log/mysqld.log
    and
    Code:
    dmesg | tail -n100
    Thanks
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

  7. #7

    Default Re: Not able to start mySQL , Please help

    linux-984r:~ # /etc/init.d/apache2 restart
    Syntax OK
    Shutting down httpd2 (waiting for all children to terminate) done
    Starting httpd2 (prefork) done
    linux-984r:~ # service mysql start
    Starting service MySQL warning: /var/run/mysql/mysql.sock didn't appear within 30 seconds
    chmod: cannot access `/var/run/mysql/mysqld.pid': No such file or directory
    failed
    linux-984r:~ # tail -n100 /var/log/mysqld.log
    tail: cannot open `/var/log/mysqld.log' for reading: No such file or directory
    linux-984r:~ # dmesg | tail -n100
    [ 9.001785] pcmcia_socket pcmcia_socket0: cs: memory probe 0x80000000-0x83ffffff: excluding 0x80000000-0x83ffffff
    [ 9.001800] yenta_cardbus 0000:04:06.0: pcmcia: parent PCI bridge window: [io 0x0000-0xffff]
    [ 9.001803] yenta_cardbus 0000:04:06.0: pcmcia: parent PCI bridge window: [mem 0x80000000-0xfcffffffff]
    [ 9.001807] pcmcia_socket pcmcia_socket0: cs: memory probe 0x80000000-0xfcffffffff: excluding 0x80000000-0x87ffffff 0xc0000000-0xc07fffff 0xc1000000-0xc37fffff 0xc4000000-0xc47fffff 0xd0000000-0xefffffff 0xfe800000-0xfeffffff 0xff800000-0xffffffff
    [ 9.054333] usbcore: registered new interface driver snd-usb-audio
    [ 9.145116]
    [ 9.145122] yenta_cardbus 0000:04:06.0: pcmcia: parent PCI bridge window: [mem 0x000a0000-0x000bffff]
    [ 9.145127] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0a0000-0x0bffff: clean.
    [ 9.146451] tifm_7xx1 0000:04:06.2: PCI INT A -> Link[LNK4] -> GSI 11 (level, low) -> IRQ 11
    [ 9.157990] pcmcia_socket pcmcia_socket0: cs: memory probe 0x0c0000-0x0fffff: excluding 0xc0000-0xfffff
    [ 9.158110] pcmcia_socket pcmcia_socket0: cs: memory probe 0xa0000000-0xa0ffffff: clean.
    [ 9.158212] pcmcia_socket pcmcia_socket0: cs: memory probe 0x60000000-0x60ffffff: excluding 0x60000000-0x60ffffff
    [ 9.236588] forcedeth 0000:00:14.0: ifname eth0, PHY OUI 0x732 @ 1, addr 00:16:d3:58:3a:ac
    [ 9.236594] forcedeth 0000:00:14.0: pwrctl gbit lnktim desc-v3
    [ 9.237248] EDAC amd64: This node reports that Memory ECC is currently disabled, set F3x44[22] (0000:00:18.3).
    [ 9.237264] EDAC amd64: ECC disabled in the BIOS or no ECC capability, module will not load.
    [ 9.237265] Either enable ECC checking or force module loading by setting 'ecc_enable_override'.
    [ 9.237267] (Note that use of the override may cause unknown side effects.)
    [ 9.237292] amd64_edac: probe of 0000:00:18.2 failed with error -22
    [ 9.238508] HDA Intel 0000:00:10.1: power state changed by ACPI to D0
    [ 9.238558] HDA Intel 0000:00:10.1: power state changed by ACPI to D0
    [ 9.238992] ACPI: PCI Interrupt Link [LAZA] enabled at IRQ 18
    [ 9.238998] alloc irq_desc for 18 on node 0
    [ 9.239000] alloc kstat_irqs on node 0
    [ 9.239040] HDA Intel 0000:00:10.1: PCI INT B -> Link[LAZA] -> GSI 18 (level, high) -> IRQ 18
    [ 9.239044] hda_intel: Disable MSI for Nvidia chipset
    [ 9.239109] HDA Intel 0000:00:10.1: setting latency timer to 64
    [ 9.239114] HDA Intel 0000:00:10.1: PCI: Disallowing DAC for device
    [ 9.424064] usb 2-7: new full speed USB device using ohci_hcd and address 4
    [ 9.624098] usb 2-7: New USB device found, idVendor=0a5c, idProduct=2101
    [ 9.624103] usb 2-7: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    [ 9.624106] usb 2-7: Product: Acer Module
    [ 9.624109] usb 2-7: Manufacturer: Broadcom Corp
    [ 9.646939] Bluetooth: Core ver 2.15
    [ 9.647121] NET: Registered protocol family 31
    [ 9.647125] Bluetooth: HCI device and connection manager initialized
    [ 9.647129] Bluetooth: HCI socket layer initialized
    [ 9.649797] Bluetooth: Generic Bluetooth USB driver ver 0.6
    [ 9.650472] usbcore: registered new interface driver btusb
    [ 9.904715] Adding 2103292k swap on /dev/sda1. Priority:-1 extents:1 across:2103292k
    [ 10.985044] device-mapper: uevent: version 1.0.3
    [ 10.985289] device-mapper: ioctl: 4.17.0-ioctl (2010-03-05) initialised: dm-devel@redhat.com
    [ 11.399853] loop: module loaded
    [ 11.537985] EXT4-fs (sda3): mounted filesystem with ordered data mode
    [ 12.921276] type=1505 audit(1294227009.761:2): operation="profile_load" pid=1275 name=/bin/ping
    [ 12.985870] type=1505 audit(1294227009.825:3): operation="profile_load" pid=1276 name=/sbin/klogd
    [ 13.109079] type=1505 audit(1294227009.949:4): operation="profile_load" pid=1277 name=/sbin/syslog-ng
    [ 13.226519] type=1505 audit(1294227010.066:5): operation="profile_load" pid=1278 name=/sbin/syslogd
    [ 13.353083] type=1505 audit(1294227010.193:6): operation="profile_load" pid=1279 name=/usr/sbin/avahi-daemon
    [ 13.458243] type=1505 audit(1294227010.298:7): operation="profile_load" pid=1280 name=/usr/sbin/identd
    [ 13.596546] type=1505 audit(1294227010.436:8): operation="profile_load" pid=1281 name=/usr/sbin/mdnsd
    [ 13.735130] type=1505 audit(1294227010.575:9): operation="profile_load" pid=1282 name=/usr/sbin/nscd
    [ 13.920648] type=1505 audit(1294227010.760:10): operation="profile_load" pid=1283 name=/usr/sbin/ntpd
    [ 14.031988] type=1505 audit(1294227010.871:11): operation="profile_load" pid=1284 name=/usr/sbin/traceroute
    [ 15.225193] ip6_tables: (C) 2000-2006 Netfilter Core Team
    [ 15.404025] ip_tables: (C) 2000-2006 Netfilter Core Team
    [ 15.450209] nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
    [ 17.671834] powernow-k8: Found 1 AMD Turion(tm) 64 X2 Mobile Technology TL-56 (2 cpu cores) (version 2.20.00)
    [ 17.671953] powernow-k8: 0 : fid 0xa (1800 MHz), vid 0x12
    [ 17.671955] powernow-k8: 1 : fid 0x8 (1600 MHz), vid 0x14
    [ 17.671958] powernow-k8: 2 : fid 0x0 (800 MHz), vid 0x1e
    [ 18.501046] Clocksource tsc unstable (delta = -277823860 ns)
    [ 19.488470] [drm] nouveau 0000:03:00.0: Allocating FIFO number 1
    [ 19.489072] [drm] nouveau 0000:03:00.0: nouveau_channel_alloc: initialised FIFO 1
    [ 19.516093] [drm] nouveau 0000:03:00.0: Allocating FIFO number 2
    [ 19.516725] [drm] nouveau 0000:03:00.0: nouveau_channel_alloc: initialised FIFO 2
    [ 23.255297] usb 2-7: USB disconnect, address 4
    [ 27.633465] BIOS EDD facility v0.16 2004-Jun-25, 1 devices found
    [ 30.188920] NET: Registered protocol family 17
    [ 40.347664] CPUFREQ: Per core ondemand sysfs interface is deprecated - up_threshold
    [ 40.675019] eth0: no IPv6 routers present
    [ 65.270321] bootsplash: status on console 0 changed to on
    [ 321.439955] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:16:d3:58:3a:ac:00:02:cf:e5:f1:62:08:00 SRC=193.213.112.4 DST=10.0.0.1 LEN=59 TOS=0x00 PREC=0x00 TTL=248 ID=33571 DF PROTO=UDP SPT=53 DPT=39858 LEN=39
    [ 2762.705311] CE: hpet increased min_delta_ns to 16875 nsec
    [ 5913.121240] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:16:d3:58:3a:ac:00:02:cf:e5:f1:62:08:00 SRC=130.67.15.198 DST=10.0.0.1 LEN=59 TOS=0x00 PREC=0x00 TTL=248 ID=59933 DF PROTO=UDP SPT=53 DPT=56908 LEN=39
    [ 6845.500806] [drm] nouveau 0000:03:00.0: Allocating FIFO number 3
    [ 6845.501518] [drm] nouveau 0000:03:00.0: nouveau_channel_alloc: initialised FIFO 3
    [ 6845.523479] [drm] nouveau 0000:03:00.0: nouveau_channel_free: freeing fifo 3
    [ 7412.975608] st: Version 20081215, fixed bufsize 32768, s/g segs 256
    [ 9098.722376] [drm] nouveau 0000:03:00.0: Setting dpms mode 1 on lvds encoder (output 0)
    [ 9098.722388] [drm] nouveau 0000:03:00.0: Calling LVDS script 6:
    [ 9098.722399] [drm] nouveau 0000:03:00.0: 0xC2F1: Parsing digital output script table
    [ 9699.002171] [drm] nouveau 0000:03:00.0: Setting dpms mode 2 on lvds encoder (output 0)
    [ 9814.704544] [drm] nouveau 0000:03:00.0: Setting dpms mode 0 on lvds encoder (output 0)
    [ 9814.704556] [drm] nouveau 0000:03:00.0: Calling LVDS script 2:
    [ 9814.704568] [drm] nouveau 0000:03:00.0: 0xC360: Parsing digital output script table
    [ 9814.857068] [drm] nouveau 0000:03:00.0: Calling LVDS script 5:
    [ 9814.857076] [drm] nouveau 0000:03:00.0: 0xC2E2: Parsing digital output script table
    [11014.695460] [drm] nouveau 0000:03:00.0: Setting dpms mode 1 on lvds encoder (output 0)
    [11014.695472] [drm] nouveau 0000:03:00.0: Calling LVDS script 6:
    [11014.695483] [drm] nouveau 0000:03:00.0: 0xC2F1: Parsing digital output script table
    [11614.978628] [drm] nouveau 0000:03:00.0: Setting dpms mode 2 on lvds encoder (output 0)
    [13165.924530] [drm] nouveau 0000:03:00.0: Setting dpms mode 0 on lvds encoder (output 0)
    [13165.924542] [drm] nouveau 0000:03:00.0: Calling LVDS script 2:
    [13165.924553] [drm] nouveau 0000:03:00.0: 0xC360: Parsing digital output script table
    [13166.077072] [drm] nouveau 0000:03:00.0: Calling LVDS script 5:
    [13166.077082] [drm] nouveau 0000:03:00.0: 0xC2E2: Parsing digital output script table
    [15697.522198] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:16:d3:58:3a:ac:00:02:cf:e5:f1:62:08:00 SRC=130.67.15.198 DST=10.0.0.1 LEN=59 TOS=0x00 PREC=0x00 TTL=248 ID=13683 DF PROTO=UDP SPT=53 DPT=40038 LEN=39
    [15697.531998] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:16:d3:58:3a:ac:00:02:cf:e5:f1:62:08:00 SRC=130.67.15.198 DST=10.0.0.1 LEN=59 TOS=0x00 PREC=0x00 TTL=248 ID=13684 DF PROTO=UDP SPT=53 DPT=40038 LEN=39
    [15712.546663] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC=00:16:d3:58:3a:ac:00:02:cf:e5:f1:62:08:00 SRC=193.213.112.4 DST=10.0.0.1 LEN=59 TOS=0x00 PREC=0x00 TTL=248 ID=31569 DF PROTO=UDP SPT=53 DPT=57413 LEN=39
    linux-984r:~ #

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,439

    Default Re: Not able to start mySQL , Please help

    Not sure if this will help but try YaST>System>System services and Enable mysql. This will ensure that mysqld is started every time you log on.

  9. #9

    Default Re: Not able to start mySQL , Please help

    Thanks for trying, but this is where it all started or in fact this is where the first errormessage came from.

  10. #10
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Default Re: Not able to start mySQL , Please help

    I must have given you the wrong filename for the msqld logfile - i cannot remember if it is /var/log/mysqld.log or /var/log/mysql.log

    Take a look in the /var/log folder. There should be a logfile for mysql (probably called mysql.log or mysqld -- something like that), would you post the last few lines of that file once you find it?

    (I dont have access to a linux machine at the moment...work only uses windows )
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •