Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: lvm2-clvm will not install on opensuse 11.3 x86_64

  1. #1

    Default lvm2-clvm will not install on opensuse 11.3 x86_64

    Hi,

    Running 'zypper install lvm2-clvm' results in a message:

    Resolving package dependencies...

    Problem: nothing provides libcpg.so.2()(64bit) needed by lvm2-clvm-2.02.45-16.2.x86_64
    Solution 1: do not install lvm2-clvm-2.02.45-16.2.x86_64
    Solution 2: break lvm2-clvm by ignoring some of its dependencies

    So it cannot find the cpg library, which appears to be a part of openais (if I believe google).

    I have configured the following repositories:

    ftp://download.nvidia.com/opensuse/11.3/
    Index of /repositories/openSUSE:/11.3:/Contrib/standard
    Index of /pub/mirrors/packman/suse/11.3/
    Index of /repositories/home:/alex_sh/openSUSE_11.3
    Index of /suse/11.3/
    Index of /distribution/11.3/repo/non-oss
    Index of /distribution/11.3/repo/oss
    Index of /source/distribution/11.3/repo/oss
    Index of /update/11.3

    What could be the problem here? Am I just missing a repository or is cluster LVM not supported on opensuse 11.3?

    Cheers
    Erik

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,162

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    When it is yout intention to post the repos you have, you better post the output of
    Code:
    zypper lr -d
    Then we can see what the URLs are and what you have switched on/off.
    (and of course between CODE tags: Posting in Code Tags - A Guide)
    Henk van Velden

  3. #3

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    I thought I had the full URLs of all active repos but this is clearly not the case. Here is the requested info:

    Code:
    #  | Alias                          | Name                      | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
    ---+--------------------------------+---------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    1  | Kernel_repo_for_11.3           | Kernel repo for 11.3      | No      | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Kernel:/HEAD/openSUSE_11.3/               |        
    2  | download.nvidia.com-opensuse   | NVIDIA Repository         | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.3/                                            |        
    3  | download.opensuse.org-standard | Main Repository (Contrib) | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.3:/Contrib/standard/         |        
    4  | ftp.uni-erlangen.de-suse       | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/                           |        
    5  | home:alex_sh                   | home:alex_sh              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/home:/alex_sh/openSUSE_11.3/              |        
    6  | local_repo                     | local_repo                | No      | No      |   99     | rpm-md | dir:///root/repo                                                                    |        
    7  | openSUSE-11.3 11.3-1.82        | openSUSE-11.3 11.3-1.82   | No      | No      |   99     | yast2  | cd:///?devices=/dev/sr0                                                             |        
    8  | openSUSE:Factory:Contrib       | openSUSE:Factory:Contrib  | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.1/ |        
    9  | packman.inode.at-suse          | Packman Repository        | Yes     | Yes     |   99     | rpm-md | http://packman.inode.at/suse/11.3/                                                  |        
    10 | repo-debug                     | openSUSE-11.3-Debug       | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/                      |        
    11 | repo-non-oss                   | openSUSE-11.3-Non-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/                        |        
    12 | repo-oss                       | openSUSE-11.3-Oss         | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                            |        
    13 | repo-source                    | openSUSE-11.3-Source      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/                     |        
    14 | repo-update                    | openSUSE-11.3-Update      | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                                           |

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,162

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    Thanks, will make things easier for others.

    I have openSUSE 11.2, I do not use lvm2-clvm, but when I select it for install with YaST, no dependency poblems are popping up. Thus it may either be an 11.3 problem or a 64-bit problem.
    Henk van Velden

  5. #5

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    I also tried to select the 32 bit version (on my 64 bit OS) and it still could not find the same dependency. Looks like it is a generic 11.3 issue. Should I write a bug on this?

  6. #6
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    I can report same problem on openSUSE 11.3 64-bit:
    Code:
    andrew-desktop:~ # zypper in lvm2-clvm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libcpg.so.2()(64bit) needed by lvm2-clvm-2.02.45-16.2.x86_64
     Solution 1: do not install lvm2-clvm-2.02.45-16.2.x86_64
     Solution 2: break lvm2-clvm by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  7. #7
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    I can also report same problem on openSUSE 11.3 32-bit:
    Code:
    file1:~ # zypper in lvm2-clvm
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libcpg.so.2 needed by lvm2-clvm-2.02.45-16.2.i586
     Solution 1: do not install lvm2-clvm-2.02.45-16.2.i586
     Solution 2: break lvm2-clvm by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c] (c):
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  8. #8

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    There is already a bug for this: https://bugzilla.novell.com/show_bug.cgi?id=598470
    I added a link to this discussion to that bug.

  9. #9
    Join Date
    Nov 2009
    Location
    Belgrade, Serbia
    Posts
    1

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    it would be nice if you have read my comment and info about fixed packages on that specific bug report.
    So for your information mention package should be fixed in my home repo and you can test it by yourself
    Index of /repositories/home:/bmanojlovic:/cluster_11_3/openSUSE_11.3

  10. #10

    Default Re: lvm2-clvm will not install on opensuse 11.3 x86_64

    Quote Originally Posted by bmanojlovic View Post
    it would be nice if you have read my comment and info about fixed packages on that specific bug report.
    So for your information mention package should be fixed in my home repo and you can test it by yourself
    Index of /repositories/home:/bmanojlovic:/cluster_11_3/openSUSE_11.3
    I would like to wait until it has passed testing. I am not in a hurry. My current setup is still managable as in a KVM based setup the host and guest use different logical volumes. Would like to use it in a later stage to guard against administrative errors.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •