Results 1 to 4 of 4

Thread: opensuse 11.3 / KDE laggy

  1. #1

    Default opensuse 11.3 / KDE laggy


    I recently updated from 11.2 to 11.3. Since that change my laptop somehow lags. Meaning:
    1. First start of krunner takes 15-30 seconds.
    2. Poweroff menu takes 15-30seconds (first time only?!)
    3. Lags while usage during the day when switching applications or starting new ones.

    After some googling, I added the repositories:
    Index of /repositories/X11:/XOrg/openSUSE_11.3
    Index of /repositories/KDE:/Release:/45/openSUSE_11.3
    Index of /repositories/KDE:/Extra/openSUSE_11.3_KDE_Release_45

    And then did a sudo zypper dup. Which brought me from KDE 4.4.4 to 4.5.3

    Then I end with the following:
    1. Krunner takes some time while typing (greater 10 seconds)
    2. Poweroff menu takes 15-30seconds (first time only?!)
    3. Klipper shortcut does not work (Crtl+Alt+V)
    3.1 Klipper search does not work
    3.2 Klipper "more" does not work
    3.3 klipper therfore became useless

    I guess some problems might be unrelated to the laggy stuff, but I'm not able to solve the puzzle on my own. So the my questions are:
    1. How can I make the lags go away?
    2. How can I get a working KDE?
    3. How can I get a working klipper (if not solved by 2.)?

    Btw. I have a second laptop which has no problems at all. These two have totally different hardware. E.g. the making trouble runs on 64Bit opensuse 11.3 kde 4.5.3 and the good one on 32Bit opensuse 11.3 kde 4.4.4 (no troubles, no update).

    Btw. 2: for what ever reason I always get the following when doing zypper up:
    Loading repository data...
    Reading installed packages...
    The following package updates will NOT be installed:
      gstreamer-0_10-plugins-base Mesa-32bit python-distribute ruby-kde4 
    The following package is going to be upgraded:
    1 package to upgrade.
    Overall download size: 3.8 MiB. After the operation, additional 2.9 MiB will be used.
    Continue? [y/n/?] (y): y
    Retrieving package batik-1.7-201.2.noarch (1/1), 3.8 MiB (7.5 MiB unpacked)
    Retrieving: batik-1.7-201.2.noarch.rpm [done (1008.3 KiB/s)]
    Installing: batik-1.7-201.2 [error]
    Installation of batik-1.7-201.2 failed:
    (with --nodeps --force) Error: Subprocess failed. Error: RPM failed: error: unpacking of archive failed on file /usr/share/batik: cpio: rename failed - Is a directory

  2. #2
    Join Date
    Jun 2008
    Groningen, Netherlands
    Blog Entries

    Default Re: opensuse 11.3 / KDE laggy

    Re: BTW2 : rename the folder /usr/share/batik to /usr/share/batik.old, the installer rpm thinks it should be a file and tries to rename it.

    The laggyness maybe caused by a missing video card driver. What's your video card, brand and model please?

    BTW: updating from one version to the next is not a good idea. It often takes more time and energy to solve matters like you have, than it takes performing a fresh install and config.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

  3. #3

    Default Re: opensuse 11.3 / KDE laggy

    Thank you for your quick reply. I also started downloading the DVD . Btw. updating from one version to the one after the next should be a even worse idea than updating to the next. I also did my 11.2 to 11.3 via zypper. And in 1 out of 2 cases it did work very well.

    Okay, the next things that happend:
    I did a rm -rf .kde4 (made backup before)
    Then I tried to get the hardware information via YAST. Which made my system crash 2 times. For the third time I installed the debugging stuff, because I wanted to file a bug. Then it did work . So no bug to file.

    Now it looks like the rm did solve my problems. Now I try to setup up my KDE configuration piece by piece. For now it looks like the system is stable but don't count your chickens before they're hatched. And klipper also does what it should do.

    Btw. the video card (took me at least 30 minutes to get it, because of the crashs):
    Mobile Intel GM45 Express Chipset (Intel GMA X4500HD (IGP) was written on a internet page selling that laptop)

  4. #4

    Default Re: opensuse 11.3 / KDE laggy

    Sorry, this is kinda weird. It still lags. Clicking on the logout-button of the lock/logout widget causes to a freeze of the screen (the only thing that works is moving the cursor) for approximately 15 seconds. So my wife only uses a hard shutdown via power-key (takes 10 seconds ). And sometimes when starting any application via icon causes a 15 seconds lag. But I've not yet figured out a systematically thing about that yet.
    And klipper does not allow searching again (and I don't know why).

    Is a downgrade from a clean 11.3 DVD install working/doable without losing my home directories? Or is there any other solution to get rid of the lags?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts