Results 1 to 7 of 7

Thread: i'm trying to install, but get failed dependencies.

  1. #1

    Default i'm trying to install, but get failed dependencies.

    hello,

    i'm tying to install inspircd12 on me vps, but i have problems, this is what i get.

    Code:
    syhsyhsyh:~ # rpm -Uhv inspircd12-1.2.8-2.1.i586.rpm
    warning: inspircd12-1.2.8-2.1.i586.rpm: Header V3 DSA signature: NOKEY, key ID aa829aef
    error: Failed dependencies:
            libgnutls.so.26 is needed by inspircd12-1.2.8-2.1.i586
            libgnutls.so.26(GNUTLS_1_4) is needed by inspircd12-1.2.8-2.1.i586
            libmysqlclient_r.so.15 is needed by inspircd12-1.2.8-2.1.i586
            libmysqlclient_r.so.15(libmysqlclient_15) is needed by inspircd12-1.2.8-2.1.i586
            libpq.so.5 is needed by inspircd12-1.2.8-2.1.i586
    i have tryed to install libgnutls.so.26 manual but it is still not working.

    sorry for me crappy english.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,825
    Blog Entries
    15

    Default Re: i'm trying to install, but get failed dependencies.

    Hi
    You don't indicate the openSUSE version your running, but anyway you need to install libgnutls26, libmysqlclient_r15 and postgresql-libs for whatever version of openSUSE your running.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: i'm trying to install, but get failed dependencies.

    Hi try this to install inspircd12. This assumes you are running openSUSE 11.3:
    Code:
    # zypper ar -f http://download.opensuse.org/repositories/server:/irc/openSUSE_11.3 serverirc
    # zypper refresh
    # zypper in inspircd12
    # zypper rr serverirc
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  4. #4

    Default Re: i'm trying to install, but get failed dependencies.

    yes, i'm runnning openSUSE 11.3.

    @ah7013 i will try that

  5. #5

    Default Re: i'm trying to install, but get failed dependencies.

    @ah7013 still not working,

    Code:
    syhsyhsyh:~ # zypper ar -f http://download.opensuse.org/repositories/server:/irc/openSUSE_11.3 serverirc
    Adding repository 'serverirc' [done]
    Repository 'serverirc' successfully added
    Enabled: Yes
    Autorefresh: Yes
    URI: http://download.opensuse.org/repositories/server:/irc/openSUSE_11.3
    
    syhsyhsyh:~ # zypper refresh
    New repository or package signing key received:
    Key ID: 410F3E90AA829AEF
    Key Name: server:irc OBS Project <server:irc@build.opensuse.org>
    Key Fingerprint: E6EDA6968E299E73D18E604A410F3E90AA829AEF
    Repository: serverirc
    
    Do you want to reject the key, trust temporarily, or trust always? [R/t/a/?]: t
    Retrieving repository 'serverirc' metadata [done]
    Building repository 'serverirc' cache [done]
    All repositories have been refreshed.
    syhsyhsyh:~ # zypper in inspircd12
    Loading repository data...
    Reading installed packages...
    'inspircd12' not found.
    Resolving package dependencies...
    Nothing to do.

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: i'm trying to install, but get failed dependencies.

    Don't know what's going wrong. Go here: software.opensuse.org: Search Results , search for 'inspirc' and use the one-click installer. That should work.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7

    Default Re: i'm trying to install, but get failed dependencies.

    Hello guys,

    I had a similar problem , but everything is now working as it should , try those two steps .

    First make sure that ur kernel is up-to-date:

    Code:
    Zypper in update
    Second , install all required/missed modules on ur opensuse box :
    Code:
    zypper in gcc make automake autoconf kernel-source kernel-syms kernel-devel
    Don't forget to make this under a sudo'ers account .(sudo [command] )

    Regards
    Jacky

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •