Results 1 to 7 of 7

Thread: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

  1. #1

    Default Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Just like the title says...I can set it but when I reboot it goes back to default
    thanks in advance

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Quote Originally Posted by gqpolo View Post
    Just like the title says...I can set it but when I reboot it goes back to default
    thanks in advance
    I can reproduce this. It also used to work when 11.3 was first released. I sent the openSUSE LXDE packager a PM on IRC, so next time he logs on he should be notified.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Quote Originally Posted by gqpolo View Post
    Just like the title says...I can set it but when I reboot it goes back to default
    thanks in advance
    OK, I was able to reproduce this , and then noted there was a bug report on it. I followed advice in bug report and fixed this.

    Bug report is here: https://bugzilla.novell.com/show_bug.cgi?id=651089

    I added the repository:
    Code:
    http://download.opensuse.org/repositories/X11:/lxde/openSUSE_11.3/
    and installed:
    Code:
    pcmanfm-lang-0.9.8_rc2-1.3.1
    pcmanfm-0.9.8_rc2-72.2
    libfm-0.1.14_rc2-75.2
    libfm-gtk0-0.1.14_rc2-75.2
    lxde-common-0.5.0-48.2
    lxde-common-branding-openSUSE-11.3-10.3.1
    libfm0-0.1.14_rc2-2.3.1
    Note bug report says updated were: libfm, libfm-debuginfo, libfm-debugsource, libfm-devel, libfm-doc, libfm-gtk0, libfm-gtk0-debuginfo, libfm0, libfm0-debuginfo, lxde-common, lxde-common-branding-openSUSE, lxde-common-branding-upstream, pcmanfm, pcmanfm-debuginfo, pcmanfm-debugsource, pcmanfm-lang
    ... but since I did not have all those installed I did not update all them. I only updated the one's I had installed.

    After updating I removed ~/.config/pcmanfm/pcmanfm.conf

    That was important. If I did not do that then the fix did not work. Then I changed my wall paper.

    I restarted LXDE and the wall paper changed and change remained !

    Good luck.

  4. #4

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Thanks for the reply...but when I try to install those packages it says it cant find them and I tried the find on web function too...I did add the repo you said too...what am I doing wrong?

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Quote Originally Posted by gqpolo View Post
    Thanks for the reply...but when I try to install those packages it says it cant find them and I tried the find on web function too...I did add the repo you said too...what am I doing wrong?
    Please provide the output of :
    Code:
    zypper lr -d
    so we can check what you stated about the repository is correct (ie do a quality check).

    I suspect thou, you may not figured out how to use YaST > Software > Software Management to do such updates.

    Please take a look at these images on an alsa updat site showing how to update alsa. Yes, it is completely different app, but the same update philosophy applies: SDB:Alsa-update - openSUSE ie :


    Note the 'versions' tab needs to be used to ensure the correct version is updated. This is all pretty basic stuff that for some reason a lot of new users fail to pickup.

    Now the above example is using the 'qt' version of YaST (and I can't recall what the gtk version of YaST looks like here). I also can't recall if LXDE comes with that qt version launched by default or if it comes with the 'gtk' YaST launched by default, nor can I remember if I had to edit things to launch that qt YaST version automatically ( yes, I think old age is making me senile). But you can always launch it (assuming YasT is NOT running) from a terminal by typing:
    Code:
    su -
    yast --qt
    Then be careful to ensure you select the version to update in the versions tab.

  6. #6

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    zypper lr -d
    # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    --+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------+--------
    1 | 11.3_updates | 11.3_updates | Yes | Yes | 99 | rpm-md | Index of /update/11.3 |
    2 | LXDE | LXDE | Yes | Yes | 99 | rpm-md | Index of /repositories/X11:/lxde/openSUSE_11.3 |
    3 | google-chrome | google-chrome | Yes | Yes | 99 | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386 |
    4 | openSUSE-11.3-NON-Oss | openSUSE-11.3-NON-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.3/repo/non-oss |
    5 | openSUSE-11.3-Oss | openSUSE-11.3-Oss | Yes | No | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    6 | repo-debug | openSUSE-11.3-Debug | No | Yes | 99 | NONE | Index of /debug/distribution/11.3/repo/oss |
    7 | repo-oss | openSUSE-11.3-Oss | Yes | Yes | 99 | yast2 | Index of /distribution/11.3/repo/oss |
    8 | repo-source | openSUSE-11.3-Source | Yes | Yes | 99 | yast2 | Index of /source/distribution/11.3/repo/oss

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,549
    Blog Entries
    37

    Default Re: Opensuse 11.3 LXDE Keeps Changing My Wallpaper Back To Default

    Quote Originally Posted by gqpolo View Post
    Code:
    zypper lr -d
    # | Alias                 | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                | Service
    --+-----------------------+-----------------------+---------+---------+----------+--------+--------------------------------------------------------------------+--------
    1 | 11.3_updates          | 11.3_updates          | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                          |        
    2 | LXDE                  | LXDE                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/lxde/openSUSE_11.3/ |        
    3 | google-chrome         | google-chrome         | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                  |        
    4 | openSUSE-11.3-NON-Oss | openSUSE-11.3-NON-Oss | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/       |        
    5 | openSUSE-11.3-Oss     | openSUSE-11.3-Oss     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss            |        
    6 | repo-debug            | openSUSE-11.3-Debug   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/     |        
    7 | repo-oss              | openSUSE-11.3-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/           |        
    8 | repo-source           | openSUSE-11.3-Source  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/
    OK, some comments, ...

    You have OSS twice. There is no need for that (ie 5 & 7 are the same). So disable #7.

    Unless you are very very heavily into Linux development, there is no need to enable repos-source (#8). So disable that #8.

    For now I recommend you disable the google-chrome repos #3 (at least until we sort this). You could also consider adding Packman repos.

    So the LXDE repository is correct. The only thing stopping you from updating the apps I told you about is your unfamiliarity with YaST Software Management. I gave you a sketch indicating where you need look to update - So GO UPDATE !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •