Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: cannot use trashcan

  1. #1
    Join Date
    Nov 2010
    Location
    Ferragudo, Portugal
    Posts
    66

    Default cannot use trashcan

    Hi,

    after ripping a dvd I removed the large file succesfully with rm command.
    since then I get a message "trashcan full, empty manually" when I want to trash a small file.
    Can is empty and has a capacity of 500 MB
    How to get the can operational again?
    Don't fix it if it aint broke

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: cannot use trashcan

    So you may need to empty the contents of the tmp folder. You can cause this to happen each time you restart by setting this value:

    Open /etc/sysconfig/cron, search for a line saying

    Code:
    CLEAR_TMP_DIRS_AT_BOOTUP="no"
    ...and edit "no" to "yes". This could also be done via GUI: YaST → "Editor for /etc/sysconfig".

    Be aware that some abilities to restore removed files and other such things will be gone when the tmp folder is cleared.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,729
    Blog Entries
    20

    Default Re: cannot use trashcan

    Using 'rm' with limited knowledge is not something I would recommend. You can enable 'Delete' in the context menu of right click, in both kde and gnome, or just use SHIFT+Delete.

    Are you sure you only removed the dvd image?

    Also
    http://forums.opensuse.org/english/i...iles-boot.html
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,662
    Blog Entries
    14

    Default Re: cannot use trashcan

    @jdcmdaniel: simply emptying /tmp at each boot IMO is not a good suggestion. Even so, better not done by editing the system cron file, if necessary rather through Yast - System - etc/sysconfig editor. Much less chance of unwanted harm being done.

    @annevance:
    Open Dolphin, set it to show hidden files, then
    click .local
    click share
    click Trash
    Select everything in there (folders 'files' and 'info', a file 'metadata), hit Shift-Del, confirm deletion.
    Log out, log in, and Trash will be recreated.

    Please let us know if this worked.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: cannot use trashcan

    Quote Originally Posted by Knurpht
    @jdcmdaniel: simply emptying /tmp at each boot IMO is not a good suggestion. Even so, better not done by editing the system cron file, if necessary rather through Yast - System - etc/sysconfig editor. Much less chance of unwanted harm being done.
    Um... emptying /tmp at boot is pretty much the only approach that makes sense. What would you suggest? And where's the possible risk (or whatever you had in mind)?

    Furthermore, using the /etc/sysconfig editor as you described does nothing else than replacing the "no" with a "yes", where's the difference and, again, the possible risk? Frankly, your suggestions seem a bit cryptic.

  6. #6
    Join Date
    Nov 2010
    Location
    Ferragudo, Portugal
    Posts
    66

    Default Re: cannot use trashcan

    I had to use Yast and set the value to "yes" after reboot, cron shows the value Yes, but I understand that I have to wait 15 minutes for the cronjob to be active.
    Also set Dolphin to show hidden files, but what does it tell me? the trashcan still shows empty.

    I realize I have to be carefull with the commandline. But that appeared to be the only way to get rid of an 1GB file.
    Don't fix it if it aint broke

  7. #7
    Join Date
    Nov 2010
    Location
    Ferragudo, Portugal
    Posts
    66

    Default Re: cannot use trashcan

    Waiting is over, tmp file now has 4 almost empty folders (total 1KB)

    But when I want to trash a 50KB file it still says "The trash has reached its maximum size, cleanup the trash manually"

    What to do next ?
    Don't fix it if it aint broke

  8. #8
    Join Date
    Mar 2010
    Location
    Southern Europe
    Posts
    352

    Default Re: cannot use trashcan

    I realize I have to be carefull with the commandline. But that appeared to be the only way to get rid of an 1GB file.
    You could get rid of it through the file manager (dolphin, konqueror...): right click -> delete (you need to enable "Show delete command" in "Configure Dolphin"), or with Shift+Delete after selecting the file.
    Also set Dolphin to show hidden files, but what does it tell me? the trashcan still shows empty.
    Are you sure that you did what Knurpht says? You have to go to ~/.local/share/Trash and delete everything there. Then log out and log in again.

    Another question to you and other people that posted in this thread: Does rm have something to do with Trash? I thought that using rm is like deleting and not like moving to trash.

  9. #9
    Join Date
    Nov 2010
    Location
    Ferragudo, Portugal
    Posts
    66

    Default Re: cannot use trashcan

    @Knurpht

    Where should I find .local ? after showing hidden files in Dolphin.
    Don't fix it if it aint broke

  10. #10
    Join Date
    Jun 2008
    Location
    Berlin
    Posts
    2,061

    Default Re: cannot use trashcan

    Quote Originally Posted by wrbbt
    Another question to you and other people that posted in this thread: Does rm have something to do with Trash? I thought that using rm is like deleting and not like moving to trash.
    Yes absolutely. The help given here is actually pretty offtopic.

    Let's summarize: the Trash *is* empty (as it should be after using 'rm' on it), yet KDE reports it being full. That's the problem, not some /tmp-setting (although emptying it at boot is recommended unless you want a overflowing /-partition).

    /tmp != ~/.local/share/Trash.

    Edit:

    Quote Originally Posted by annevance
    Where should I find .local ?
    Hm, you can not find it? Please post the output of

    Code:
    ls -l ~/.local/
    ## as user!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •