Results 1 to 2 of 2

Thread: pppd error in openSUSE

  1. #1
    Join Date
    Dec 2010
    Location
    South Africa
    Posts
    33

    Default pppd error in openSUSE

    Good day everyone

    I recently encountered an error with pppd on both openSUSE 11.2 and 11.3.

    I use umtsmon (which uses pppd) to connect to the internet with my 3G device.
    Yesterday for some reason it just plainly refused to connect to the internet. I have been using the same configuration for almost a year now without any issues. I tried it on 4 different computers running 11.2 and 11.3 and all of them failed. Thinking that it is the hardware I borrowed a windows laptop and tested it on that, only to find that it works flawlessly. On my network server I sometimes use the device as a backup and activate it with "ifup modem0", for some reason this also now fails.

    After doing some troubleshooting I managed to extract the following from pppd.

    Running it with my user account:
    pppd options in effect:
    debug debug debug # (from command line)
    updetach # (from command line)
    idle 7200 # (from command line)
    dump # (from command line)
    active-filter xxx # [don't know how to print value] # (from /etc/ppp/filters)
    noauth # (from /etc/ppp/options)
    /dev/ttyUSB1 # (from command line)
    460800 # (from command line)
    lock # (from command line)
    crtscts # (from command line)
    modem # (from command line)
    asyncmap 0 # (from command line)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    lcp-restart 2 # (from /etc/ppp/options)
    lcp-max-configure 60 # (from /etc/ppp/options)
    noipdefault # (from /etc/ppp/options)
    defaultroute # (from command line)
    replacedefaultroute # (from command line)
    usepeerdns # (from command line)
    noipx # (from command line)
    using channel 5
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyUSB1
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0xb694a5c6> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x8 <asyncmap 0x0> <auth chap MD5> <magic 0x279fba5> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0x8 <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0xb694a5c6> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0x9 <asyncmap 0x0> <magic 0x279fba5> <pcomp> <accomp>]
    sent [LCP ConfAck id=0x9 <asyncmap 0x0> <magic 0x279fba5> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0xb694a5c6]
    sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15> <bsd v1 15>]
    sent [IPCP ConfReq id=0x1 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0xa magic=0x279fba5]
    rcvd [LCP EchoRep id=0x0 magic=0x279fba5 b6 94 a5 c6]
    rcvd [LCP ProtRej id=0xb 80 fd 01 01 00 0f 1a 04 78 00 18 04 78 00 15 03 2f]
    Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
    rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <compress VJ 0f 01> <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    sent [LCP EchoReq id=0x1 magic=0xb694a5c6]
    IPCP: timeout sending Config-Requests
    sent [LCP TermReq id=0x2 "No network protocols running"]
    Terminating on signal 15
    sent [LCP TermReq id=0x3 "User request"]
    Connection terminated.
    Modem hangup

    Running it as root:
    pppd options in effect:
    debug debug debug # (from command line)
    updetach # (from command line)
    idle 7200 # (from command line)
    dump # (from command line)
    active-filter xxx # [don't know how to print value] # (from /etc/ppp/filters)
    noauth # (from /etc/ppp/options)
    /dev/ttyUSB0 # (from command line)
    460800 # (from command line)
    lock # (from command line)
    crtscts # (from command line)
    modem # (from command line)
    asyncmap 0 # (from command line)
    lcp-echo-failure 4 # (from /etc/ppp/options)
    lcp-echo-interval 30 # (from /etc/ppp/options)
    lcp-restart 2 # (from /etc/ppp/options)
    lcp-max-configure 60 # (from /etc/ppp/options)
    novj # (from command line)
    noipdefault # (from /etc/ppp/options)
    defaultroute # (from command line)
    usepeerdns # (from command line)
    nobsdcomp # (from command line)
    noipx # (from command line)
    using channel 6
    Using interface ppp0
    Connect: ppp0 <--> /dev/ttyUSB0
    sent [LCP ConfReq id=0x1 <asyncmap 0x0> <magic 0x658d9f4c> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0xc <asyncmap 0x0> <auth chap MD5> <magic 0x27d81fc> <pcomp> <accomp>]
    No auth is possible
    sent [LCP ConfRej id=0xc <auth chap MD5>]
    rcvd [LCP ConfAck id=0x1 <asyncmap 0x0> <magic 0x658d9f4c> <pcomp> <accomp>]
    rcvd [LCP ConfReq id=0xd <asyncmap 0x0> <magic 0x27d81fc> <pcomp> <accomp>]
    sent [LCP ConfAck id=0xd <asyncmap 0x0> <magic 0x27d81fc> <pcomp> <accomp>]
    sent [LCP EchoReq id=0x0 magic=0x658d9f4c]
    sent [CCP ConfReq id=0x1 <deflate 15> <deflate(old#) 15>]
    sent [IPCP ConfReq id=0x1 <addr 0.0.0.0> <ms-dns1 0.0.0.0> <ms-dns2 0.0.0.0>]
    rcvd [LCP DiscReq id=0xe magic=0x27d81fc]
    rcvd [LCP EchoRep id=0x0 magic=0x27d81fc 65 8d 9f 4c]
    rcvd [LCP ProtRej id=0xf 80 fd 01 01 00 0c 1a 04 78 00 18 04 78 00]
    Protocol-Reject for 'Compression Control Protocol' (0x80fd) received
    rcvd [IPCP ConfNak id=0x1 <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14> <ms-wins 10.11.12.13> <ms-wins 10.11.12.14>]
    sent [IPCP ConfReq id=0x2 <addr 0.0.0.0> <ms-dns1 10.11.12.13> <ms-dns2 10.11.12.14>]
    Modem hangup
    Connection terminated.

    I have no idea why pppd would break all of a sudden but I expect it might have been an update that broke it since I have automated updates on all of my systems.

    Thanks in advance.

  2. #2
    Join Date
    Dec 2010
    Location
    South Africa
    Posts
    33

    Default Re: pppd error in openSUSE

    I found the problem

    My SP disabled my InternetVPN APN. When using the normal Internet APN it seems to work fine.

    Thanks in any case. Off to go and harass my SP.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •