Results 1 to 5 of 5

Thread: VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

  1. #1

    Default VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

    at the end of the installation of VirtualBox 4.0 I get:
    Starting VirtualBox kernel modules
    failed (modprobe vboxnetflt failed. Please use 'dmesg' to find out why)

    # modprobe vboxnetflt
    dkms FATAL: Error inserting vboxnetflt (/lib/modules/2.6.34.7-0.5-desktop/updates/vboxnetflt.ko): Invalid module format

    but things things seem to be working fine

    per the vbox forum vboxnetflt is the Bridged networking module and I was told it's a dkms issue (they asked if it was installed, it was from the Packman repo but I did rebuild it from their src.rpm which did not help).

    As I don't use bridged networks it's not an issue for me but seems relevant

    running 11.3 64bit
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  2. #2
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

    Since some time I've also tested the DKMS package from Pacman, I noticed some problems with it, I think it's loaded loaded too late in the boot process. I changed it to load at boot in the runtime level editor in yast>system, switch to expert view and toggle dkms_autoinstaller to be started at boot.
    Merry Christmas to you all!

  3. #3

    Default Re: VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

    thanks, added it to boot but probably won't be testing cause I rm'ed the rpm and Vbox is running fine so until the next upgrade .........., also posted the suggestion to the Vbox forum

    regards,
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4
    Join Date
    Jun 2008
    Location
    Skogås Sweden
    Posts
    638

    Default Re: VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

    Its's shureley hard to test something that's supposed to interact in the boot process when it's needed, I've done some tests but we really need feedback from more users.

  5. #5

    Default Re: VirtualBox installation error/warning " failed (modprobe vboxnetflt failed."

    Quote Originally Posted by hank_se View Post
    Since some time I've also tested the DKMS package from Pacman, I noticed some problems with it, I think it's loaded loaded too late in the boot process. I changed it to load at boot in the runtime level editor in yast>system, switch to expert view and toggle dkms_autoinstaller to be started at boot.
    Merry Christmas to you all!

    don't think this is the solution to this problem did as suggested and just rebooted, still get:

    # modprobe vboxnetflt
    dkms FATAL: Error inserting vboxnetflt (/lib/modules/2.6.34.7-0.5-desktop/updates/vboxnetflt.ko): Invalid module format
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •