Results 1 to 4 of 4

Thread: Strange repo initialization error.

  1. #1
    Join Date
    Jun 2008
    Location
    Kansas City, Missouri
    Posts
    114

    Default Strange repo initialization error.

    Starting Yast and then config. repos. gives this error:

    There were errors while restoring the repository configuration.
    Error refreshing service Packman Repo (http://packman.inode.at/suse/11.3/packman.repo):
    Parse error: repoindex.xml[1] Document is empty

    If I continue my repo list and software management both come up okay and function as they should (nothing noted yet anyway). Is this just something that glitched when adding the Packman repo and the file repoindex.xml[1] should be deleted?
    " It wouldn't dare! " - Shaggyman



  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Strange repo initialization error.

    For Packman and openSUSE 11.3, just delete your present Packman repository and add this one I use instead:

    Code:
    http://packman.jacobs-university.de/suse/11.3/
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    Kansas City, Missouri
    Posts
    114

    Default Re: Strange repo initialization error.

    Quote Originally Posted by jdmcdaniel3 View Post
    For Packman and openSUSE 11.3, just delete your present Packman repository and add this one I use instead:

    Code:
    http://packman.jacobs-university.de/suse/11.3/
    Thank You,
    Even deleted and replaced all the repos. Thanks for the suggestion but deleting the existing Packman repo and then putting it back or one of the mirrors is irrelevant. Everything works fine including the package management and refresh of repositories. I just keep getting this annoying error about and empty file and I'd like to make it go away.
    " It wouldn't dare! " - Shaggyman



  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Strange repo initialization error.

    Well, I can only say that the address that you posted gives me a 404 - Not Found Error.

    So, get rid of this address and add the right one back in as I suggested. I would ask that you run the following terminal command and post the results:

    Code:
    zypper repos
    Here is the output when I run the command:

    Code:
    #  | Alias                               | Name                                | Enabled | Refresh
    ---+-------------------------------------+-------------------------------------+---------+--------
    1  | /vlc                                | /vlc                                | No      | No     
    2  | KDE3                                | KDE3                                | Yes     | Yes    
    3  | Updates for openSUSE 11.3 11.3-1.82 | Updates for openSUSE 11.3 11.3-1.82 | Yes     | Yes    
    4  | mozilla                             | mozilla                             | Yes     | Yes    
    5  | openSUSE-11.3 11.3-1.82             | openSUSE-11.3 11.3-1.82             | No      | No     
    6  | packman                             | packman                             | Yes     | Yes    
    7  | repo-debug                          | openSUSE-11.3-Debug                 | No      | Yes    
    8  | repo-non-oss                        | openSUSE-11.3-Non-Oss               | Yes     | Yes    
    9  | repo-oss                            | openSUSE-11.3-Oss                   | Yes     | Yes    
    10 | repo-source                         | openSUSE-11.3-Source                | No      | Yes
    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •