Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: KDE picks wrong soundcard in 11.2

  1. #1

    Default KDE picks wrong soundcard in 11.2

    New install of 11.2 with KDE 4.

    I have two soundcards in my system, one on the motherboard and a soundblaster.

    I multiboot and all FIVE other images, including SUSE 10.1 with KDE 3, use the soundblaster so that is where the speakers are plugged in.

    11.2 insists on configuring the motherboard sound card for KDE, even when I do a fresh install setting the soundblaster as the primary sound card at installation time or when I remove the motherboard sound card from the configuration after installation. KDE 4 never even lists the soundblaster as a known card.

    Any way to fix or work around this restriction?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE picks wrong soundcard in 11.2

    You must be missing something here.
    In Yast > Hardware > Sound
    Do you see both cards?

    In KDE Desktop Settings: Hardware > Multimedia > Phonon
    Do you see both cards

    In Kmix can you see both cards?
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: KDE picks wrong soundcard in 11.2

    caf4926 has the correct advice IMHO.

    You need to ensure that card-0 in YaST > Hardware > Sound is the card in which you wish the sound to come out of. You can either delete the 'other' card in YaST > Hardware > Sound (temporary delete which only unconfigures that unwanted card, and note you can add it back later) or simply go to YaST > Hardware > Sound > Other and change the order of sound cards.

    Then you need to go to KMENU > Configure Desktop > Multimedia and ensure the ORDER of sound devices you have there matches the order of sound devices you have in YaST > Hardware > Sound.

    And in some cases (in ADDITION to the above) you also can run the diagnostic script:
    Code:
    /usr/sbin/alsa-info.sh
    and examine the order of sound devices there to ensure it is the same.

    The order of sound devices is critical to get this working.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: KDE picks wrong soundcard in 11.2

    Quote Originally Posted by nospam990 View Post
    ....11.2 insists on configuring the motherboard sound card for KDE, even when I do a fresh install setting the soundblaster as the primary sound card at installation time or when I remove the motherboard sound card from the configuration after installation.
    If my memory serves me correct, the file /etc/modprobe.d/50-sound.conf keeps a record of the sound card configuration (it used to be /etc/modprobe.d/sound.conf, but I think it changed in 11.2). By running YaST you change the order of sound devices. YaST should have your sound blaster card listed (as should the 50-sound.conf file) assuming your hardware is not broken.

  5. #5
    Join Date
    Jun 2008
    Location
    Stoney Stanton - England
    Posts
    1,093

    Default Re: KDE picks wrong soundcard in 11.2

    if you are using the soundblaster card why don't you disable the onboard soundcard in the bios?

  6. #6

    Default Re: KDE picks wrong soundcard in 11.2

    Progress .... sort of. I now think KDE is trying to use the correct card.

    Now I get a message box that pops up (briefly) when I try to start Kaffeine.

    Notification from Phonon: KDE's Multimedia Library
    The audio playback device Ensoniq AudioPCI ENS1371 (ES1371
    DAC2/ADC) does not work
    Falling back to .

    Play Test Sound on the card works in Yast>Hardware>Sound

    I spot nothing that seems significant to me in /var/log/

    Any suggestions for what to try or look at next?

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE picks wrong soundcard in 11.2

    If test sound in Yast works
    Now check your Kmix settings and make sure you have the mixer volume On
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: KDE picks wrong soundcard in 11.2

    The problem does not occur for the root userid. Is there a permission that non-root users need that I may have missed?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: KDE picks wrong soundcard in 11.2

    Quote Originally Posted by nospam990 View Post
    The problem does not occur for the root userid. Is there a permission that non-root users need that I may have missed?
    No
    And why are you logging in as root?

    Check @oldcpu's guide
    SDB:Audio troubleshooting - openSUSE

    You could try as su -
    Code:
    rcalsasound restart
    then reboot
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,491
    Blog Entries
    37

    Default Re: KDE picks wrong soundcard in 11.2

    Quote Originally Posted by nospam990 View Post
    The problem does not occur for the root userid. Is there a permission that non-root users need that I may have missed?
    If you believe it to be a permissions problem, then you can add your regular user to group 'audio'. There is guidance here for that in step-6

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •