Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Compiz freezes opensuse 11.3

  1. #1

    Default Compiz freezes opensuse 11.3

    Hi all,

    I have an 64 bit based laptop with openSuse 11.3 KDE installed on it, my grafic card is a Geforce GT330M and I have the last official drivers from Nvidia installed Version: 260.19.29

    My problem is that I have always freezes of the system that allow me to move the mouse, but I cannot do anything more.


    Anyone can help me ?

    Thanks

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Compiz freezes opensuse 11.3

    Hi all,

    I have an 64 bit based laptop with openSuse 11.3 KDE installed on it, my grafic card is a Geforce GT330M and I have the last official drivers from Nvidia installed Version: 260.19.29

    My problem is that I have always freezes of the system that allow me to move the mouse, but I cannot do anything more.


    Anyone can help me ?

    Thanks
    This sounds like a hardware problem, but can be caused by a driver problem. When you say you installed the nVidia proprietary video driver, how did you install it? Did you load the nVidia driver the hard way? Did you add the kernel option nomodeset to your Grub menu.lst file? Did you set the kernel option NO_KMS_IN_INITRD = Yes in the /etc/sysconfig Editor? Finally, what is your present kernel version? Have you loaded the most recent kernel updates for openSUSE 11.3?

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3

    Default Re: Compiz freezes opensuse 11.3

    Quote Originally Posted by jdmcdaniel3 View Post
    This sounds like a hardware problem, but can be caused by a driver problem. When you say you installed the nVidia proprietary video driver, how did you install it? Did you load the nVidia driver the hard way? Did you add the kernel option nomodeset to your Grub menu.lst file? Did you set the kernel option NO_KMS_IN_INITRD = Yes in the /etc/sysconfig Editor? Finally, what is your present kernel version? Have you loaded the most recent kernel updates for openSUSE 11.3?

    Thank You,
    Im not really sure want the hard way means, but think thats what I did. I downloaded the file and simply executed the *.run file. I didnt add any option in the menu.lst file and to the /etc/sysconfig . My kernel version is 2.6.34.7-0.5

    thanks

  4. #4
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Compiz freezes opensuse 11.3

    So, in order to install the nVidia driver and get it to work, you must add the nomodeset kernel load option in your grub menu.lst file. Here is an example from my menu.lst file.

    Code:
     ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.3 - 2.6.34.7-0.5
        savedefault 3
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.34.7-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part2 resume=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part1 splash=silent quiet nomodeset showopts vga=0x346
        initrd /boot/initrd-2.6.34.7-0.5-desktop
    To edit this file using KDE I would enter the menu Run Command:

    Code:
    kdesu kwrite /boot/grub/menu.lst
    To just look, you can open a terminal session and type:

    Code:
    cat /boot/grub/menu.lst
    To set the NO_KMS_IN_INITRD = Yes, open YaST / System / etc/sysconfig Editor / System / Kernel / NO_KMS_IN_INITRD change to Yes and press OK in bottom right. Reboot when done for these to take effect. I can say that I did not think you could even load the nVidia driver if the nomodeset command was not used in your menu.lst file.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  5. #5
    upscope NNTP User

    Default Re: Compiz freezes opensuse 11.3

    jdmcdaniel3 wrote:

    >
    > So, in order to install the nVidia driver and get it to work, you must
    > add the nomodeset kernel load option in your grub menu.lst file. Here
    > is an example from my menu.lst file.
    >
    >
    > Code:
    > --------------------
    > ###Don't change this comment - YaST2 identifier: Original name:
    > ###linux###
    > title Desktop -- openSUSE 11.3 - 2.6.34.7-0.5
    > savedefault 3
    > root (hd0,1)
    > kernel /boot/vmlinuz-2.6.34.7-0.5-desktop
    > root=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-

    part2
    > resume=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-

    part1
    > splash=silent quiet *nomodeset *showopts vga=0x346 initrd
    > /boot/initrd-2.6.34.7-0.5-desktop
    > --------------------
    > To edit this file using KDE I would enter the menu Run Command:
    >
    >
    > Code:
    > --------------------
    > kdesu kwrite /boot/grub/menu.lst
    > --------------------
    > To just look, you can open a terminal session and type:
    >
    >
    > Code:
    > --------------------
    > cat /boot/grub/menu.lst
    >
    > --------------------
    > To set the NO_KMS_IN_INITRD = Yes, open YaST / System / etc/sysconfig
    > Editor / System / Kernel / NO_KMS_IN_INITRD change to Yes and press OK
    > in bottom right. Reboot when done for these to take effect. I can
    > say that I did not think you could even load the nVidia driver if the
    > *nomodeset* command was not used in your menu.lst file.
    >
    > Thank You,
    >

    I have 11.3 and I do not have NOMODESET in my grub menu. I run the
    Nvidia 260-19-21 driver installed from YaST and the Nvidia Repo. I do
    have No_KMS set to yes. I experience a slight delay at times when
    Desktop Effects is enabled. Have not had time to look into it.

    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 10|
    Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Compiz freezes opensuse 11.3

    I have 11.3 and I do not have NOMODESET in my grub menu. I run the
    Nvidia 260-19-21 driver installed from YaST and the Nvidia Repo. I do
    have No_KMS set to yes. I experience a slight delay at times when
    Desktop Effects is enabled. Have not had time to look into it.

    --
    Russ
    Russ, while your PC does not go up in flames without the nomodeset command, it is still recommended if you are loading the nVidia proprietary binary video driver to use this kernel load option. I found this explanation of the nomodeset command:

    > What is "nomodeset" SUPPOSED to do?

    The newest kernels have (God knows why) moved the video
    mode setting into the kernel (the only explanation I've
    ever seen for why this is a good idea is that the monitor
    goes "click" less often that way). So all the programming
    of the hardware specific clock rates and registers on the
    video card happen in the kernel during initial boot
    rather than in the X driver when the X server starts.
    (And the X driver developers hate having to deal with
    both possibilities, so they'd really like no one to ever
    use nomodeset).

    The "nomodeset" kernel parameter turns off this feature
    and leaves the system BIOS video setting in place during
    boot.

    Because the kernel may need the video driver loaded to
    do mode setting, the nouveau driver is probably included
    in the initrd image, hence the need for both "nomodeset"
    and "rdblacklist=nouveau" to keep the kernel out of the
    video mode business so the binary nvidia driver can
    then do mode setting when X starts with no conflicting
    drivers loaded in the kernel.
    Thanks Steven P. Ulrick for your explanation of nomodeset. Following is a note from the nVidia HOWTO on installing their driver the hard way:

    NOTE: The nvidia installer does not work as long as a Xserver is still
    running and the nvidia kernel module is still loaded. Therefore
    please boot into runlevel 3 by specifying "3" as kernel boot
    option or switch to runlevel 3 ("init 3") and unload the kernel
    module ("rmmod nvidia") before running the nvidia installer.
    Since openSUSE 11.3 use "nomodeset" as additional kernel boot
    option.
    Here is a excerpt from the openSUSE 11.3 release notes:

    Initializing Graphics with KMS (Kernel Mode Setting)

    With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.
    In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.
    On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS). On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).
    And the best part about using nomodeset is, it costs nothing to use and follows the suggestions of many experts on the subject.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    upscope NNTP User

    Default Re: Compiz freezes opensuse 11.3

    jdmcdaniel3 wrote:

    >
    >> I have 11.3 and _*I_do_not_have_NOMODESET_in_my_grub_menu*_. I run
    >> the Nvidia 260-19-21 driver installed from YaST and the Nvidia Repo.
    >> I do have No_KMS set to yes. I experience a slight delay at times
    >> when Desktop Effects is enabled. Have not had time to look into it.
    >>
    >> --
    >> RussRuss, while your PC does not go up in flames without the
    >> *nomodeset

    > *command, it is still recommended if you are loading the nVidia
    > proprietary binary video driver to use this kernel load option. I
    > found this explanation of the* nomodeset *command:
    >
    >> > What is "*nomodeset*" SUPPOSED to do?

    >>
    >> The newest kernels have (God knows why) moved the video
    >> mode setting into the kernel (the only explanation I've
    >> ever seen for why this is a good idea is that the monitor
    >> goes "click" less often that way). So all the programming
    >> of the hardware specific clock rates and registers on the
    >> video card happen in the kernel during initial boot
    >> rather than in the X driver when the X server starts.
    >> (And the X driver developers hate having to deal with
    >> both possibilities, so they'd really like no one to ever
    >> use *nomodeset*).
    >>
    >> The "*nomodeset*" kernel parameter turns off this feature
    >> and leaves the system BIOS video setting in place during
    >> boot.
    >>
    >> Because the kernel may need the video driver loaded to
    >> do mode setting, the nouveau driver is probably included
    >> in the initrd image, hence the need for both "*nomodeset*"
    >> and "rdblacklist=nouveau" to keep the kernel out of the
    >> video mode business so the binary nvidia driver can
    >> then do mode setting when X starts with no conflicting
    >> drivers loaded in the kernel.Thanks Steven P. Ulrick for your
    >> explanation of *nomodeset*. Following

    > is a note from the nVidia HOWTO on installing their driver the hard
    > way:
    >
    >> NOTE: The nvidia installer does not work as long as a Xserver is
    >> still running and the nvidia kernel module is still loaded. Therefore
    >> please boot into runlevel 3 by specifying "3" as kernel boot
    >> option or switch to runlevel 3 ("init 3") and unload the kernel
    >> module ("rmmod nvidia") before running the nvidia installer.
    >> Since openSUSE 11.3 use "*nomodeset*" as additional kernel boot
    >> option.
    >> Here is a excerpt from the openSUSE 11.3 release notes:

    >
    >> INITIALIZING GRAPHICS WITH KMS (KERNEL MODE SETTING)
    >> With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting)
    >> for Intel, ATI and NVIDIA graphics, which now is our default. If you
    >> encounter problems with the KMS driver support (intel, radeon,
    >> nouveau), disable KMS by adding *nomodeset *to the kernel boot
    >> command line. To set this permanently, add it to the kernel command
    >> line in /boot/grub/menu.lst. This option makes sure the appropriate
    >> kernel module (intel, radeon, nouveau) is loaded with modeset=0 in
    >> initrd, i.e. KMS is disabled.
    >> In the rare cases when loading the DRM module from initrd is a
    >> general problem and unrelated to KMS, it is even possible to disable
    >> loading of the DRM module in initrd completely. For this set the
    >> NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then
    >> recreates initrd afterwards. Reboot your machine.
    >> On Intel without KMS the Xserver falls back to the fbdev driver
    >> (the intel driver only supports KMS). On ATI for current GPUs it
    >> falls back to radeonhd. On NVIDIA without KMS the nv driver is used
    >> (the nouveau driver only supports KMS).
    >>
    >> And the best part about using *nomodeset* is, it costs nothing to use

    > and follows the suggestions of many experts on the subject.
    >
    > Thank You,
    >

    Thanks, I'll set it in menu.lst and see what happens.


    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 10|
    Intel core2duo 2.5 MHZ,|8GB DDR3|GeForce 8400GS

  8. #8

    Default Re: Compiz freezes opensuse 11.3

    Quote Originally Posted by jdmcdaniel3 View Post
    So, in order to install the nVidia driver and get it to work, you must add the nomodeset kernel load option in your grub menu.lst file. Here is an example from my menu.lst file.

    Code:
     ###Don't change this comment - YaST2 identifier: Original name: linux###
    title Desktop -- openSUSE 11.3 - 2.6.34.7-0.5
        savedefault 3
        root (hd0,1)
        kernel /boot/vmlinuz-2.6.34.7-0.5-desktop root=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part2 resume=/dev/disk/by-id/ata-WDC_WD6000HLHX-01JJPV0_WD-WXA1C20K0415-part1 splash=silent quiet nomodeset showopts vga=0x346
        initrd /boot/initrd-2.6.34.7-0.5-desktop
    To edit this file using KDE I would enter the menu Run Command:

    Code:
    kdesu kwrite /boot/grub/menu.lst
    To just look, you can open a terminal session and type:

    Code:
    cat /boot/grub/menu.lst
    To set the NO_KMS_IN_INITRD = Yes, open YaST / System / etc/sysconfig Editor / System / Kernel / NO_KMS_IN_INITRD change to Yes and press OK in bottom right. Reboot when done for these to take effect. I can say that I did not think you could even load the nVidia driver if the nomodeset command was not used in your menu.lst file.

    Thank You,
    I've done everything but it still doesn't work correctly, now it only freezes the shortcuts on start menu, the shortcuts I have on the desktop work fine.

  9. #9
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Compiz freezes opensuse 11.3

    So, lets start by giving us the output from the free command, this is what it looks like on my PC:

    Code:
    james@linux-ew60:~> free
                 total       used       free     shared    buffers     cached
    Mem:       8186576    4235968    3950608          0     209592    3376520
    -/+ buffers/cache:     649856    7536720
    Swap:      2104476          0    2104476
    Next, lets get the output from the fdisk command, you must be root to do this. Here is what it looks like on my PC:

    Code:
    james@linux-ew60:~> su -
    Password: 
    linux-ew60:~ # fdisk -l
    
    Disk /dev/sda: 2000.4 GB, 2000397852160 bytes
    255 heads, 63 sectors/track, 243201 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x4cbc9c09
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1   *           1      243202  1953512448    7  HPFS/NTFS
    
    Disk /dev/sdb: 600.1 GB, 600127266816 bytes
    255 heads, 63 sectors/track, 72961 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x46f71f1a
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdb1               1         262     2104483+  82  Linux swap / Solaris
    /dev/sdb2   *         263       19092   151251975   83  Linux
    /dev/sdb3           19093       72962   432705294   83  Linux
    
    Disk /dev/sdc: 1500.3 GB, 1500301910016 bytes
    255 heads, 63 sectors/track, 182401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x0009698d
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sdc1               1      182402  1465136128    7  HPFS/NTFS
    Is it possible you are running out or memory and/or disk space? Depending on what we find, it may be time to consider updating your kernel outside of what comes with openSUSE 11.3, going for 2.6.36 or 2.6.37 which was just released.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  10. #10

    Default Re: Compiz freezes opensuse 11.3

    Code:
                 total       used       free     shared    buffers     cached
    Mem:       6106580    1263432    4843148          0      34736     884316
    -/+ buffers/cache:     344380    5762200
    Swap:      2097148          0    2097148
    Code:
    Disk /dev/sda: 500.1 GB, 500107862016 bytes
    255 heads, 63 sectors/track, 60801 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0xd7622a0f
    
       Device Boot      Start         End      Blocks   Id  System
    /dev/sda1               1        1443    11588608   27  Unknown
    /dev/sda2            1443        1456      102400    7  HPFS/NTFS
    /dev/sda3            1456       32774   251564032    7  HPFS/NTFS
    /dev/sda4   *       32774       60802   225129472    f  W95 Ext'd (LBA)
    /dev/sda5           32774       57277   196816896    7  HPFS/NTFS
    /dev/sda6           57277       57538     2097152   82  Linux swap / Solaris
    /dev/sda7           57538       58844    10485760   83  Linux
    /dev/sda8           58844       60802    15725568   83  Linux

    here it is!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •