Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: PC freezes when I add Virtual flag is added to xorg.conf

  1. #1
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default PC freezes when I add Virtual flag is added to xorg.conf

    Hi all I have an nVidia radeon x1300 series running on my suse 64 bit system.
    The problem is when I try to enable dual head it tells me that I dont have enough virtual memory so when I add the:
    Virtual 3840 1200
    under the screen section it works for a couple of minutes and then bom! it freezes up no mouse no keyboard response and the screen gets all distorted. whats odd is that I can still ssh to the system.
    The following is my current xorg.conf without the Virtual flag.
    Code:
    # /.../
    # SaX generated X11 config file
    # Created on: 2010-12-19T10:38:36-0500.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [SaX2] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "Files"
      FontPath     "/usr/share/fonts/misc:unscaled"
      FontPath     "/usr/share/fonts/local"
      FontPath     "/usr/share/fonts/75dpi:unscaled"
      FontPath     "/usr/share/fonts/100dpi:unscaled"
      FontPath     "/usr/share/fonts/Type1"
      FontPath     "/usr/share/fonts/URW"
      FontPath     "/usr/share/fonts/Speedo"
      FontPath     "/usr/share/fonts/PEX"
      FontPath     "/usr/share/fonts/cyrillic"
      FontPath     "/usr/share/fonts/latin2/misc:unscaled"
      FontPath     "/usr/share/fonts/latin2/75dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/100dpi:unscaled"
      FontPath     "/usr/share/fonts/latin2/Type1"
      FontPath     "/usr/share/fonts/latin7/75dpi:unscaled"
      FontPath     "/usr/share/fonts/baekmuk:unscaled"
      FontPath     "/usr/share/fonts/japanese:unscaled"
      FontPath     "/usr/share/fonts/kwintv"
      FontPath     "/usr/share/fonts/truetype"
      FontPath     "/usr/share/fonts/uni:unscaled"
      FontPath     "/usr/share/fonts/CID"
      FontPath     "/usr/share/fonts/ucs/misc:unscaled"
      FontPath     "/usr/share/fonts/ucs/75dpi:unscaled"
      FontPath     "/usr/share/fonts/ucs/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/misc:unscaled"
      FontPath     "/usr/share/fonts/hellas/75dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/100dpi:unscaled"
      FontPath     "/usr/share/fonts/hellas/Type1"
      FontPath     "/usr/share/fonts/misc/sgi:unscaled"
      FontPath     "/usr/share/fonts/xtest"
      FontPath     "/opt/kde3/share/fonts"
      InputDevices "/dev/gpmdata"
      InputDevices "/dev/input/mice"
    EndSection
    
    Section "Module"
      Load         "dri"
      Load         "dbe"
      Load         "freetype"
      Load         "extmod"
      Load         "glx"
    EndSection
    
    Section "ServerFlags"
      Option       "AllowMouseOpenFail" "on"
      Option       "ZapWarning" "on"
    EndSection
    
    Section "InputDevice"
      Driver       "kbd"
      Identifier   "Keyboard[0]"
      Option       "Protocol" "Standard"
      Option       "XkbLayout" "us"
      Option       "XkbModel" "microsoftpro"
      Option       "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
      Driver       "mouse"
      Identifier   "Mouse[1]"
      Option       "Buttons" "5"
      Option       "Device" "/dev/input/mice"
      Option       "Name" "Dell USB Optical Mouse"
      Option       "Protocol" "explorerps/2"
      Option       "Vendor" "Sysp"
      Option       "ZAxisMapping" "4 5"
    EndSection
    
    
    Section "Monitor"
      Option       "CalcAlgorithm" "XServerPool"
      DisplaySize  380 300
      HorizSync    30-80
      Identifier   "Monitor[0]"
      ModelName    "NOVATEK  563D"
      Option       "DPMS"
      Option       "PreferredMode" "1280x1024"
      VendorName   "NVT"
      VertRefresh  43-75
      UseModes     "Modes[0]"
    EndSection
    
    
    Section "Modes"
      Identifier   "Modes[0]"
    EndSection
    
    
    Section "Device"
      BoardName    "Framebuffer Graphics"
      Driver       "fbdev"
      Identifier   "Device[0]"
      VendorName   "VESA"
    EndSection
    
    
    Section "Screen"
      SubSection "Display"
        Depth      15
        Modes      "default" 
      EndSubSection
      SubSection "Display"
        Depth      16
        Modes      "default" 
      EndSubSection
      SubSection "Display"
        Depth      24
        Modes      "default" 
      EndSubSection
      SubSection "Display"
        Depth      8
        Modes      "default" 
      EndSubSection
      Device       "Device[0]"
      Identifier   "Screen[0]"
      Monitor      "Monitor[0]"
    EndSection
    
    
    Section "ServerLayout"
      Identifier   "Layout[all]"
      InputDevice  "Keyboard[0]" "CoreKeyboard"
      InputDevice  "Mouse[1]" "CorePointer"
      Screen       "Screen[0]"
    EndSection
    
    
    Section "DRI"
        Group      "video"
        Mode       0660
    EndSection
    Any info on this is greatly appreciated...
    Hmmmm I wonder how long before im good at this????????????

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Hmmm...why are you using the fbdev driver rather than the radeon driver? If you use a KMS driver (like the radeon driver), then larger virtual screen sizes are possible. Not sure about this, but maybe the fbdev driver does not support such a large virtual screen size...

  3. #3
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Quote Originally Posted by deano_ferrari View Post
    Hmmm...why are you using the fbdev driver rather than the radeon driver? If you use a KMS driver (like the radeon driver), then larger virtual screen sizes are possible. Not sure about this, but maybe the fbdev driver does not support such a large virtual screen size...
    Hmmm good question I had originally installed the nVidia driver with it and had :

    Driver "fglrx"

    on my xorg file, when this driver was installed it would do the same thing so I opted to uninstall it. I guess im running universal drivers now that's probably where teh fbdev is coming from?
    Which in fact thanks for mentioning this, now I don't even have the option to uncheck mirror screen. this sucks
    What is also weird is that an rpm -qa | grep fglrx reveals
    x11-video-fglrxG02-8.762-2
    ati-fglrxG02-kmp-default-8.762_2.6.27.19_5-2
    Hmmmm I wonder how long before im good at this????????????

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Hmmm good question I had originally installed the nVidia driver with it and had :

    Driver "fglrx"
    Your getting yourself confused

    nvidia hardware --> open source nouveau driver or proprietary nvidia driver
    ati hadware --> open source radeon driver or proprietary fglrx driver

    If you want to stay with the fglrx driver, then follow the 'hard way' section of this ATI guide.

  5. #5
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Quote Originally Posted by deano_ferrari View Post
    Your getting yourself confused

    nvidia hardware --> open source nouveau driver or proprietary nvidia driver
    ati hadware --> open source radeon driver or proprietary fglrx driver

    If you want to stay with the fglrx driver, then follow the 'hard way' section of this ATI guide.
    Hey sorry it took me a while to respond I was out of commision for a while so I tried the hard way, but I get a message saying that I dont have enough virtual memory even when I add the virtual flags....
    Hmmmm I wonder how long before im good at this????????????

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Which version of openSUSE are you using? You mentioned that the graphics chipset is a radeon X1300, is that correct?

    Code:
    /usr/sbin/hwinfo --gfxcard
    It may be that you have to stay with the radeon driver (as the X1300 is no longer supported by the proprietary driver, unless your still using the older Xorg version with openSUSE 11.2).

  7. #7
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Quote Originally Posted by deano_ferrari View Post
    Which version of openSUSE are you using? You mentioned that the graphics chipset is a radeon X1300, is that correct?

    Code:
    /usr/sbin/hwinfo --gfxcard
    It may be that you have to stay with the radeon driver (as the X1300 is no longer supported by the proprietary driver, unless your still using the older Xorg version with openSUSE 11.2).
    Code:
    localhost:~ # /usr/sbin/hwinfo --gfxcard
    26: PCI 100.0: 0300 VGA compatible controller (VGA)             
      [Created at pci.318]
      UDI: /org/freedesktop/Hal/devices/pci_1002_7183
      Unique ID: VCu0.aiHZfenAOj2
      Parent ID: vSkL.MGnq93IN+_A
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
      SysFS BusID: 0000:01:00.0
      Hardware Class: graphics card
      Model: "ATI Radeon X1300/X1550 Series (RV516 7183)"
      Vendor: pci 0x1002 "ATI Technologies Inc"
      Device: pci 0x7183 "Radeon X1300/X1550 Series (RV516 7183)"
      SubVendor: pci 0x1028 "Dell"
      SubDevice: pci 0x0d02 
      Driver: "fglrx_pci"
      Driver Modules: "fglrx"
      Memory Range: 0xc0000000-0xcfffffff (rw,prefetchable)
      Memory Range: 0xdfde0000-0xdfdeffff (rw,non-prefetchable)
      I/O Ports: 0xdc00-0xdcff (rw)
      Memory Range: 0xdfe00000-0xdfe1ffff (ro,prefetchable,disabled)
      IRQ: 16 (10277 events)
      I/O Ports: 0x3c0-0x3e7 (rw)
      Module Alias: "pci:v00001002d00007183sv00001028sd00000D02bc03sc00i00"
      Driver Info #0:
        XFree86 v4 Server Module: fglrx
      Driver Info #1:
        XFree86 v4 Server Module: fglrx
        3D Support: yes
        Extensions: dri
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #10 (PCI bridge)
    
    27: PCI 100.1: 0380 Display controller
      [Created at pci.318]
      UDI: /org/freedesktop/Hal/devices/pci_1002_71a3
      Unique ID: NXNs.bcVrYw36tO6
      Parent ID: vSkL.MGnq93IN+_A
      SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.1
      SysFS BusID: 0000:01:00.1
      Hardware Class: graphics card
      Model: "ATI RV516 [Radeon X1300 Pro] (Secondary)"
      Vendor: pci 0x1002 "ATI Technologies Inc"
      Device: pci 0x71a3 "RV516 [Radeon X1300 Pro] (Secondary)"
      SubVendor: pci 0x1028 "Dell"
      SubDevice: pci 0x0d03 
      Memory Range: 0xdfdf0000-0xdfdfffff (rw,non-prefetchable)
      Module Alias: "pci:v00001002d000071A3sv00001028sd00000D03bc03sc80i00"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #10 (PCI bridge)
    
    Primary display adapter: #26
    And I have suse 11.0
    Hmmmm I wonder how long before im good at this????????????

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    And I have suse 11.0
    Ok, that explains why you're still able to use the proprietary driver. However, be aware that 11.0 is unsupported now, and you should really be considering an upgrade. (11.2 is sensible if you prefer the proprietary driver for your 'legacy' grphics system).

    Anyway, you could try using the amdccle (AMD Catalyst Control Centre) utility to dynamically configure your dual monitor setup. From a terminal, become root with the 'su -' command and enter your root password when prompted. Then type 'amdcccle'.

    Alternativley, there is the aticonfig CLI utility to help generate a working xorg.conf for your dual head system. To get started

    Code:
    aticonfig --help
    To create a basic dual head system for example, have your second monitor connected, drop to runlevel 3 with

    Code:
    init 3
    then (again as root) do something like

    Code:
    sudo aticonfig --initial=dual-head --screen-layout=right
    When finished, return to a graphical desktop with

    Code:
    init 5
    Useful references (google is your friend too):

    Configuring - cchtml.com

    X.Org/Dual Monitors/ATI - Gentoo Linux Wiki
    Last edited by deano_ferrari; 28-Dec-2010 at 18:29.

  9. #9
    Join Date
    Jan 2009
    Location
    Queens
    Posts
    126

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    To
    deano_ferrari

    Thank you so much for all your help I did try your steps but unfortunately with the same results, if it helps at all this is the last entry in /var/log/messages before the freeze:

    WARNING: Application 'gnome-wm.desktop' failed to register before timeout

    And believe me I have googled for a long time.. but have found no solution yet...
    Hmmmm I wonder how long before im good at this????????????

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: PC freezes when I add Virtual flag is added to xorg.conf

    Did you make it to the windwo manager login? (I'm guessing not). Can you start up in failsafe mode ok? Maybe post your xorg.conf that aticonfig generated.

    Haven't needed to look here before, but this may be useful with diagnosis

    Code:
    cat ~/.xsession-errors

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •