Results 1 to 7 of 7

Thread: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

  1. #1

    Question monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    Hello,
    I've just installed open SUSE 11.3 with KDE. Problem is, that the screen flashes (turn all black for about two seconds and then back). It repeats at about five second intervals. When the mouse cursor is not moving, it is OK. Hardware used is BENQ G2200W LCD monitor and SiS661Fx onboard graphic card.
    I'have installed openSUSE about yeat ago (probably older version) also with KDE and the same HW and everything worked fine. Thanks for answers!
    O.Pokorny

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,279
    Blog Entries
    1

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    Stange! Can you boot up in failsafe mode ok? Are you connected via a VGA or DVI cable? (These answers may help others to assist).

    Maybe the Xorg server needs help with your monitor settings:

    I note the specs for your monitor (from a quick search)

    1680 x 1050
    HorizSync 83 kHz max
    VertRefresh 76 Hz max

    The file that specifies monitor configuration is /etc/X11/xorg.conf.d/50-monitor.conf

    You could try uncommenting

    Code:
    HorizSync 28-85
    VertRefresh 50-100
    Now, system files need root privileges to edit. So, to edit type

    Code:
    kdesu kate /etc/X11/xorg.conf.d/50-monitor.conf
    and be careful with your editing. When finished, save, then reboot, or restart the X-server with CTRL-ALT-Backspace (twice).

    There is a goood chance that other issues (configuration) need addressing too. Maybe others familiar with your graphics chipset can advise further...

    Edit: This guide might be helpful as well:
    Last edited by deano_ferrari; 19-Dec-2010 at 01:22.

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,279
    Blog Entries
    1

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    I think I misunderstood your post. Anyway, screen flickering with KDE4 and certain graphics hardware/driver combinations has been the subject of more than a few bug reports and threads. For example, this Ubuntu bug report. You could try the advice outlined there, which worked for some users. I had never realised this config setting existed myself until now!

    System Settings >> Advanced >> Service Manager >> Startup Services

    Scroll down to the 'Detecting RANDR (monitor) changes and disable (its enabled by default). Save the changes and exit. See if that makes a difference.

  4. #4

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    Hello,
    when running failsafe mode, everything is OK. Monitor is connected via VGA (D-SUB input). I haven't found the folder mentioned above. In my filesystem there is only /etc/X11/(no folder xorg.conf.d).

  5. #5

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    I have'n found anything like System Settings in the enviroment. What I found is "System Services(runlevel)" but among these there is no DETECT_RANDR_CHANGES.
    Further I have found in tool named "/etc/sysconfig Editor" under "Desktop-Display manager" item "DISPLAYMANAGER_RANDR_MODE_VGA".

  6. #6

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    PROBLEM SOLVED!!!
    I've just configured wireless network adapter, via YaSt downloaded and installed actualizations and everything works fine! I would like to thank for helping!!
    O.Pokorny

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,279
    Blog Entries
    1

    Default Re: monitor flashes (open SUSE 11.3 + KDE + BENQ G2200W)

    I have'n found anything like System Settings in the enviroment.
    You are running KDE4, right? From the main menu (under Favourites in my menu), you should be able navigate to the KDE 'System Settings' control panel (formerly called Configure Desktop). Select the 'Advanced' tab, then choose 'Service Manager'. From there, have a look at 'Startup Services' and you should see 'Detecting RANDR (monitor) changes' enabled. Disable it, and see if it stops the flicker you're getting.

    Hello,
    when running failsafe mode, everything is OK. Monitor is connected via VGA (D-SUB input). I haven't found the folder mentioned above. In my filesystem there is only /etc/X11/(no folder xorg.conf.d).
    That s because you're using Dolphin file manager, and haven't selected 'View' > 'Show Hidden Files'. Anyway, after reading your first post in depth, forget adjusting the Xorg config files there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •