Results 1 to 4 of 4

Thread: Smile - no output file -> SOLUTION

  1. #1

    Default Smile - no output file -> SOLUTION

    If you install Smile (video slideshow creator) from Packman repository, you will probably find out that it doesn't produce any output file. This project is most probably dead, homepage is 404 and it's practically impossible to get any information about this program. Therefore it took me 3 exhausting hours to get it working Here is the solution:

    There is a missing fake.pl file, so you have to copy it to the right place, which is /opt/smile (for OpenSuse, for other distros it could be elsewhere, for example /usr/bin). You can obtain this file from the source package but as it is very small I post it right here to spare your time:

    Code:
    #!/usr/bin/perl
    binmode STDIN;
    $line = '';
    while (($n = read STDIN, $data, 1) != 0) {
    $line .= $data;
    if ($data eq "\n") {
    $line = '';
    } elsif ($data eq "\r") {
    if ($line =~ m/^Pos.*fps\s*Trem.*\r$/) {
    print $line;
    $line = '';
    }
    }
    }
    So create a new file /opt/smile/fake.pl and copy these lines into it. Btw. the original file from the source doesn't have the first line, but according to the tip from different forum it is supposed to be here.

    If Smile still doesn't work you might try to add some extra permission to fake.pl, something like chmod 755 /opt/smile/fake.pl

    And if it is still not working check the log file ~/.logsmile.txt This file is by the way also impossible to find, there is no sign of him in the documentation.

    I hope this will help you

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Smile - no output file -> SOLUTION

    On 2010-12-18 18:06, tobice wrote:
    > Therefore it took
    > me 3 exhausting hours to get it working Here is the solution:


    Perhaps you can email this info to the packman packager.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: Smile - no output file -> SOLUTION

    Well I did it, but I don't think this is a problem of Packman. When I was looking for the solution I found many people with the same problem and they were not OpenSuse users. As far as I know this bug affects not only rpm based distros but also debian based, like Kubuntu for example. And I also found a man who had already posted this to the Packman mailing list so I don't know whether this will change anything. I hope it will

  4. #4
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Smile - no output file -> SOLUTION

    On 2010-12-18 19:06, tobice wrote:
    >
    > Well I did it, but I don't think this is a problem of Packman. When I
    > was looking for the solution I found many people with the same problem
    > and they were not OpenSuse users. As far as I know this bug affects not
    > only rpm based distros but also debian based, like Kubuntu for example.
    > And I also found a man who had already posted this to the Packman
    > mailing list so I don't know whether this will change anything. I hope
    > it will


    Yes, obviously it is an upstream problem. But the packager can also correct
    such problems with patches. As there are no upstream new version, the patch
    would remain for a long time. It makes no sense to package something that
    is known to be broken, even less if it can be easily repaired.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •