Results 1 to 8 of 8

Thread: Plasma Desktop Crashes

  1. #1

    Default Plasma Desktop Crashes

    I had openSuse 11.3 KDE4.4.4 installed and used the 1-Click install to get the nVidia drivers.
    However, this gave me the problems with Amarok and other applications crashing.
    I switched the system repos to use packman but that didn't help.

    The solution on the forums seemed to be either recompile with an old nVidia driver or upgrade to KDE4.5 as most people were reporting to not see it under 4.5.

    Upgrading seemed to be the easiest method, especially as there appeared to be a stable repo now.

    I upgraded and now plasma-desktop crashes on login!
    Is getting the old nVidia driver my only option now?

    zypper lr -d
    Code:
                                                                                                                                                
    # | Alias                    | Name                  | Enabled | Refresh | Priority | Type   | URI                                                                       | Service  
    --+--------------------------+-----------------------+---------+---------+----------+--------+---------------------------------------------------------------------------+--------  
    1 | KR45                     | KR45                  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.3/ |          
    2 | NVIDIA Repository        | NVIDIA Repository     | Yes     | Yes     |   99     | rpm-md | http://download.nvidia.com/opensuse/11.3/                                 |          
    3 | ftp.uni-erlangen.de-suse | Packman Repository    | Yes     | Yes     |   99     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/11.3/                 |          
    4 | repo-debug               | openSUSE-11.3-Debug   | No      | Yes     |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.3/repo/oss/            |          
    5 | repo-non-oss             | openSUSE-11.3-Non-Oss | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/non-oss/              |          
    6 | repo-oss                 | openSUSE-11.3-Oss     | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.3/repo/oss/                  |          
    7 | repo-source              | openSUSE-11.3-Source  | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.3/repo/oss/           |          
    8 | repo-update              | openSUSE-11.3-Update  | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.3/                                 |          
    linux-h87v:
    Grub:
    Code:
    linux-h87v:/boot/grub # cat menu.lst
    # Modified by YaST2. Last modification on Sat Dec 11 21:01:56 GMT 2010                                                                                                              
    # THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader                                                                                                                        
    # Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader                                                                                                 
                                                                                                                                                                                        
    default 0                                                                                                                                                                           
    timeout 8                                                                                                                                                                           
    ##YaST - generic_mbr                                                                                                                                                                
    gfxmenu (hd0,4)/message                                                                                                                                                             
    ##YaST - activate                                                                                                                                                                   
                                                                                                                                                                                        
    ###Don't change this comment - YaST2 identifier: Original name: linux###                                                                                                            
    title openSUSE 11.3 - 2.6.34.7-0.5                                                                                                                                                  
        root (hd0,4)                                                                                                                                                                    
        kernel /vmlinuz-2.6.34.7-0.5-default root=/dev/system/rootSuse resume=/dev/system/swap splash=silent quiet showopts vga=0x314 nomodeset                                         
        initrd /initrd-2.6.34.7-0.5-default                                                                                                                                             
                                                                                                                                                                                        
    ###Don't change this comment - YaST2 identifier: Original name: failsafe###                                                                                                         
    title Failsafe -- openSUSE 11.3 - 2.6.34.7-0.5                                                                                                                                      
        root (hd0,4)                                                                                                                                                                    
        kernel /vmlinuz-2.6.34.7-0.5-default root=/dev/system/rootSuse showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x314
        initrd /initrd-2.6.34.7-0.5-default
    
    ###Don't change this comment - YaST2 identifier: Original name: windows 1###
    title windows 1
        rootnoverify (hd0,0)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: windows 2###
    title windows 2
        rootnoverify (hd0,1)
        chainloader +1
    
    ###Don't change this comment - YaST2 identifier: Original name: floppy###
    title Floppy
        rootnoverify (fd0)
        chainloader +1

  2. #2
    Join Date
    Aug 2008
    Location
    Winnipeg, Canada
    Posts
    203

    Default Re: Plasma Desktop Crashes

    You could try and boot into failsafe mode and add a new user and see if plasma crashes with that user. If Plasma doesn't crash then you can rename your `username/.kde4 folder and try logging into your system with your correct user. You can get all of your settings back for mail...etc.

    If Plasma crashes with the new user then you probably have to re-compile the older driver.

    Cheers
    etech97

  3. #3

    Default Re: Plasma Desktop Crashes

    I thought that removing nvidia drivers using YaST (I could open it via Alt-F2) would revert me to the initial state shortly after the initial openSuste install.
    Although the graphic experience wan't fantastic back then, at least the applications opened.

    However, on restart Alt-F2 didn't bring up a box and I was left with a black screen and a mouse pointer.

    I managed to get in to IceWM and I created a new user with YaST.
    However, when I logged in with that user I still got the same problem of a black screen.

    I had previously downloaded the old nVidia driver but it wouldn't install as I didn't have kernel source installed.

    If I can't/wont download the rest of the dependencies to install the old driver, is there anything else I can do to get the KDE Desktop without the nVidia drivers and just use the drivers that came with the distro?

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,697

    Default Re: Plasma Desktop Crashes

    You can get things back by running CL version of Yast in the command line. You can also install the needed kernel source to try an older version of NVIDIA. At the boot screen press 3 (to boot to CL, run level 3) then select the boot log in as root and run yast. Navigate with the tab and arrow keys.

    What card do you have?

  5. #5

    Default Re: Plasma Desktop Crashes

    The problem is now that I can't connect to the internet (I'm waiting for a delayed flight atm and using a public PC).
    The internet access is wireless with no security until you open your browser and input username/password on a webpage.
    Not sure how I can do this from the command line.

    I can get to IceWM, but I can't work out how to bring up a network manager.
    I can open firefox and konqueror but it isn't automatically connecting to the wireless network so I need to work out how to connect via the command line.

    From IceWM I manged to run plasma-desktop from the command line and got a task bar and kicker but no desktop widgets.
    So it seems that there is some potential there.
    However, when I tried to log back in to a KDE session I got the black screen and not this half plasma that I managed from IceWM.

  6. #6

    Default Re: Plasma Desktop Crashes

    Graphics card is Nvidia Quadro NVS 135M.

    Is it possible to download the kernel-source, make + gcc from another PC then copy them to this one and install them from the command line?

  7. #7

    Default Re: Plasma Desktop Crashes

    I'm making progress!
    This ghacks article gives instructions on connecting to wireless via CLI
    Connect to a wireless network via command line

    Even though the last command outputted
    Code:
    ls: cannot access /var/run/netconfig//wlan0/: No such file or directory
    I think that when I booted into Windows I was assigned an IP.

    I thought to type knetworkmanager in xterm and sudden;y I was connected!

    I've managed to download the kernel-source.
    Next step, try the old driver!

  8. #8

    Default Re: Plasma Desktop Crashes

    Woop! Woop! Woop!
    All back!
    Compiling the old version was straight forward as promised!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •