Results 1 to 3 of 3

Thread: How to turn up the high resolution in opensuse11.3?

  1. #1

    Default How to turn up the high resolution in opensuse11.3?

    My screen resolution is only 640x480 after I installed the nVidia driver by authority method of 1-click install.And then I run nvidia-xconfig,/etc/X11/xorg.conf was built.Restart my PC. I selected the default mode to run opensuse.My screen was black.So I select the failsafe mode and remove the /etc/X11/xorg.conf.I try to copy my ubuntu 10.3 /etc/X11/xorg.conf,but I failed,the screen was black when booting default mode.
    Now my LCD resolution is so low.
    Graphics card:nVidia Geforce 5200
    Monitor:19 inch widescreen LCD
    And I can keep the best LCD resolution 1440x900@60Hz in the Windows XP successfully.
    Please help me to solve my trouble.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: How to turn up the high resolution in opensuse11.3?

    If you go to the nVidia WEB site and actualy enter your video card model, it does not show you can load the very latest video driver. You will most likely need to uninstall anything you did and then look at all information here from nVidia.

    NVIDIA DRIVERS 173.14.28 Certified

    In general, you would get near recent for 1-Click install, but for old video cards, you need to confirm just what video driver is required first.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,570
    Blog Entries
    38

    Default Re: How to turn up the high resolution in opensuse11.3?

    Dependant on your hardware, you may need to use the boot code "nomodeset" (please read the openSUSE-11.3 release notes). You may also need to disable KMS in the kernel also per the http://www.suse.com/relnotes/i386/op... release notes.

    To help openSUSE-11.3 users with this there are a couple of guides:
    Don't forget what I noted wrt the release notes :

    Initializing Graphics with KMS (Kernel Mode Setting)

    With openSUSE 11.3 we are switching to KMS (Kernel Mode Setting) for Intel, ATI and NVIDIA graphics, which now is our default. If you encounter problems with the KMS driver support (intel, radeon, nouveau), disable KMS by adding nomodeset to the kernel boot command line. To set this permanently, add it to the kernel command line in /boot/grub/menu.lst. This option makes sure the appropriate kernel module (intel, radeon, nouveau) is loaded with modeset=0 in initrd, i.e. KMS is disabled.

    In the rare cases when loading the DRM module from initrd is a general problem and unrelated to KMS, it is even possible to disable loading of the DRM module in initrd completely. For this set the NO_KMS_IN_INITRD sysconfig variable to yes via YAST, which then recreates initrd afterwards. Reboot your machine.

    On Intel without KMS the Xserver falls back to the fbdev driver (the intel driver only supports KMS). On ATI for current GPUs it falls back to radeonhd. On NVIDIA without KMS the nv driver is used (the nouveau driver only supports KMS).
    Note also, for users to provide help/troubleshoot your problems, they need access to the appropriate log file (which will show the errors) ... so in that case you would need to paste the contents of the file /var/log/Xorg.0.log to a paste site such as SUSE Paste and then post here the URL/address where those contents are located, so the graphic card configuration experts on our forum can check it out and provide specific suggestions.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •