Results 1 to 5 of 5

Thread: Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

  1. #1
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Thumbs up Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

    In früheren Suse Versionen habe ich einfach in /usr/share/X11/xkb/symbols/us bzw. gb folgende Änderungen vorgenommen:
    Code:
     key <AC01> {        [         a,    A,      adiaeresis,     Adiaeresis]     };
     key <AD07> {        [         u,    U,      udiaeresis,     Udiaeresis]     };
     key <AD09> {        [         o,    O,      odiaeresis,     Odiaeresis]     };
    Damit hatte ich dann immer die deutschen Umlaute auf dem US- bzw. UK-Keyboard mit der rechten Alt-Taste (bzw. AltGr).

    Seit 11.3 und KDE4.5.4 (gleich in einem Schritt installiert) geht das leider nicht mehr, die Datei wird irgendwie ignoriert.

    Für US-Tastaturen gibt es ja als Workaround in KDE->Systemeinstellungen->Eingabegeräte->Tastatur->Belegung eine Variante, welche die Umlaute mit AltGr auf benachbarte Tasten legt (q,y,p).

    Jedoch für UK-Tastaturen sehe ich nur eine unbequeme Variante mit Deadkeys.

    Ich habe zwei Laptops, einen mit UK und einen mit US Tastatur.

  2. #2

    Default Re: Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

    Am einfachsten kannst Du eine "compose-key" definieren. Ich benutzte dafür die rechte CTRL Taste. Unter KDE läßt sie sich folgendermassen einstellen (habe's nur auf Englisch) :

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    Personal Settings
    Regional & Language -> Keyboard Layout ->
    (*) Enable Keyboard
    -> Advanced
    [+] Compose key position
    ....
    ---[v] Right Ctrl
    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    Ansonsten kannst Du jederzeit folgendes in einem Terminal eingeben:
    setxkbmap -option compose:rctrl
    Es wirkt sofort.

    Dann (der Reihe nach) :

    Code:
    rctrl " o -> ö
    rctrl " O -> Ö
    rctrl " a -> ä
    rctrl " A -> Ä
    rctrl " u -> ü
    rctrl " U -> Ü
    rctrl s s -> ß
    Es ist zwar nicht optimal, funktionniert aber unabhängig von Tastatur Model und Belegung.

  3. #3

    Default Re: Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

    Quote Originally Posted by STurtle View Post
    Für US-Tastaturen gibt es ja als Workaround in KDE->Systemeinstellungen->Eingabegeräte->Tastatur->Belegung
    Und dann "Advanced" (Weitere Einstellungen ?) ...
    [+] Compose key position.

  4. #4
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

    Danke für den Tipp, aber die Lösung mit Compose-Key mag ich nicht so (ist ja im Grunde das gleiche wie die Deadkey-Varianten).

  5. #5
    Join Date
    Jun 2008
    Location
    Hessia
    Posts
    303

    Default Re: Umlaute auf US/UK Keyboard in 11.3 nicht mehr wie bisher?

    Lösung in diesem Thread gefunden:

    Nachdem man die Dateien in /usr/share/xkb/symbols manipuliert hat muss man:
    1. Alle *.xkm dateien in /usr/share/xkb/compiled/ löschen
    2. Die Datei /var/cache/hald/fdi-cache löschen
    3. Neustarten (Restart X nicht genug)

    Beim herumprobieren und readme lesen habe ich 1. und 3. selbst herausgefunden, was die folge hatte das meine Tastatur im graphischen Modus gar nicht mehr ging. Daraufhin fand ich beim panischen googlen mit einem anderen Computer den oben verlinkten Thread, löschte in der root-konsole diese dämliche fdi-cache Datei, und alles war gut! Jetzt habe ich meine Umlaute auf Recht-Alt-a/u/o!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •