Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: CDROM is not showing up/not automount

  1. #1

    Default CDROM is not showing up/not automount

    I am using Suse since 6.5. I am no linux-expert, just power-user for years (no windows, no MAC OS X) at 3 computers at home and at work.

    I just did two bare-bone-installs from up-to-date dvds with opensuse 11.3 at two almost identical Dell Inspirion 6400-Laptops. Clear, flawless installation without any workarounds... Same install at a Dell Desktop Computer without any problems. Automatic updating.

    But both Laptops are having problems to read and show inserted data-cdroms. Knowing from the old versions and the new opensuse 11.3 at the desktop-PC what should happen, I have no clue what to do.

    It is definitely no technical problem:
    - the name of the inserted data-cdrom can be seen in k3b
    - inserted dvds are triggering the correct action (!) (suggestions are shown what to do with the dvd; cdrom: no results, no suggestions, just a short and proper working of the cd-device itself can be heart)
    - the data-cdrom can be mounted manually

    What did not help:
    - inserting a data-cdrom as root
    - changing the permissions of non-root-users
    - several updates of opensuse 11.3
    - reading several forums (the answers go into the directions newbee-who-does-not-know-how-openuse-works, wrong-installation, wrong-updating-of-an-old-opensuse-version, geek-how-screwed-up-his-installation-with-manual-wrongdoings => nothing which helps in my situation)

    this is my hardware-info about the cdrom/dvd-device:

    "55: SCSI 100.0: 10602 CD-ROM (DVD)
    [Created at block.249]
    Unique ID: KD9E.nUBGD094xDA
    Parent ID: w7Y8.EEEhEpVYhZ1
    SysFS ID: /class/block/sr0
    SysFS BusID: 1:0:0:0
    SysFS Device Link: /devices/pci0000:00/0000:00:1f.2/host1/target1:0:0/1:0:0:0
    Hardware Class: cdrom
    Model: "TSSTcorp DVD+-RW TS-L632H"
    Vendor: "TSSTcorp"
    Device: "DVD+-RW TS-L632H"
    Revision: "D200"
    Driver: "ata_piix", "sr"
    Driver Modules: "ata_piix"
    Device File: /dev/sr0 (/dev/sg1)
    Device Files: /dev/sr0, /dev/block/11:0, /dev/scd0, /dev/disk/by-path/pci-0000:00:1f.2-scsi-1:0:0:0, /dev/disk/by-label/Fara\x20und\x20Fu, /dev/cdrom, /dev/cdrw, /dev/dvd, /dev/dvdrw
    Device Number: block 11:0 (char 21:1)
    Features: CD-R, CD-RW, DVD, DVD-R, DVD-RW, DVD-R DL, DVD+R, DVD+RW, DVD+R DL
    Config Status: cfg=no, avail=yes, need=no, active=unknown
    Attached to: #27 (IDE interface)
    Drive Speed: 24
    Volume ID: "FARA_UND_FU"
    Application: "TOAST ISO 9660 BUILDER COPYRIGHT (C) 1997 ADAPTEC, INC. - HAVE A NICE DAY"
    Creation date: "2002073017583500""

    Any suggestions? Please help!

    Thanks in advance!

    Ingolf

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,007
    Blog Entries
    1

    Default Re: CDROM is not showing up/not automount

    Which deskktop environment are you using? KDE4 has a device notifier that can be configured to handle removable media...

  3. #3
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: CDROM is not showing up/not automount

    I had a problem with this recently.
    I needed to run zypper up and then reboot to get it
    to work properly. Could not even mount optical drives from the CLI.

  4. #4

    Default Re: CDROM is not showing up/not automount

    Quote Originally Posted by deano_ferrari View Post
    Which deskktop environment are you using? KDE4 has a device notifier that can be configured to handle removable media...
    Here it is: 4.4.4 (KDE 4.4.4) "release 3"
    I know that KDE4 is notifying if there is a USB-stick, Video-DVD or Audio-CD etc. THIS IS WORKING WITH EVERY OF MY COMPUTERS. But it is completely ignoring my data-CDROMs. Any help is appreciated.

  5. #5

    Default Re: CDROM is not showing up/not automount

    Quote Originally Posted by GofBorg View Post
    I had a problem with this recently.
    I needed to run zypper up and then reboot to get it
    to work properly. Could not even mount optical drives from the CLI.
    What did you do by running zypper? What did you reboot? Opensuse? Zypper? KDE? And what is "it" what you get by rebooting?
    I CAN mount data-cdroms from CLI.

    Thanks for your reply.

    I forgot to mention: One of the Dell Laptops did recognize everything (data-cdroms too) with opensuse 10.3.

    Any clues?

    Ingolf

  6. #6
    Join Date
    Jun 2008
    Location
    Delta Quadrant
    Posts
    1,434

    Default Re: CDROM is not showing up/not automount

    >> I had a problem with this recently.
    >> I needed to run zypper up and then reboot to get it
    >> to work properly. Could not even mount optical drives from the CLI.


    > What did you do by running zypper?

    zypper up...updates to latest versions against the repos you have
    configured.

    > What did you reboot?

    Rebooted the PC.

    > Zypper? KDE? And what is "it" what you get by rebooting?

    It was my optical DVD-RW.

    > I CAN mount data-cdroms from CLI.

    Probably not the same issue then.

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,007
    Blog Entries
    1

    Default Re: CDROM is not showing up/not automount

    Maybe the behaviour your experiencing is the same as described (and solved) as in this thread. Try adjusting the device notifier settings as suggested

    I've just looked at this here (KDE 4.4.5), and this is what I get...

    Right-click the device notifier, and choose "Device Notifier Settings", then "Removable Devices".

    I usually have ticks next to both "Enable automatic mounting of removable media" and "Only automatically mount removable media that has been manually mounted before". Then it behaves as I expect: plug in a device or put in a CD/DVD that has not been seen before and it must be mounted manually (by clicking the "attach" icon for instance); plug in something that has been seen before and it is mounted in /media and immediately available from the terminal or wherever.

    If I remove the tick next to "Only ... that has been manually mounted before" then it behaves in the way you describe in the original post. However, if I scroll down the "Device Overrides" and check "Automount on attach" for the device or disc, then it works the way I would have expected for that device/disc.

    I guess that is some sort of bug in the end: either the config options are not being observed properly, or they have not been described properly.

  8. #8
    Will Honea NNTP User

    Default Re: CDROM is not showing up/not automount

    deano ferrari wrote:

    > Maybe the behaviour your experiencing is the same as described (and
    > solved) as in this 'thread.'
    > (http://forums.fedoraforum.org/showth...45#post1416545) Try
    > adjusting the device notifier settings as suggested


    Thanks for the link - I missed that one when it came by. I couldn't get the
    !@#$$% thing to recognize ANYTHING until I ticked the "automount only media
    previously manually mounted " or some such but at least I can get to the
    blasted CD/DVD again. PITA issue - one copy of 11.3/KDE4 works, the other
    partition won't. This is a partial solution on the balky one.

    --
    Will Honea

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: CDROM is not showing up/not automount

    On 2010-12-13 21:36, madicineman wrote:

    > It is definitely no technical problem:
    > - the name of the inserted data-cdrom can be seen in k3b
    > - inserted dvds are triggering the correct action (!) (suggestions are
    > shown what to do with the dvd; cdrom: no results, no suggestions, just a
    > short and proper working of the cd-device itself can be heart)
    > - the data-cdrom can be mounted manually


    Do I understand that CDroms do not mount, but DVDs do mount, automatically?
    And that you can mount the CDs manually? In two laptops?

    Then --> Bugzilla.

    In my laptop, some cdroms are unreadable (I can not boot some lives), but
    that's hardware, it is a different thing. The crucial point in your case is
    that it mounts manually, so hardware works.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: CDROM is not showing up/not automount

    Quote Originally Posted by deano_ferrari View Post
    Maybe the behaviour your experiencing is the same as described (and solved) as in this thread. Try adjusting the device notifier settings as suggested
    Thanks: that was the solution! Why did the configuration change with opensuse 11.3? Does anybody knows? - Ingolf

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •