Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: VirtualBox Linux kernel driver just doesn't want to work properly

  1. #1

    Default VirtualBox Linux kernel driver just doesn't want to work properly

    Every other time I try to run a VirtualBox OS, I'll get this notice:

    Code:
    VirtualBox - Error In suplib0sInit:
    Kernel driver not installed (rc=-1908)
    The VirtualBox Linux kernel driver (vboxdrv) is either not loaded or there is a permission problem with /dev/vboxdrv. Please reinstall the kernel module by executing
    
    '/etc/init.d/vboxdrv setup'
    
    as root. Users of Ubuntu, Fedora or Mandriva should install the DKMS package first. This package keeps track of Linux kernel changes and recompiles the vboxdrv kernel module if necessary.
    I've tried reinstalling the driver using the method mentioned in the error:

    Code:
    Stopping VirtualBox kernel modules                                   done
    Uninstalling old VirtualBox DKMS kernel modules                      done
    Trying to register the VirtualBox kernel modules using DKMS          done
    Starting VirtualBox kernel modules                                   done
    but the problem still persists!

    Before I waste another 3 hours trying to get this working I figured I'd ask here.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    I just did all that but I still got the error when I rebooted.

    I guess I could just have the "/etc/init.d/vboxdrv setup" run at start up as a last resort, but I have no clue how to set that up properly.

    Or if opensuse has the option to save my session on logout/shutdown I guess I could live with that.
    Hehe, it's funny how I'm just now thinking about these.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    What error?

    What happens when you try and start Virtual Box?

    In a terminal to start it: VirtualBox
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    The VirtualBox kernel driver error from the first post, although I just realized that I only get that error whenever I have it run at startup. Could it be that VirtualBox starts running before the driver gets a chance to load? And if that's true is there any way to have the driver start first?

    Maybe creating a script that executes the driver, and then starts the application would be a viable option. I don't know how you would get a driver running though, I'm assuming you can't just run it like an executable.

    I'm using the "VBoxManage startvm" command and switch to run the VM directly, not "VirtualBox" by the way.

  6. #6
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    Yes, you have to start the VM after the driver is loaded. You should adjust your init script so that it Requires the vboxdrv capability in the metadata at the top of the file. But I'm guessing you aren't using an init script but putting it in boot.local or something. That gets run too early in the boot sequence.

  7. #7

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    Okay I created this script and am having run at start-up:

    Code:
    echo **** | sudo -S /etc/init.d/vboxdrv start
    VBoxManage startvm "Windows XP"
    Everything works now, thanks guys. (And I understand that having my password visible in a script like that isn't exactly the safest way to go around it, but, considering how I really only use this computer for music and schoolwork, I don't mind the risk.)

    This is off-topic, but I'd also like to know how run the command {VBoxManage controlvm "Windows XP" savestate} automatically whenever I click the shutdown button. Is there a configuration script I need to edit to do this? What is it called and where is it located?

  8. #8
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    Quote Originally Posted by XypherWolf View Post
    This is off-topic, but I'd also like to know how run the command {VBoxManage controlvm "Windows XP" savestate} automatically whenever I click the shutdown button. Is there a configuration script I need to edit to do this? What is it called and where is it located?
    Are you talking about when you click the shutdown button on the host OS?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  9. #9
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    You can edit sudoers so that you can run that command (and only that exact command) without a password.

    I'm not sure why you need to run the init script manually with sudo. It should be active on boot. Check this:

    chkconfig --list vboxdrv

    If not on in runlevels 3 and 5 at least, then do:

    chkconfig --set vboxdrv on

  10. #10
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: VirtualBox Linux kernel driver just doesn't want to work properly

    Quote Originally Posted by ah7013 View Post
    Are you talking about when you click the shutdown button on the host OS?
    If you are talking about the host OS and you are running KDE then this is what I would do:
    Code:
    kwrite ~/bin/savexpstate.sh
    Add this in that text file and save:
    Code:
    VBoxManage controlvm "Windows XP" savestate
    Then give it executable rights
    Code:
    chmod +x ~/bin/savexpstate.sh
    Then in KDE control center go to Startup and Shutdown -> Autostart -> Add script -> Browse to your home folder, click bin, then click on savexpstate.sh. Then hit OK. Then change run on for savexpstate.sh to Shutdown
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •