Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Font size adjustment

  1. #1
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    154

    Default Font size adjustment

    I'm running OpenSuSE 11.3, upgraded from 11.1, with the Nvidia video driver. The font size for Yast, Firefox, and several other things is too small. I've tried changing it using the Appearance section of Personal Settings. That changes the font size in some contexts such as the window titles and task manager, but not in all contexts. In Firefox I've tried something similar, but it doesn't affect the font used in the tabs, function bar on the top, etc. The font in those parts of Firefox is the same as the one in Yast. So there's some other font setting around, but I haven't been able to find it. I've tried Google and SDB, but have no success searching there.

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Font size adjustment

    Can I please have a look at your xorg.conf? Paste the output of:
    Code:
    cat /etc/X11/xorg.conf
    And also, did you manually install the nvidia driver or is it off the nvidia repo?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    154

    Default xorg.conf

    xorg.conf:
    # /.../
    # SaX generated X11 config file
    # Created on: 2010-10-05T21:28:46-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #

    Section "Files"
    FontPath "/usr/share/fonts/misc:unscaled"
    FontPath "/usr/share/fonts/local"
    FontPath "/usr/share/fonts/75dpi:unscaled"
    FontPath "/usr/share/fonts/100dpi:unscaled"
    FontPath "/usr/share/fonts/Type1"
    FontPath "/usr/share/fonts/URW"
    FontPath "/usr/share/fonts/Speedo"
    FontPath "/usr/share/fonts/PEX"
    FontPath "/usr/share/fonts/cyrillic"
    FontPath "/usr/share/fonts/latin2/misc:unscaled"
    FontPath "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath "/usr/share/fonts/latin2/Type1"
    FontPath "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath "/usr/share/fonts/baekmuk:unscaled"
    FontPath "/usr/share/fonts/japanese:unscaled"
    FontPath "/usr/share/fonts/kwintv"
    FontPath "/usr/share/fonts/truetype"
    FontPath "/usr/share/fonts/uni:unscaled"
    FontPath "/usr/share/fonts/CID"
    FontPath "/usr/share/fonts/ucs/misc:unscaled"
    FontPath "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/misc:unscaled"
    FontPath "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath "/usr/share/fonts/hellas/Type1"
    FontPath "/usr/share/fonts/misc/sgi:unscaled"
    FontPath "/usr/share/fonts/xtest"
    FontPath "/opt/kde3/share/fonts"
    InputDevices "/dev/gpmdata"
    InputDevices "/dev/input/mice"
    EndSection

    Section "ServerFlags"
    Option "AllowMouseOpenFail" "on"
    EndSection

    Section "Module"
    Load "glx"
    Load "type1"
    Load "extmod"
    Load "dbe"
    Load "freetype"
    EndSection

    Section "InputDevice"
    Driver "kbd"
    Identifier "Keyboard[0]"
    Option "Protocol" "Standard"
    Option "XkbLayout" "us"
    Option "XkbModel" "microsoftpro"
    Option "XkbRules" "xfree86"
    EndSection


    Section "InputDevice"
    Driver "mouse"
    Identifier "Mouse[1]"
    Option "Buttons" "5"
    Option "Device" "/dev/input/mice"
    Option "Name" "ImPS/2 Generic Wheel Mouse"
    Option "Protocol" "explorerps/2"
    Option "Vendor" "Sysp"
    Option "ZAxisMapping" "4 5"
    EndSection


    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 370 301
    HorizSync 31-70
    Identifier "Monitor[0]"
    ModelName "1280X1024@75HZ"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "--> VESA"
    VertRefresh 50-75
    UseModes "Modes[0]"
    EndSection


    Section "Modes"
    Identifier "Modes[0]"
    EndSection


    Section "Screen"
    DefaultDepth 24
    SubSection "Display"
    Depth 15
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection


    Section "Device"
    BoardName "Framebuffer Graphics"
    Driver "nvidia"
    Identifier "Device[0]"
    Screen 0
    VendorName "VESA"
    EndSection



    Section "ServerLayout"
    Identifier "Layout[all]"
    InputDevice "Keyboard[0]" "CoreKeyboard"
    InputDevice "Mouse[1]" "CorePointer"
    Option "Clone" "off"
    Option "Xinerama" "off"
    Screen "Screen[0]"
    EndSection


    Section "DRI"
    Group "video"
    Mode 0660
    EndSection

    Section "Extensions"
    EndSection

    pwa@suillus2:~> cd /etc/X11
    pwa@suillus2:/etc/X11> ls
    XF86Config Xresources x11perfcomp
    XF86Config-20051030 fs xdm
    XF86Config-20051030-0 fvwm2 xim
    XF86Config-20060408 gdm xim.d
    XF86Config-20060507 kconfigrc xinit
    XF86Config-20060820 lbxproxy xorg.conf
    XF86Config-20060919 proxymngr xorg.conf.backup
    XF86Config-suillus qt_plugins_3.1rc xorg.conf.d
    XF86Config.YaST2save qt_plugins_3.2rc xorg.conf.install
    XF86Config.install qt_plugins_3.3rc xorg.conf.md5
    XF86Config.saxsave qtrc xorg.conf.saxsave
    Xmodmap rstart xsm
    Xmodmap.remote susewm
    My Nvidia version came from the nvidia repo (I think). I got it using the one-step installation accessible via the SDB (SDB:Nvidia drivers).

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: xorg.conf

    I had the same problem. These are the steps I took to solve it. Run all these commands as root (by doing su -) -

    1. Make a backup of xorg.conf incase anything goes wring:
    Code:
    cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bak
    2. Modify xorg.conf and add these two lines under the "Monitor" section
    Code:
    Option         "UseEdidDpi" "FALSE"
    Option         "DPI" "96 x 96"
    So it should end up looking like:
    Code:
    Section "Monitor"
    Option "CalcAlgorithm" "XServerPool"
    DisplaySize 370 301
    HorizSync 31-70
    Identifier "Monitor[0]"
    ModelName "1280X1024@75HZ"
    Option "DPMS"
    Option "PreferredMode" "1280x1024"
    VendorName "--> VESA"
    VertRefresh 50-75
    UseModes "Modes[0]"
    Option         "UseEdidDpi" "FALSE"
    Option         "DPI" "96 x 96"
    EndSection
    3. Save and close the file. Now log off KDE and when you log back on the fonts should be fine
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    154

    Default Yast fonts still too small

    The fonts in Yast are still too small, though the other ones I've looked at seem OK (Firefox in particular). I don't remember having this problem when I was running 11.1, so it's not too likely that it's merely an 11.1 carryover.

    How did you come up with that magic incantation?

  6. #6
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Yast fonts still too small

    Quote Originally Posted by pwabrahams View Post
    The fonts in Yast are still too small, though the other ones I've looked at seem OK (Firefox in particular). I don't remember having this problem when I was running 11.1, so it's not too likely that it's merely an 11.1 carryover.

    How did you come up with that magic incantation?
    I remember reading it somewhere (think it was the Ubuntu forums) where someone else was experiencing a similar issue and by forcing the DPI (Dots Per Inch) in xorg.conf the fonts looked OK. If you want to change the font size in YaST log in as root (by doing su -) in Konsole and run:
    Code:
    qtconfig
    Then you can change font options under the Fonts tab
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,289
    Blog Entries
    15

    Default Re: Font size adjustment

    Quote Originally Posted by ah7013
    Option "DPI" "96 x 96"
    Hi
    It's best to verify first using xdpyinfo as to the DPI;
    eg for my setup it's;
    Code:
    xdpyinfo |grep resol
    resolution:    104x102 dots per inch
    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.24-0.2-default
    up 3 days 20:25, 2 users, load average: 0.11, 0.07, 0.02
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.21


  8. #8
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    154

    Default Problem now specific to Yast

    I did the qtconfig thing and discovered that according to qtconfig, the standard font is what it is supposed to be -- and the apps I've looked at now have the correct font.
    Except, that is, for Yast. I tried reinstalling Yast but that made no difference. As far as I can tell, Yast has no place for setting that kind of thing.

  9. #9
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Problem now specific to Yast

    Quote Originally Posted by pwabrahams View Post
    I did the qtconfig thing and discovered that according to qtconfig, the standard font is what it is supposed to be -- and the apps I've looked at now have the correct font.
    Except, that is, for Yast. I tried reinstalling Yast but that made no difference. As far as I can tell, Yast has no place for setting that kind of thing.
    Did you run qtconfig as root? I have successfully changed my font in YaST running qtconfig as root
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  10. #10
    Join Date
    Jun 2008
    Location
    Deerfield, Massachusetts
    Posts
    154

    Default Success at last

    Running qtconfig as root was the trick. Thanks much!

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •