Results 1 to 6 of 6

Thread: NX Nomachine typing on its own

  1. #1
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Unhappy NX Nomachine typing on its own

    I have nx nomachine installed on 64bit opensuse 11.2. All was fine until I ran updates this week and now it seems that it has a mind of its own. (dont remember which packages were updates)

    Every time I open the cli it just starts typing the equal symbol on its own. In fact every time I open anything that can accept text input it just starts adding equal symbols. It enters them about 2 every second.

    Code:
    jason@FileServer:~> =========================
    I uninstalled all the NX packages, killed the .nx folder in my user folder and then reinstalled the packages and still the same thing.

    Any ideas?

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: NX Nomachine typing on its own

    mejason69 wrote:
    > Any ideas?


    try a different keyboard..

    that is to say: it sure sounds like a hardware problem....sticky key,
    intermittent short circuit in the wire, bad ground in the plug, little
    speck of corrosion here or there...

    well, to me, it sounds like something somewhere in the _hardware_ has
    a fault which is introducing that key stroke..

    if it were me i'd check the hardware before emergency surgery on the
    software..

    how long has it been since you last spilled Red Bull on the keyboard? ;-)

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  3. #3

    Default Re: NX Nomachine typing on its own

    The keyboard doesn't always behave as expected in NX sessions. However the only issue I know (and fixed) is the one described in that thread: FreeNX / nomachine NXclient -- keyboard problems

  4. #4
    Join Date
    Jun 2008
    Location
    Miami, FL
    Posts
    68

    Default Re: NX Nomachine typing on its own

    Quote Originally Posted by DenverD View Post
    mejason69 wrote:
    > Any ideas?


    try a different keyboard..

    that is to say: it sure sounds like a hardware problem....sticky key,
    intermittent short circuit in the wire, bad ground in the plug, little
    speck of corrosion here or there...

    well, to me, it sounds like something somewhere in the _hardware_ has
    a fault which is introducing that key stroke..

    if it were me i'd check the hardware before emergency surgery on the
    software..

    how long has it been since you last spilled Red Bull on the keyboard? ;-)

    --
    DenverD
    CAVEAT: C A V E A T [posted via NNTP w/openSUSE 10.3]
    LOL, I should have mentioned it does it from any keyboard and any pc. From windows or linux clients. Also, in the local machine it does not add all the equal signs.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: NX Nomachine typing on its own

    mejason69 wrote:
    > I should have mentioned it does it from any keyboard and any pc.
    > From windows or linux clients.


    yep, always nice to know when it is not necessary to GUESS if hardware
    has already been eliminated as a possible cause..

    have you checked with the folks in the mx nomachine fora to see if
    there is a known problem with the (i guess) new kernel you (may) have
    installed in your update..

    by the way, you don't have to guess what you installed in the update,
    you can learn that with precision via yast/zypper logs and/or
    Code:
    rpm -qa --last
    i don't know, but you might find that nx has solved the problem..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD [posted via NNTP w/openSUSE 10.3]

  6. #6
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,037

    Default Re: NX Nomachine typing on its own

    Like DenverD, my first guess would have been hardware, but I see that you
    have eliminated that as a possible problem.

    When you say you have nomachine nx installed, are you referring to the
    client piece or the server piece?

    Either way, what you might do is connect to the server and stick a
    machine with wireshark on the wire (make sure you use a hub from the
    client end so you can sniff the traffic) and see if you see anything that
    might be keyboard data. You should disable encryption at the client so
    you can tell keyboard traffic vs. just regular ssh traffic (keepalives
    and the like). That would help narrow the problem down to a client
    config issue or a server config issue.

    Jim

    --
    Jim Henderson
    openSUSE Forums Administrator

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •