Results 1 to 6 of 6

Thread: help : How to remove the tab-like character in terminal?

  1. #1

    Smile help : How to remove the tab-like character in terminal?

    In my terminal , there's always a tab-like(a long space) between the
    "pswz-zhangy@linux-buym:~>" and the cursor, how can i get rid of if?
    thank you~~

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,913

    Default Re: help : How to remove the tab-like character in terminal?

    Quote Originally Posted by cnpswzy View Post
    In my terminal , there's always a tab-like(a long space) between the
    "pswz-zhangy@linux-buym:~>" and the cursor, how can i get rid of if?
    thank you~~
    You mean '~' character ?

    Best regards,
    Greg

  3. #3

    Default Re: help : How to remove the tab-like character in terminal?

    Hello cnpswzy and welcome to the community!

    Quote Originally Posted by cnpswzy
    In my terminal , there's always a tab-like(a long space) between the
    "pswz-zhangy@linux-buym:~>" and the cursor, how can i get rid of if?
    thank you~~
    That's simple to change.
    Open your ~/.bashrc and add this line:
    Code:
    export PS1="$USER@$HOST>"
    You can also change this to everything you want.
    Before this change has effect you need to log-out and in again.

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,644
    Blog Entries
    14

    Default Re: help : How to remove the tab-like character in terminal?

    Quote Originally Posted by cnpswzy View Post
    In my terminal , there's always a tab-like(a long space) between the
    "pswz-zhangy@linux-buym:~>" and the cursor, how can i get rid of if?
    thank you~~
    I know what you mean. There's about a tab's size of space after the prompt, and when you type chars don't appear at the cursor position properly.
    In my case I saw this on a LiveCD, behaviour was the same immediately after install, disappeared after installing the NVIDIA driver.
    Question: do you have an NVIDIA video card/gpu?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: help : How to remove the tab-like character in terminal?

    Quote Originally Posted by Knurpht View Post
    I know what you mean. There's about a tab's size of space after the prompt, and when you type chars don't appear at the cursor position properly.
    In my case I saw this on a LiveCD, behaviour was the same immediately after install, disappeared after installing the NVIDIA driver.
    Question: do you have an NVIDIA video card/gpu?
    thank you!

    I'm now running opensuse in a sun VirtualBox.
    It looks like a offset, and become longer when the cursor goes near the right edge of the terminal window.
    Sorry, my expression maybe confusing~~

  6. #6
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: help : How to remove the tab-like character in terminal?

    Quote Originally Posted by cnpswzy View Post
    It looks like a offset, and become longer when the cursor goes near the right edge of the terminal window.
    Is that in a real (like in ALT+CTRL+F1) or emulated (like Konsole) terminal? It might be related to the way a terminal emulator compute the pseudo cursor position being confused by the virtual machine DPI settings, which might differ from the host's DPI. You could try setting the opensuse VM DPI to 96 bps, see if it helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •