Results 1 to 3 of 3

Thread: KDE 4.5.4 update broken dependency

  1. #1
    Join Date
    Dec 2009
    Location
    Menominee, Michigan
    Posts
    55

    Default KDE 4.5.4 update broken dependency

    On my opensuse 11.2 pc, the Decmber 3rd KDE 4.5.4 update proceeded to install all updates except libkdecore4 (and maybe others). libkdecore4 now has a dependency on liblzma5 which is not available. The result is an all white desktop with boxes where the widgets should be.

    I found this bug report: https://bugzilla.novell.com/show_bug.cgi?id=657433
    But I can't find liblzma5 in the repository that is listed in the 2nd posting.

    Code:
    mark@baird:~> zypper lr -d
    #  | Alias                                  | Name                                   | Enabled | Refresh | Priority | Type   | URI                                                                                  | Service
    ---+----------------------------------------+----------------------------------------+---------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
    1  | 11.2_Wine_Repository                   | 11.2 Wine Repository                   | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Emulators%3a/Wine/openSUSE_11.2            |        
    2  | GNOME:Apps                             | GNOME:Apps                             | Yes     | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/GNOME%3a/Factory/openSUSE_11.2/            |        
    3  | Packman_Repository_USA                 | Packman Repository USA                 | Yes     | Yes     |   90     | rpm-md | http://packman.unixheads.com/suse/11.2/                                              |        
    4  | Printing                               | Printing                               | Yes     | Yes     |  100     | rpm-md | http://download.opensuse.org/repositories/Printing/openSUSE_11.2/                    |        
    5  | Virtualization:VirtualBox_1            | Virtualization:VirtualBox              | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_11.2/              |        
    6  | download.videolan.org-SuSE             | VideoLan Repository                    | No      | No      |   99     | rpm-md | http://download.videolan.org/pub/videolan/vlc/SuSE/11.2/                             |        
    7  | google-chrome                          | google-chrome                          | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                  |        
    8  | openSUSE 11.2 Debug                    | openSUSE 11.2 Debug                    | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/debug/distribution/11.2/repo/oss                        |        
    9  | openSUSE 11.2 KDE Factory Desktop      | openSUSE 11.2 KDE Factory Desktop      | No      | No      |  100     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.2/ |        
    10 | openSUSE-11.2-Non-Oss_1                | openSUSE-11.2-Non-Oss                  | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/non-oss/                         |        
    11 | openSUSE-11.2-Oss_1                    | openSUSE-11.2-Oss                      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.2/repo/oss/                             |        
    12 | openSUSE:Education:openSUSE_11.2       | openSUSE:Education:openSUSE_11.2       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/Education/openSUSE_11.2                    |        
    13 | openSUSE:Factory:Contrib:openSUSE_11.2 | openSUSE:Factory:Contrib:openSUSE_11.2 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:Factory:Contrib/openSUSE_11.2     |        
    14 | openSUSE_11.2_kde_4.5                  | openSUSE_11.2_kde_4.5                  | Yes     | Yes     |   92     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/45/openSUSE_11.2/            |        
    15 | repo-update                            | openSUSE-11.2-Update                   | Yes     | Yes     |   92     | rpm-md | http://download.opensuse.org/update/11.2/
    The opensuse 11.3 version of libkdecore4 only depends on liblzma0.



    Does anyone have any suggestions as to a workaround?

    Thanks
    Mark

    opensuse 11.2 64Bit

  2. #2
    Join Date
    Mar 2009
    Location
    Belgium
    Posts
    45

    Default Re: KDE 4.5.4 update broken dependency

    same question here...
    Noticed that openSUSE 11.3 went fine, but my 11.2 box is having this dependency problem like above.

  3. #3
    Join Date
    Dec 2009
    Location
    Menominee, Michigan
    Posts
    55

    Default Re: KDE 4.5.4 update broken dependency

    The update today (December 4th) fixed the depencency problem and I was able to successfully update all KDE files. Some settings in .kde4 got mangled and I had no panels and I couldn't see my widgets even though they were running.

    Code:
    mark@baird:~> rpm -qR libkdecore4
    libqt4 >= 4.6.3
    /sbin/ldconfig  
    /sbin/ldconfig  
    rpmlib(PayloadFilesHavePrefix) <= 4.0-1
    rpmlib(CompressedFileNames) <= 3.0.4-1
    libQtCore.so.4()(64bit)  
    libQtDBus.so.4()(64bit)  
    libQtNetwork.so.4()(64bit)  
    libbz2.so.1()(64bit)  
    libc.so.6()(64bit)  
    libc.so.6(GLIBC_2.2.5)(64bit)  
    libc.so.6(GLIBC_2.3.4)(64bit)  
    libc.so.6(GLIBC_2.4)(64bit)  
    libfam.so.0()(64bit)  
    libkdecore.so.5()(64bit)  
    liblzma.so.0()(64bit)  
    libm.so.6()(64bit)  
    libm.so.6(GLIBC_2.2.5)(64bit)  
    libpthread.so.0()(64bit)  
    libpthread.so.0(GLIBC_2.2.5)(64bit)  
    libstdc++.so.6()(64bit)  
    libstdc++.so.6(CXXABI_1.3)(64bit)  
    libstdc++.so.6(GLIBCXX_3.4)(64bit)  
    libstdc++.so.6(GLIBCXX_3.4.11)(64bit)  
    libstdc++.so.6(GLIBCXX_3.4.9)(64bit)  
    libutempter.so.0()(64bit)  
    libutil.so.1()(64bit)  
    libutil.so.1(GLIBC_2.2.5)(64bit)  
    libz.so.1()(64bit)  
    rpmlib(PayloadIsLzma) <= 4.4.6-1
    Code:
    mark@baird:~> rpm -q --changelog libkdecore4 | less
    * Sat Dec 04 2010 tittiatcoke@gmail.com
    - Make sure that the right version of xz (lzma) is chosen to
      prevent that users have to add additional repo's
    snip...
    Code:
    mark@baird:~> rpm -q libkdecore4
    libkdecore4-4.5.4-9.1.x86_64
    Mark

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •