Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Bei sicherer Verbindung kei Seitenaufbau.

  1. #1

    Question Bei sicherer Verbindung kei Seitenaufbau.

    Hallo!

    Ich habe OpenSuse 11.3 mit KDE auf einem DELL STUDIO 17xx.
    Seit der Neuinstallation von 11.3 kann ich nicht auf https Seiten zugreifen.
    Wenn ich z.b. versuche auf meine eMail zuzugreifen (web.de) kann ich sie lesen.
    Aber wenn ich versuche sie zu löschen geht es nicht. Nach einiger Zeit schreibt er mir
    "Verbindung wurde durch den Server beendet."
    Genauso Online-Banking geht nicht, der Rechner steht still und ruft die Seiten nicht
    auf.
    Das passiert bei ALLEN Browsern in openSUSE! Habe schon versucht die proxy Einst. in den Servern einszustellen aber es bringt nichts.
    Unter Windows kann ich auf alles zugreifen. Hat jemand eine Idee??

    Gruss
    Chris.

  2. #2
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Hallo zusammen,

    mein erster spontaner Gedanke: Firewall ausschalten.

    Liebe Grüße

    Erik

  3. #3

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Habe ich bereits versucht ohne Erfolg.

  4. #4
    esvau008 NNTP User

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Am 03.12.2010 23:36, schrieb psifus:
    >
    > Habe ich bereits versucht ohne Erfolg.
    >

    Hallo Chris,

    also ich würde es _erstmal_ nicht bei der Firewall vermuten, denn
    schließlich wird man nicht unbedingt ausgehende https-Verbindungen
    blocken (es ist nicht unmöglich, aber selten sinnvoll, oder?)
    Verbindungsfehler, die in eine Art timeout laufen, haben sehr häufig
    DNS-Probleme als Ursache. Aber Du baust ja bereits erfolgreich eine
    Verbindung zur Seite (web.de) auf: also muss auch die DNS-Anfrage i.O.
    sein. Trotzdem empfehle ich, mal im Log-File (tail -f /var/log/messages
    /var/log/localmessages) zu sehen - während der Verbindungsstörungen (der
    Zugriff auf dieses Dateien ist nur für Root erlaubt! Dieses "tail -f
    ...." kann man mit Strg+c wieder verlassen).

    Richtig ist es auch mal nach den Proxy-Einstellungen zu sehen: Betreibst
    DU einen eigenen lokalen, benutzt Du einen vom Provider oder gehts auch
    direkt? Wenn es direkt auch geht, wäre es eine gute Möglichkeit, um
    evtl. Störungsquellen auszuschliessen. Was gibt denn "env | grep proxy"
    aus und was ist z.B. beim FF eingestellt? Ausnahmen?

    Beim FF kann man auch mit div. Einstellungen und Add-Ons (Stichwort
    NoScript) die Benutzung von div. Webseiten verunmöglichen....

    Schau mal nach und zeigt uns, was da eingestellt ist.

    Schönen Sonntag noch
    Sven

  5. #5
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Hallo zusammen,

    ich würde vorschlagen, wir gehen das analytisch an. Mache bitte folgendes:

    Schließe alles, was auf http oder den Proxy zugreifen könnte außer einem Browserfenster. Vergiss nicht, die Update-Funktion abzuschalten. Wir wollen das Ergebnis klein halten. Danach schaltest Du sie einfach wieder an. Die paar Minuten werden schon nichts schaden. Dann wechselst Du auf die Konsole und tippst folgendes:

    Code:
    su
    rootpasswort
    netstat -apneec | grep :80 > /home/DeinHomeDir/netstat.txt
    "rootpasswort" und "DeinHomeDir ersetzt Du natürlich durch das, was bei Dir gilt. Wundere Dich nicht. Es scheint nichts zu passieren, da der Parameter -c netstat anweist, jede Sekunde ein Update auszuspucken. Dann öffnest Du eine Seite, die langsam lädt. Warte so lange, bis sie aufgebaut ist oder es zu einem Timeout kommt. Dann wechselst Du wieder auf die Konsole und beendest dort den netstat-Befehl mit STRG-C. Dann tippst Du:

    Code:
    chown DeinUserName /home/DeinHomeDir/netstat.txt
    exit
    Nun machst Du den netstat.txt auf. In diesem solltest Du Zeilen wie diese finden:

    Code:
    tcp        0      0 192.168.1.23:47709      130.57.4.15:80          VERBUNDEN   1004       838941     1708/seamonkey-bin
    Spannend ist vor allem die Spalte STATUS. Das ist die, in der im Beispiel "VERBUNDEN" steht. Was steht da? Ändert sich das, was da steht? Auch interessant sind die zweite und dritte Spalte, in denen im Beispiel zwei Nullen stehen. Das erste ist die Receive-Queue und das zweite die Send-Queue. Wie sind die Werte? Ändern sich die Werte? Ich fürchte, die Ergebnismenge wird zu groß, als dass Du sie hier posten könntest. Aber ein paar Beispielzeilen könntest Du rauskopieren, wenn sich was geändert hat. Dann sehen wir weiter.

    Liebe Grüße

    Erik

  6. #6
    Join Date
    Sep 2008
    Location
    Sulzbach (Taunus), Hessen [Hesse], Deutschland [Germany]
    Posts
    2,178

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Ein kleiner Einwurf:
    Quote Originally Posted by erikro View Post
    [...]Ich fürchte, die Ergebnismenge wird zu groß, als dass Du sie hier posten könntest.[...]
    Vielleicht kann ja
    SUSE Paste auf paste.opensuse.org
    benutzt werden, wenn man nicht weiß, was nun interessant sein könnte?

    LG
    pistazienfresser

  7. #7

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Wooooaa.. so viel Info.. Werde es nach und nach mal durchgehen.
    Noch eine Info zu meinem Problem. Es tritt auch auf dem Notebook meines Vaters auf.
    WIr haben zur gleichen Zeit opensuse 11.3 installiert. Und seit dem ist der zugriff
    auf https(ssl?)-Seiten erschwert. Auf einige können wir zugreifen auf anderen bleibt er stehen. Onlinebanking geht nur anschauen, wenn ich ne funtion machen will steht er still und es kommt nach ner zeit die info mit dem "server bricht ab..."

    Gruss

    Chris

  8. #8
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Hallo zusammen,

    was hattet Ihr denn vorher drauf? Ich erinnere mich bei solchen Problemen in englischen Foren häufiger den Tipp gelesen zu haben, IPv6 auszuschalten. So wie ich das verstanden habe, ist das aber eher ein Problem des Routers, der kein IPv6 kann. Dann könnte das auch unter 11.3 helfen. Probieren kannst Du es ja mal.

    Liebe Grüße

    Erik

  9. #9

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Hallo!

    Hatten vorher opensuse 11.2 drauf und alles lief super. IPv6 ist deaktiviert.
    Problem ist immer noch da:

    Kann meine eMail angucken (bei web.de) wenn ich sie markiere und löschen will
    dann ist es vorbei (Die Verbindung wurde durch den Server beendet.)
    Was mir aufgefallen ist, das es nur passiert wenn ich den LÖSCHEN - BUTTON drücke.
    Wähle ich es per rechte Maustaste, dann löscht er die Nachrichten ohne Probleme.
    Als wenn da irgendeine Funtion aufgerufen wird, die blockiert wird und die Verbindung
    abbricht.... ??!!

    Chris

  10. #10
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Bei sicherer Verbindung kei Seitenaufbau.

    Hallo zusammen,

    und wie sieht nun die Ausgabe von netstat aus???

    Liebe Grüße

    Erik

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •