Results 1 to 2 of 2

Thread: No compositing (Desktop Effects) using nvidia on opensuse11.3-Xen

  1. #1

    Unhappy No compositing (Desktop Effects) using nvidia on opensuse11.3-Xen

    I am receiving the following error when trying to enable Compositing in Desktop Settings for KDE4 in openSuse 11.3-Xen
    Code:
    Error: Compositing is not supported on your system.
    Required X extensions (XComposite and XDamage) are not available.
    I want to have desktop effects enabled but can't seem to figure out how to get this done.

    "Advanced" Tab is greyed out.
    "Enable desktop effects" is greyed out.

    Computer: Dell Precision M4300 Laptop
    Graphics Card: NVidia Quadro FX 360M)
    Kernel: 2.6.34.7-0.5-xen #1 SMP 2010-10-25 08:40:12 +0200 x86_64 GNU/Linux
    Xinerama: enabled
    Nvidia Installer Version: NVIDIA-Linux-x86_64-260.19.21

    Here are snippets from xorg.conf (will post any relevant section upon request).
    Code:
    Section "Files"
        ModulePath      "/usr/lib64/xorg/modules/extensions"
        ModulePath      "/usr/lib64/xorg/modules/drivers"
        ModulePath      "/usr/lib64/xorg/modules"
    EndSection
    Code:
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    Code:
    Section "Extensions"
        Option         "Damage" "Enable"
        Option         "Composite" "Enable"
    EndSection
    I had to install the NVidia drivers for Xen using the following talk through: Talk:Use Nvidia driver with Xen - openSUSE
    This worked to get X up and running in the Xen kernel. However, I'm pulling what hair I have left trying to figure out how to enable compositing in Xen. The entire motivation for my upgrade was this one feature (amongst some other things).

    Please show me where I'm going wrong. I hope this is not a "live with it" type of scenario due to my using Xen.

  2. #2

    Wink [SOLVED] No compositing (Desktop Effects) using nvidia on opensuse11.3-Xen

    You will notice the [SOLVED] in the header.
    The problem was that I was using Xinerama and not Twinview to handle both my monitors. (My rationale for using Xinerama was that it allowed each monitor to act as a separate monitor when maximizing windows... this feature has been added to Twinview to have been fixed). The following URL was my source for solving this problem: [gnome] [SOLVED] Nvidia- Composite extension is not available - Ubuntu Forums

    Xinerama apparently does not support Compositing. I am not sure if there is any advantage to having Xinerama vs Twinview at this point. Anyway, here is how to fix it:

    Installation of NVIDIA Driver in Xen Kernel

    You can follow the instructions here: Use Nvidia driver with Xen - openSUSE

    The key section is setting the environment variables prior to running Nvidia's installer (I was previously doing it the hard way which involved extraction of the installer and patching it). Those variables are:
    Code:
    $ export IGNORE_XEN_PRESENCE=1
    $ export SYSSRC=/lib/modules/$(uname -r)/source
    $ export SYSOUT=/lib/modules/$(uname -r)/build
    Configuring X
    1. Start "nvidia-settings" as root
      Code:
      $ su -
      $ nvidia-settings
    2. under "X Server Display Configuration" click on "Configure..."
    3. select "TwinView"
    4. Click on "Save to X Configuration File"
    5. Click on Quit
    6. Restart X

    Compositing should now be available on your Xen Desktop... well worth the headache for Desktop Effects.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •