Results 1 to 7 of 7

Thread: vmware console eyboard quick question

  1. #1
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default vmware console eyboard quick question

    Hi,

    I have two vmware client setups, for testing things in linux. I let them
    often in text mode. I'm used to issue ctrl-R in bash to retrieve the
    history. The problem is, in the vmware-server session, if I forget that I'm
    not yet "IN", ie, the client is not grabbing the keyboard, it only has the
    focus, the console gets the ^R instead of the client, and it reboots the
    client machine! Without asking.

    I want to disable that ^R keyboard shortcut for reset.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  2. #2

    Default Re: vmware console eyboard quick question

    Hello robin_listas,

    Quote Originally Posted by robin_listas
    Hi,

    I have two vmware client setups, for testing things in linux. I let them
    often in text mode. I'm used to issue ctrl-R in bash to retrieve the
    history. The problem is, in the vmware-server session, if I forget that I'm
    not yet "IN", ie, the client is not grabbing the keyboard, it only has the
    focus, the console gets the ^R instead of the client, and it reboots the
    client machine! Without asking.

    I want to disable that ^R keyboard shortcut for reset.
    After some searching I found this article: VMware's worst feature: Ctrl-R to reboot - Contentment
    It isn't really a solution but a workaround.
    Instead of resetting your client it will ask for confirmation.

    Also read the first comment because it corrects a fault in the article.
    Quote Originally Posted by Reply
    ... It is "hint.vmui.reset", not "pref.vmui.reset"...
    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  3. #3
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vmware console eyboard quick question

    On 2010-11-30 15:36, Edward Iii wrote:

    > Also read the first comment because it corrects a fault in the article.
    > Reply Wrote:
    >> ... It is "hint.vmui.reset", not "pref.vmui.reset"...

    >
    > Good luck!
    >
    >


    Wonderful!

    But it does not work... :-(

    It also says:

    > Next, save the file and open VMware Console back up and go to Help > Hints > Show Enabled Hints. Make sure you do both or you will still be frustrated the next time you hit Ctrl-R.



    I do not have that menu entry, no "help" button. Maybe the trick is not for
    the server version.


    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  4. #4

    Default Re: vmware console eyboard quick question

    Hello robin_listas,

    Quote Originally Posted by robin_listas
    Wonderful!

    But it does not work... :-(

    It also says:

    > Next, save the file and open VMware Console back up and go to Help > Hints > Show Enabled Hints. Make sure you do both or you will still be frustrated the next time you hit Ctrl-R.



    I do not have that menu entry, no "help" button. Maybe the trick is not for
    the server version.
    Sad to hear it doesn't work.
    I thought it would have worked because it also says:
    Quote Originally Posted by article
    I run Windows on my Linux desktop using VMware Server. ...
    But there's another workaround: VMWare ctrl-z key binding, how to remove - Stack Overflow
    This workaround is actually for the [Ctrl] + [z] key binding but it should also work for the [Ctrl] + [r].

    Good luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vmware console eyboard quick question

    On 2010-11-30 17:06, Edward Iii wrote:

    >> I do not have that menu entry, no "help" button. Maybe the trick is not
    >> for the server version.

    > Sad to hear it doesn't work.
    > I thought it would have worked because it also says:
    > article Wrote:
    >> I run Windows on my Linux desktop using *VMware Server*. ...


    It might have been for version 1 of the console.


    > But there's another workaround: 'VMWare ctrl-z key binding, how to
    > remove - Stack Overflow' (http://tinyurl.com/33yuhhc)
    > This workaround is actually for the [Ctrl] + [z] key binding but it
    > should also work for the [Ctrl] + [r].
    >
    > Good luck!


    Interesting... it says:


    This will not remove the key binding from VmWare, but you could set the
    option to "Grab keyboard and mouse intput on key press" in the VmWare
    preferences. VmWare help explicitly states that this will disable the
    system accelerator key sequences.


    But I don't see those preferences anywhere. No preferences menu. I suppose
    I have to edit the preferences file:

    pref.grabOnKeyPress = "TRUE"

    and restart the console.

    [...]

    Wow. Children, don't do this at home...

    It grabbed the keyboard alright, but then did not release it. Pressing
    ctrl-alt released and grabbed the keyboard continously, but I could not tab
    to the host as any key was grabbed. The mouse died (the VM was in text
    mode), and as the host remembered the mouse position over the vmconsole...
    impossible to exit. It cycled continuously as if I had pressed [enter] and
    never released it.

    Nothing worked. I had to boot the laptop, ssh-in, find the PID of the
    console and kill it.

    I changed the option back to false. Then I found another preference - there
    is no menu here:

    hints.hideAll = "TRUE" (tried also FALSE).

    which should work together with

    hint.vmui.reset = "TRUE"
    hint.vmui.poweroff = "TRUE"


    But it doesn't work... machine resets with no questions asked. Puagh.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6

    Default Re: vmware console eyboard quick question

    Hello robin_listas,

    Quote Originally Posted by robin_listas
    Interesting... it says:


    This will not remove the key binding from VmWare, but you could set the
    option to "Grab keyboard and mouse intput on key press" in the VmWare
    preferences. VmWare help explicitly states that this will disable the
    system accelerator key sequences.


    But I don't see those preferences anywhere. No preferences menu. I suppose
    I have to edit the preferences file:

    pref.grabOnKeyPress = "TRUE"

    and restart the console.

    [...]

    Wow. Children, don't do this at home...

    It grabbed the keyboard alright, but then did not release it. Pressing
    ctrl-alt released and grabbed the keyboard continously, but I could not tab
    to the host as any key was grabbed. The mouse died (the VM was in text
    mode), and as the host remembered the mouse position over the vmconsole...
    impossible to exit. It cycled continuously as if I had pressed [enter] and
    never released it.

    Nothing worked. I had to boot the laptop, ssh-in, find the PID of the
    console and kill it.

    I changed the option back to false. Then I found another preference - there
    is no menu here:

    hints.hideAll = "TRUE" (tried also FALSE).

    which should work together with

    hint.vmui.reset = "TRUE"
    hint.vmui.poweroff = "TRUE"


    But it doesn't work... machine resets with no questions asked. Puagh.
    I totally didn't expect that to happen.

    I'm afraid I'm out of suggestions.
    Hopefully you'll find a solution!

    Best of luck!
    Where did I put my coffee cup?
    dir -R /home/* | grep "coffee cup"

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: vmware console eyboard quick question

    On 2010-12-01 15:36, Edward Iii wrote:

    >>
    >> But it doesn't work... machine resets with no questions asked. Puagh.

    > I totally didn't expect that to happen.
    >
    > I'm afraid I'm out of suggestions.


    They were good suggestions. Just bad luck.

    > Hopefully you'll find a solution!


    Yes, perhaps somebody knows why they did not work for me, or there is
    another way. Or perhaps they suddenly work another day if I reboot or
    something - computers are sometimes unpredictable! :-}

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •