Results 1 to 4 of 4

Thread: Remmina keyboard mapping problem

  1. #1

    Default Remmina keyboard mapping problem

    I'm running openSUSE 11.3 on my HP Pavilion dv5 laptop. I've installed remmina from Factory:Contrib to use to remote control my Windows 7 desktop at work. I've used it without problems on Ubuntu, but I'm having a real problem in openSUSE that I cannot find any solution for. Certain keys are not mapping correctly. Specifically, the delete and navigation keys aren't working right. Down-arrow causes the Start menu to open.

    At this point, I haven't a clue where to begin. I've played around with keyboard layouts to no avail. I've also tried compiling from source from the remmina website, but the result was the same. Considering how little I've been able to find on this problem, this does not seem to be common problem.

    Can anyone offer a solution or point me in the right direction.

  2. #2

    Default Re: Remmina keyboard mapping problem

    Looks like I solved my own problem. I decided to try the standalone freerdp client. No keymap problems. I noticed the following in the console output:

    Loading keymap evdev
    xkbfilepath: /usr/share/freerdp/keymaps/evdev
    I thought it looked familiar from running remmina from the console previously. I ran remmina from the console again and sure enough I saw the same output. The difference now is that remmina appears to be working okay. No keymap problems.

    Checking the file list for both remmina-plugins and freerdp shows that /usr/share/freerdp/keymaps/evdev is installed by freerdp and not remmina-plugins. My guess is that the keymaps from freerdp are needed by remmina, but since freerdp itself isn't needed for RDP support, it isn't installed as a dependency. Of course, I'm no expert on this, but that is how it appears to me.

    To make a long story short, if you are having keymap problems with RDP connections using remmina, install the freerdp package

  3. #3

    Default Re: Remmina keyboard mapping problem

    Thank You Sir!

    Just installed Remmina because rdesktop wouldn't connect to the Win 2K3 server I needed to connect to. In putty on the box, I couldn't get the pipe key "|" to work. Hard to grep things out without that!

    Installed freerdp and all the keys (arrows as well) work great.

    Thanks again.

  4. #4

    Default Re: Remmina keyboard mapping problem I CONFIRM SOLUTION FOR Ubuntu 11.10

    Installing freerdp does remove problems with keymapping in remmina in Ubuntu 11.10. I have also made a proper keyboard setting in remmina in Settings->RDP tab.

    Many thanks to Author!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts