Results 1 to 10 of 10

Thread: Shutdown failed on Suse 11.3

  1. #1

    Default Shutdown failed on Suse 11.3

    Hello,

    When I try to shutdown, logout, reboot using the graphical interface (Menu, Leave and then shutdown,reboot,..), I get the shutdown window and when I press the shutdown button, nothing happens. When I issue in a terminal window 'shutdown -h now' the system shuts down however.
    Does someone had a simular problem and if so how did they resolve it.

    Note that I use the 64 bit version of Suse 11.3 on a Dell Precison T5400 with a NVidea G290 card (using the NVidea drivers).

    Thanks a lot in advance

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Shutdown failed on Suse 11.3

    * marclisp,

    so this is KDE?

    You could try and play with the settings in /usr/share/kde4/config/kdm/kdmrc:

    [Shutdown]
    # The command (subject to word splitting) to run to halt the system.
    # Default is "/sbin/halt"
    #HaltCmd=

    Try uncommenting it and set it to the default /sbin/halt first, or try /sbin/poweroff

    Uwe

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Shutdown failed on Suse 11.3

    Another thing to try is try executing KDE shutdown from Konsole. Just do this as your normal user account (not root):

    Code:
    qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 0 2 2
    Does that shut down the computer?
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  4. #4
    upscope NNTP User

    Default Re: Shutdown failed on Suse 11.3

    ah7013 wrote:

    >
    > Another thing to try is try executing KDE shutdown from Konsole. Just
    > do this as your normal user account (not root):
    >
    >
    > Code:
    > --------------------
    > qdbus org.kde.ksmserver /KSMServer
    > org.kde.KSMServerInterface.logout 0 2 2
    > --------------------
    >
    >
    > Does that shut down the computer?
    >

    I have been following this thread and others trying to figure out why I
    cannot shutdown my 11.3 or 11.4 system but my 11.2 shuts down OK. All
    are on same system but individual disc drives.

    I tried your command and it worked the first time on my 11.3 system but
    the second time I tried it I get the usual message I have been getting.

    System will shutdown immediately
    [ some numbers} Power Down
    ex. [693 004373]Power Down

    have left sit for up to 20 minutes, only way to shut down the rest of
    way is the power button.

    I have noticed if I do a kernel update the log-out/shutdown usually
    works the first time, but then symptoms as above. Its like something is
    not being set or rest.

    See bugzilla # 619754 which I updated after trying above.

    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 8|
    Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

  5. #5

    Default Re: Shutdown failed on Suse 11.3

    Hello,

    Thanks all for the quick replies. Unfortunately neither the first solution (kdm settings) or the second solution seems to work.
    When I type in qdbus org.kde.ksmserver /KSMServer org.kde.KSMServerInterface.logout 0 2 2 no shutdown happens and I don't see any error message at all. One thing I noticed + also one thing I forget to mention when I started the thread is the following: When I used the menu 'Leave->Shutdown' I get the first time a dialog box asking to confirm if I want to shutdown (together with a timer couting down), but not shutdown. When I do this a second time I didn't get this dialog box anymore.
    When I restart my computer and I issue the command 'qdbus ..." no shutdown happens and when I try the menu 'Leave -> Shutdown' I didn't got the dialog box either.
    Some extra info which could be maybe usefull, I played with the powersave settings, to avoid blanking my screen after a certain period of inactivity.

    Again thanks for any help.

    Marc Mertens

  6. #6

    Default Re: Shutdown failed on Suse 11.3

    I have noticed that if you install both KDE & Gnome then you need to shutdown from whichever GUI is your main desktop, otherwise it will not shutdown but simply log you out of whichever system you are currently running.

  7. #7

    Default Re: Shutdown failed on Suse 11.3

    Hello,


    unfortunately, I stay in the desktop when I do a shutdown. By the way logout or resart does not work either. It looks to me that the menu options to shutdown, restart or logout does not work at all on my system.

    Marc Mertens

  8. #8
    upscope NNTP User

    Default Re: Shutdown failed on Suse 11.3

    marclisp wrote:

    >
    > Hello,
    >
    >
    > unfortunately, I stay in the desktop when I do a shutdown. By the
    > way logout or resart does not work either. It looks to me that the
    > menu options to shutdown, restart or logout does not work at all on my
    > system.
    >
    > Marc Mertens
    >

    1. I never get the count down message. If I click logout - shutdown it
    goes all the way except the final step.(shutting down).

    2. My restart has always worked good on 11.3, 11.4, and 11.2. 11.2 also
    shuts down correctly so I assume its not my BIOS or Hardware. I also
    have an old PIII thathas 11.2 and it also works fine. I'd try 11.3 on it
    but its so slow you can take a nap waitting for it to start or do
    anything. Max memory on it is 640KB.

    If you find something that works more than once, Please post it. I will
    do same.

    --
    Russ
    openSUSE 11.3 (2.6.34.7-0.5-default)|KDE 4.5.3 Release 10|
    Intel core2duo 2.5 MHZ,|4GB DDR3|GeForce 8400GS

  9. #9

    Default Re: Shutdown failed on Suse 11.3

    Hello,

    I trie d switch user to switch to root to do the shutdown as root. I was actually able to switch user to root but alas the shutdown, logout is still not working. Can someone tell me what happens when you use the UI to do a shutdown/logout so that I can see which configuration files are involved and try to solve the problem. I really like suse 11.3 and the latest version of kde but this shutdown problem is driving me nuts.

    Thanks for any help.

    Marc Mertens

  10. #10

    Default Re: Shutdown failed on Suse 11.3

    Hello Everyone,

    I solved my problem (although I detected another problem). It seemed that during shutdown, logout , restart KDE tries to play a ogg vorbis sound file. If this fails the shutdown, logout, restart fails. When I disabled sound in the system notiofications the problem was solved. See https://bugs.kde.org/show_bug.cgi?id=213541 for more details on this.
    Now to figure out why I can't play ogg vorbis files.


    Have a good day

    Marc Mertens

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •