Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: NetworkManager waiting for authorization

  1. #11
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: NetworkManager waiting for authorization

    On 11/22/2010 07:36 PM, tsu2 wrote:
    >
    > Prob a little late but i would have been <really> interested in trying
    > to discover why kwallet was involved (maybe connecting to WEP using an
    > unusual network manager?).
    >
    > I'm under the impression when connecting to a WPA AP, the wireless key
    > is encrypted and stored in the wpa_supplicant config file. Running the
    > encrypted file through a decryptor should have revealed what it was, and
    > simply removing that single line should have enabled a new key to be
    > entered (if that is even necessary).


    When you use NM, the encryption key is stored using the method you select in the
    Connection Manager under the Other group. The default is "In Secure Storage
    (Encrypted)", otherwise known as in a wallet. When a connection attempt is made,
    NM writes the configuration file for wpa_supplicant on the fly. Your impression
    is not correct when using NM. In addition, the configuration file used in manual
    applications is not encrypted - security depends only on the fact that only root
    can read it.


  2. #12

    Default Re: NetworkManager waiting for authorization

    I just installed the opensuse 12 and regret to say that the same thing is visible here. I am rather disappointed with the NetworkManager and its constant "waiting for authorization". I performed the steps above where i have to delete the config files for kwallet and NM.Kwallet came up again and asked me for pwd. i told it i dont want anything setup.guess what the interface stillw aits for autho.I will switch to ifup method.This is ridicoulous.

  3. #13
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: NetworkManager waiting for authorization

    On 14/12/11 22:36, dann radkov wrote:
    >
    > I just installed the opensuse 12 and regret to say that the same thing
    > is visible here. I am rather disappointed with the NetworkManager and
    > its constant "waiting for authorization". I performed the steps above
    > where i have to delete the config files for kwallet and NM.Kwallet came
    > up again and asked me for pwd. i told it i dont want anything
    > setup.guess what the interface stillw aits for autho.I will switch to
    > ifup method.This is ridicoulous.
    >
    >


    Make your network connection a system connection
    http://dl.dropbox.com/u/10573557/SUS...reless-new.png

  4. #14
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    13,206
    Blog Entries
    3

    Default Re: NetworkManager waiting for authorization

    Quote Originally Posted by dann_radkov View Post
    I just installed the opensuse 12 and regret to say that the same thing is visible here. I am rather disappointed with the NetworkManager and its constant "waiting for authorization".
    I think this is a NetworkManager bug, or perhaps a PolicyKit bug. I ran into the same problem over the last few days while visiting relatives. I set the connection to "System Connection" and "Automatically connect". Most of the time, when I boot, it would connect. But sometimes I would get that "waiting for authorization". I tried XFCE, which used the gnome applet, and that failed to connect though I don't remember the error message in that case.

    Back in KDE, I was not able to do anything to get it to connect. I tried a disconnect, followed by a connect. That cause a PolicyKit authorization window to come up. I entered the root password. Then it went back to "waiting for authorization." Rebooting did get me connected. But something is evidently broken here.

    Fortunately, that does not happen on my home network.

    No, I have not reported as a bug. Because it does not happen on my home network, I can't reproduce the problem to gather useful evidence to report.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #15
    Join Date
    Feb 2010
    Location
    Upstate New York, USA
    Posts
    480

    Default Re: NetworkManager waiting for authorization

    Quote Originally Posted by Knurpht View Post
    I wouldn't think it's a bug. Even more: I bet that if you create a new user, login as that user, the whole thing will work.


    What you can do is removing the config files for the networkmanager and kwallet. That would force recreation of defaults: the first time you connect to a network, the walletmanager setup program would run. If you want to try this, here you go:


    Logout
    Hit Ctrl-Alt-F1
    login with username and password, do:
    Code:
    rm -rf ~/.kde4/share/apps/networkmanager
    rm -rf ~/.kde4/share/apps/kwallet
    rm ~/.kde4/share/config/networkman*
    rm ~/.kde4/share/config/kwalletrc

    Now the configs and configfiles for networkmanager and kwallet have been removed.
    Hit Ctrl-Alt-F7 to return to the login screen
    Login and see: kwallet will come up at first networkconnection.
    The above procedure corrected the experienced problems on both openSUSE 11.3 and 11.4. This problem had not presented on openSUSE 12.1, perhaps as 12.1 is a recent install.

    The above procedure also corrected problem(s) noted in http://forums.opensuse.org/english/g...ml#post2418644
    .

    FWIW, I do not explicitly use KWallet, and several of these problems occurred after using a laptop in two airports as well as two hotels.
    Lap: Gateway NV79, i5-430, 4GB, 2 x 500GB HD, Intel GMA HD
    openSUSE Leap 15.0 x64 + 42.3 x64, KDE 5.15.3, Ubuntu 16.04 LTS, Windows 7

    Test:: openSUSE 15.0, KDE Plasma, Windows/XP/SP3 guest.

  6. #16
    Join Date
    Jun 2008
    Location
    Cambridge, UK
    Posts
    76

    Default Re: NetworkManager waiting for authorization

    I came across this thread having upgraded from 11.4 to 12.1 and had the same problem with the networkmanager plasmoid refusing to correct saying it needed authorisation, it didn't fire up the kdewallet (which I did manually and unlocked it).
    I happened to be doing the upgrade at a hotel with free wifi which didn't need encryption or logging in, so I was surprised it seemed to think it needed any kind of authorisation at all.

    Arriving at work, it did connect but only when I said the work guest wifi was a system connection and entered the WPA passphrase again.

    So, I will probably try deleted the kde network config files as suggested to see if it makes the problem go away.

    Since dropping kdenetworkmanager and going to plasmoid some versions ago, I have had a fair few problems, it wasn't until 11.4 that the plasmoid was really of release quality IMNSHO.
    --
    Cambridge geek, will code for gadgets

  7. #17
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Re: NetworkManager waiting for authorization

    I had something like this ever since upgrading to 12.1, network manager just never been as smooth as on 11.4 before. Taking long time to initiate, occasionally asking for password, and sometimes not finding my network at all until I disabled and reenabled wireless manually. Until today it was only mildly annoying.

    "Waiting for authorisation" problem popped up today and it killed it. Network manager is obviously asking for password but it hasn't fired the password prompt window and I have no idea how to get around it and no internet on that machine at all.

    I think it's a genuine bug and from googling around I see it has been filed and discussed, but how can I get my internet back in the meantime? I tried changing storing secrets to encrypted file, I clicked on wallet to start working, I changed it back again - I can't get past that authorization dialog that never pops up.

    Traditional with ifup asked to install "smpppd" or something, I clicked to ignore it since I can't install anything without internet and that package is for sending mail or something, shouldn't affect wireless, imo, anyway, "traditional" didn't work and I can't tell what was wrong with it because its status is not shown anywhere, I think it simply failed to initialize the network.

    Can anybody suggest any workaround? I was clicking like mad here and there, perhaps I missed something. Should I get the notebook to ethernet cable and install Gnome or Xfce until network manager is fixed? Or should I try the instructions for removing settings files given on a previous page? They are not related to this particular bug, are they?

    Is there a way to evoke authorization dialog manually or pass it the network password some other way?

    I am at wits end.

  8. #18
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,593
    Blog Entries
    38

    Default Re: NetworkManager waiting for authorization

    Quote Originally Posted by Stan_Ice View Post
    Is there a way to evoke authorization dialog manually or pass it the network password some other way?
    I think there is.

    Please take a look at post#4 in this thread http://forums.opensuse.org/forums/en...nt-router.html which may, or may not, be relevant.

  9. #19
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Re: NetworkManager waiting for authorization

    That doesn't work the same way on my system.

    I've never used "system connection" until this bug popped up and so never had successful connection this way. Files for wifi networks in /etc/NetworkManager/system-connections do not have any weird numbers, and password is stored in security section in form of psk=*password*

    Files in /.kde4/share/apps/networkmanagement/secrets/ have weird names but they are not random, if I delete/rename them they are regenerated with exact same name and inside they look perfectly okay. The original file for my connection had password stored correctly but what happens if I remove that file the newly generated file does not have password at al, no "psk=" line whatsoever, not even empty one. If I add it manually it doesn't change a thing as network manager doesn't seem to access this file when it deals with authentication.

    What happens is that network manager shows password prompt but doesn't write it in the "secrets" file and then fails on "waiting for authorization".

    Perhaps I should just make this network open for now.

    Personally I suspect the bug was introduced with some recent update to policy kits that handle this type of thing. Is there any way to roll back the updates? I don't even know which one.

  10. #20
    Join Date
    Mar 2009
    Location
    Bangkok
    Posts
    431

    Default Re: NetworkManager waiting for authorization

    Set my wifi as open on the router and got my internet back.

    I guess I can make it a bit more secure by disabling SSID broadcast, but how can I connect to it from network manager? Will it do it automatically? It seems to scan for available networks before connecting and on 12.1 I occasionally have to manually reenable wireless in order for my broadcast network to appear. What will happen if I hide it?

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •