Results 1 to 7 of 7

Thread: Change Default Fonts

  1. #1

    Question Change Default Fonts

    The main thing that bugs me about openSUSE is the fonts.
    Trivial I know!

    Compare the fonts in this screenshot of YaST
    http://users.telenet.be/photo-memori...-downgrade.png
    to this screenshot of Synaptic
    http://www.nongnu.org/synaptic/images/0.53-main.png

    (neither image is mine)

    Note how the YaST fonts are 'skinnier' and that the Synaptic fonts are slightly more proportional in height/width ratio.

    How do I change these system wide fonts?

    As a secondary question, does anyone know which fonts are in each of the screenshots above?

  2. #2
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Change Default Fonts

    I found this searching google how to change the YaST font:
    Random Thoughts: Change YaST2 Fonts

    This is assuming of course if you are using the QT (KDE) version of YaST and not the GTK (GNOME) version of YaST
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Change Default Fonts

    YaST uses Sans Serif 9pt by default in the QT version. Not sure about Synaptic
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  4. #4

    Default Re: Change Default Fonts

    Thanks for that.

    I'd always gone to the QT 4 Settings from the kickoff launcher.
    I should have realised that you had to run qtconfig as root to get it to change for things like YaST!
    I now have a nice looking YaST thanks to Droid Sans 9


    Sans Serif 9 was a bad choice of font IMHO. I hope it is not the default choice in 11.4!

  5. #5
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Change Default Fonts

    Quote Originally Posted by opticyclic View Post
    Thanks for that.

    I'd always gone to the QT 4 Settings from the kickoff launcher.
    I should have realised that you had to run qtconfig as root to get it to change for things like YaST!
    I now have a nice looking YaST thanks to Droid Sans 9


    Sans Serif 9 was a bad choice of font IMHO. I hope it is not the default choice in 11.4!
    Glad you managed to change your font
    Running 11.4 M3 on my netbook and so far the YaST font looks the same I will fire up the qtconfig utility to confirm
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  6. #6
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: Change Default Fonts

    I looked in qtconfig in 11.4 M3 and it is still Sans Serif 9 so it should still be the default choice in 11.4
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  7. #7
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Change Default Fonts

    I'd prefer:
    kdesu systemsettings
    over this Qt4 utility. Let's you change the appearance of GtK+ applications, in case you have the Gtk+ YaST, that are run as root too.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •